Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Zombie Plague 4.3

[ROZWIĄZANE] prosze o naprawienie/nowy kill_reward

zombie plague 4.3

  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Ossal

    Wszechwidzący

  • Użytkownik

Reputacja: 20
Życzliwy

  • Postów:263
  • GG:
  • Lokalizacja:Warszawa
Offline

Napisano 29.11.2012 00:07

nie wiem czy wszyscy wiedzą ale zp_kill_reward ma dosyć spory błąd.
mam na myśli ten tu:
http://amxx.pl/topic...on-kill-reward/

Jak wiadomo przed infekcją gracze są mniej wiecej po równo w ct i w tt (po infekcji przenosi żywych do ct a zombie do tt), i ten plugin właśnie na tym etapie sie gubi. Dostaje sie ammo paki tylko wtedy, gdy przed infekcją gracz zabijany (zombie) i gracz który zabija zombiaka byli w przeciwnych drużynach. proszę o poprawienie/napisanie pluginu który daje ap nie zależnie od bazowych drużyn (po prostu zabijesz zombie dostajesz 2 ap). Mam nadzieje że wyraziłem się jasno. z góry dzięki :)
  • +
  • -
  • 0

#2 Ossal

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 20
Życzliwy

  • Postów:263
  • GG:
  • Lokalizacja:Warszawa
Offline

Napisano 02.12.2012 19:30

nie wiem jak można zrobić taki błąd w pluginie i dać go do sieci:D wystarczyło wejść w sma i na pierwszy rzut oka widać tego woła:D trzeba zmienić:
if(kid != 0 && kid != vid && get_user_team(kid) != get_user_team(vid) && get_pcvar_num(reward_enable))
na taki:
if(kid != 0 && kid != vid && get_pcvar_num(reward_enable))

i wszystko śmiga jak należy:D
może komuś się to przyda //close
  • +
  • -
  • 0

#3 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 02.12.2012 20:26

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0

DarkGL to mój autorytet.






Również z jednym lub większą ilością słów kluczowych: zombie plague 4.3

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych