Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

Serwer nie może się połączyć z Mysql

gmamxbans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
35 odpowiedzi w tym temacie

#1 anved

    Pomocny

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 14.05.2012 20:52

Wgrywałem juz 2 wersje (amxbans 5.1b i dzisiaj gm 1.6.1) i nadal jest ten błąd, już sam nie wiem co zle daje, robiłem wszystko według instrukcji a nadal zle działa.


Wersja: Gm 1.6.1
Amxmodx: 1.8.1
dproto : ns/s v. 0.9.87
w zdalnym połączeniu dodałem "%".
Ręcznie też dodawałem server ale pisze, że niedostępny.
logi (tylko takie):
L 05/14/2012 - 21:22:25: [amxbans_main.amxx] [AMXBans] Connection failed!
L 05/14/2012 - 21:22:25: [amxbans_main.amxx] [AMXBans] Message: Can't connect to MySQL server on '188.xxx.218.xx' (110) (2003)
L 05/14/2012 - 21:22:25: [amxbans_main.amxx] [AMXBans] Query statement: SELECT `motd_delay` FROM `amx_serverinfo` WHERE address = '178.xx.106.69:xxxxx';

amxbans:
Spoiler


plugins.ini:
Spoiler


modules.ini:
Spoiler


sql.cfg
Spoiler


Męczę się już którąś godzinę z tym, proszę o pomoc.
  • +
  • -
  • 0

#2 Engi

    [EKSiD] playaz44

  • Power User

Reputacja: 236
Wszechwidzący

  • Postów:837
  • GG:
  • Imię:Seba
  • Lokalizacja:Gdańsk
Offline

Napisano 14.05.2012 20:56

W sql.cfg w hoscie nie podaje się żadnego adresu IP wpisz tam "localhost" albo nazwę strony np "blabla.xxx.pl" (<- oczywiście daj swoją nazwę strony to był przykład :D )

Użytkownik playaz44 edytował ten post 14.05.2012 20:58

  • +
  • -
  • 0

Użytkowniku! Zanim napiszesz wiadomość wiedz, że:
 

W odpowiedzi na ten status, przejrzałem kilka ostatnich Twoich postów i dodałem Ci kolejne 3 punkty ostrzeżeń. Mam nadzieję, że pomogłem.

1:0 dla Benia :D
I pamiętaj, na GG i Steam pomagam tylko odpłatnie. Mój numer GG to: 6746210, a nazwa na Steam to: playaz44


#3 Mr. Dziwny

    Wyrafinowany

  • Power User

Reputacja: 68
Pomocny

  • Postów:429
  • GG:
  • Imię:Marcin
  • Lokalizacja:Lębork
Offline

Napisano 14.05.2012 21:02

jezeli masz strone na xaa.pl to podaj nazwe swojego forum czyli tam :

www.nazwa-forum.xaa.pl

w pliku sql.cfg w miejsce hosta :)
  • +
  • -
  • 0

[ CS-Sfera.pl - Forum ogólnotematyczne ]

Sprzedam paczkę AMXX - COD MOD a la LOL (100k LVL):

IP serwera - 31.186.82.137:27106 (podgląd), pisać GG!
Kontakt:
GG: 46592283
E-mail: marcin@cs-sfera.pl


#4 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 14.05.2012 21:07

Kiedyś dawałem kod ip i działało. A co do .xaa.pl to próbowałem i też nie działa.
  • +
  • -
  • 0

#5 fejk

    Wszechpomocny

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:336
  • GG:
  • Lokalizacja:users.ini
Offline

Napisano 14.05.2012 21:11

jeżeli strone masz na .xaa.pl to w hoscie musi być strona.xaa.pl nie ma innej możliwości

<p><br></p><p>w zdalnym połączeniu dodałem "%".</p>


a weż podaj tam ip serwera bez portu

#6 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 14.05.2012 21:17

@up dawałem i tak. Dawałem samo %, samo ip serva bez portu, naraz % i ip serva. Nadal nie działa.
  • +
  • -
  • 0

#7 Engi

    [EKSiD] playaz44

  • Power User

Reputacja: 236
Wszechwidzący

  • Postów:837
  • GG:
  • Imię:Seba
  • Lokalizacja:Gdańsk
Offline

Napisano 14.05.2012 21:23

do hosta bazy wpisz "nazwa twojej strony .xaa.pl"
  • +
  • -
  • 0

Użytkowniku! Zanim napiszesz wiadomość wiedz, że:
 

W odpowiedzi na ten status, przejrzałem kilka ostatnich Twoich postów i dodałem Ci kolejne 3 punkty ostrzeżeń. Mam nadzieję, że pomogłem.

1:0 dla Benia :D
I pamiętaj, na GG i Steam pomagam tylko odpłatnie. Mój numer GG to: 6746210, a nazwa na Steam to: playaz44


#8 Rodzyn

    Wszechwiedzący

  • Power User

Reputacja: 140
Zaawansowany

  • Postów:560
  • GG:
  • Imię:Dawid
  • Lokalizacja:Bielawa
Offline

Napisano 14.05.2012 21:33

1. To jest na vps serwer czy wykupiony na np. Gamesol, Pukawka, Zabijaka, itd.
2.Jeżeli to na vps i to dodatku na vipower.pl to musisz napisać do supportu aby dodali ip twojej strony do firewall
3. Sprawdz czy w katalogu modules masz plik "mysql.so"
4. Z tego co pamiętam to amxmod 1.8.1 miał jakiś błąd w sql wiec radze zaktualizować go do 1.8.2
  • +
  • -
  • 0

#9 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 14.05.2012 21:42

1. Wykupiony na mojeserwery
2. patrz odp 1
3. Mam coś takiego mysql_amxx_i386.so
4. Zrobię to jutro, dzisiaj już nie mam czasu, chęci, siły, żeby to zrobić.
  • +
  • -
  • 0

#10 LokalnyHost

    Profesjonalista

  • Użytkownik

Reputacja: 39
Życzliwy

  • Postów:213
  • Imię:Bedoka
  • Lokalizacja:Opole
Offline

Napisano 14.05.2012 22:02

1. Zmień hosta na adres twojej strony
2. Dopisz bo amxbans_main debug, nie konieczne ale z przyzwyczajenia ^^
3. Po zmianie tych plików daj logi.
  • +
  • -
  • 0

#11 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 15.05.2012 12:44

// AMXBans próbuje pobierać Ip automatycznie (Tak, widać ;/)
// Możesz ustawić inne iP -np. ":"
amxbans_server_address ""

wpisz ip swojego serwera (gry)
  • +
  • -
  • 0

DarkGL to mój autorytet.


#12 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 15.05.2012 15:19

@up dałem tak:
// AMXBans próbuje pobierać Ip automatycznie (Tak, widać ;/)
// Możesz ustawić inne iP -np. "<ip>:<port>"
amxbans_server_address "xxx.xx.xxx.xx:xxxxx"
I nie działa. Wgrałem również amx 1.8.2, próbowałem na zmianę dawać ip i .xaa.pl do sql.cfg, nic nie pomogło.
  • +
  • -
  • 0

#13 Universal

    Pomocny

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:44
  • Lokalizacja:Kg
Offline

Napisano 15.05.2012 18:14

tu wpisz ip swojego serwera a w hoście w sql.cfg wpisz nazwastrony.xaa.pl - bez www. ;)
  • +
  • -
  • 0
Posiadam unikalne pluginy do base builder oraz przerabiam z ZM na BB, gg : 6645288 ;)

#14 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 15.05.2012 18:23

Pisałem szybciej, że tak robiłem :facepalm:
  • +
  • -
  • 0

#15 fejk

    Wszechpomocny

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:336
  • GG:
  • Lokalizacja:users.ini
Offline

Napisano 15.05.2012 18:59

no to zrób tak w sql.cfg w nazwie hosta daj adres swojej strony.xaa.pl i wtedy pokaż logi, bo jeżeli tak robiłeś to czemu logi są:

'188.xxx.218.xx'
że nie może się połączyć?

#16 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 15.05.2012 19:28

@up dałem log ja miałem podane ip. a różnica między logiem z ip a logiem z .xaa.pl jest tylko taka
ip:
L 05/14/2012 - 21:22:25: [amxbans_main.amxx] [AMXBans] Message: Can't connect to MySQL server on '188.xxx.218.xx' (110) (2003)
xaa.pl:
L 05/15/2012 - 20:01:20: [amxbans_main.amxx] [AMXBans] Message: Can't connect to MySQL server on 'cs-xzy123.xaa.pl' (110) (2003)
  • +
  • -
  • 0

#17 Pro-Skill

    Pomocny

  • Użytkownik

Reputacja: 11
Początkujący

  • Postów:55
  • Lokalizacja:Polska
Offline

Napisano 15.05.2012 20:13

Po tylu próbach powinno zadziałać. Dodaj ip serwera bez portu do bazy danych
  • +
  • -
  • 0

#18 anved

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:44
  • Lokalizacja:pomorze
Offline

Napisano 15.05.2012 20:23

Mam cały czas dodane. A to może być przez np. domenę? Bo mam domenę kupioną (na xaa.pl kupiłem).
  • +
  • -
  • 0

#19 fejk

    Wszechpomocny

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:336
  • GG:
  • Lokalizacja:users.ini
Offline

Napisano 15.05.2012 20:35

nie nie szukaj dziury w całym, ja mam .xaa.pl i mam domene.pl i wszystko działa pięknie.

#20 Engi

    [EKSiD] playaz44

  • Power User

Reputacja: 236
Wszechwidzący

  • Postów:837
  • GG:
  • Imię:Seba
  • Lokalizacja:Gdańsk
Offline

Napisano 15.05.2012 20:46

A w amxbans.cfg podałeś taki sam prefiks jak przy instalacji amxbans?
  • +
  • -
  • 0

Użytkowniku! Zanim napiszesz wiadomość wiedz, że:
 

W odpowiedzi na ten status, przejrzałem kilka ostatnich Twoich postów i dodałem Ci kolejne 3 punkty ostrzeżeń. Mam nadzieję, że pomogłem.

1:0 dla Benia :D
I pamiętaj, na GG i Steam pomagam tylko odpłatnie. Mój numer GG to: 6746210, a nazwa na Steam to: playaz44






Również z jednym lub większą ilością słów kluczowych: gmamxbans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych