Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z roundsound`em

roundsound

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
Brak odpowiedzi do tego tematu

#1 Skejcik

    Nowy

  • Pijawka

Reputacja: 0
zer0.

  • Postów:1
  • Lokalizacja:Wrocław
Offline

Napisano 02.11.2011 18:54

Mój problem jest taki.
Wbijam na swój serwer i podkoniec rundy muza leci ale nie zawsze np.2rundy leci , 3runda juz nie lieci , 4 znowu leci . muzyka odtwarzana jest losowo nie bierze pod uwage tego ze przydzielilem osobne do ct i tt ? proszę pomózcie rozwiazac mi ten problem.
tu macie roundsound.sma Dobrze zrobilem ?

RoundSound.sma

#include <amxmodx>

public plugin_init()
{
register_plugin("RoundSound","1.0","PaintLancer")
register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
new rand = random_num(0,4)

client_cmd(0,"mp3 stop")

switch(rand)
{
case 0: client_cmd(0,"mp3 loop/ssgroup")
case 1: client_cmd(0,"mp3 loop/ssgroup1")
case 2: client_cmd(0,"mp3 loop/ssgroup2")
case 3: client_cmd(0,"mp3 loop/ssgroup3")
case 4: client_cmd(0,"mp3 loop/ssgroup4")
}

return PLUGIN_HANDLED
}

public ct_win()
{
new rand = random_num(0,4)

client_cmd(0,"mp3 stop")

switch(rand)
{
case 0: client_cmd(0,"mp3 loop/ssgroup5")
case 1: client_cmd(0,"mp3 loop/ssgroup6")
case 2: client_cmd(0,"mp3 loop/ssgroup7")
case 3: client_cmd(0,"mp3 loop/ssgroup8")
case 4: client_cmd(0,"mp3 loop/ssgroup9")
}

return PLUGIN_HANDLED
}

public plugin_precache()
{
precache_sound("misc/ssgroup.mp3")
precache_sound("misc/ssgroup1.mp3")
precache_sound("misc/ssgroup2.mp3")
precache_sound("misc/ssgroup3.mp3")
precache_sound("misc/ssgroup4.mp3")
precache_sound("misc/ssgroup5.mp3")
precache_sound("misc/ssgroup6.mp3")
precache_sound("misc/ssgroup7.mp3")
precache_sound("misc/ssgroup8.mp3")
precache_sound("misc/ssgroup9.mp3")

return PLUGIN_CONTINUE
}


RoundSound.ini

; CT Sounds
"sound/misc/ssgroup5.mp3" "CT"
"sound/misc/ssgroup6.mp3" "CT"
"sound/misc/ssgroup7.mp3" "CT"
"sound/misc/ssgroup8.mp3" "CT"
"sound/misc/ssgroup9.mp3" "CT"

; T Sounds
"sound/misc/ssgroup.mp3" "T"
"sound/misc/ssgroup1.mp3" "T"
"sound/misc/ssgroup2.mp3" "T"
"sound/misc/ssgroup3.mp3" "T"
"sound/misc/ssgroup4.mp3" "T"


Muze mam w sound/misc

Błagam pomocy :(
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: roundsound

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych