Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

Problem z amxbans - strona nie łączy się z bazą mysqlamxbans 1.6

gmamxbans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
14 odpowiedzi w tym temacie

#1 NEQU#

    Wszechwidzący

  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 15.08.2015 11:37

Witam, mój problem polega na tym, iż strona nie łączy się z bazą mysql. Na serwerze działają admini, bany też dalej działają, jednak nie można ich wyświetlić. Dodam też że wczoraj wszystko działało. Proszę o szybką pomoc.

 

amxbansproblem.jpg

 

 

 


Użytkownik NEQU# edytował ten post 15.08.2015 11:40

  • +
  • -
  • 1
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#2 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 15.08.2015 13:20

Nie mogę edytować 1 posta.

 

Po reinstalacji bansa na nowej bazie danych wyskakuje ten sam błąd. Problem występuje od rana, wczoraj wszystko działało.


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#3 oeN.

    Wszechwidzący

  • Użytkownik

Reputacja: 78
Zaawansowany

  • Postów:274
  • Lokalizacja:Dom
Offline

Napisano 15.08.2015 13:53

127.0.0.1 zamień na localhost


  • +
  • -
  • 0

#4 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 15.08.2015 15:33

db.config.inc.php

 

    $config->db_host = "localhost";
    $config->db_user = "alkoskil_amxbans";
    $config->db_pass = "moje haslo";
    $config->db_db = "alkoskil_amxbans";
    $config->db_prefix = "amx";

 

Podczas instalacji i tak trzeba wybrać host bazy: localhost, bo inaczej nie będzie się dało zainstalować.

Mój hosting - mintshost

Dodanie % też nie przynosi efektów.

 

amxbans stąd http://amxx.pl/topic...oprawki-amxxpl/


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#5 oeN.

    Wszechwidzący

  • Użytkownik

Reputacja: 78
Zaawansowany

  • Postów:274
  • Lokalizacja:Dom
Offline

Napisano 15.08.2015 15:40

Zamień localhost na IP zewnętrzne, u Ciebie to 193.17.184.51


  • +
  • -
  • 0

#6 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 15.08.2015 15:43

Can't connect to MySQL server on '193.17.184.51' (111)

 

;s


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#7 Tymek1996

    Nowy

  • Pijawka

Reputacja: 0
zer0.

  • Postów:1
  • Imię:Szymon
  • Lokalizacja:Z daleka
Offline

Napisano 16.08.2015 08:42

Podpinam się pod ten temat. Posiadam ten sam problem. AMXBANS wczoraj to południa normalnie działał, a po południu ten sam błąd proszę o pomoc.


  • +
  • -
  • 0

#8 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 16.08.2015 13:49

refresh


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#9 ex0

    Wolny strzelec.

  • Power User

Reputacja: 377
Wszechpomocny

  • Postów:1124
  • GG:
  • Imię:Kacper
  • Lokalizacja:Żywiec
Offline

Napisano 16.08.2015 14:56

Nie oszukujmy się ale zero podstawowej wiedzy i skorzystania z instrukcji jaka znajduje się na amxx

Zaczynając od początku:

 

 

127.0.0.1 zamień na localhost

Co za róznica? 127.0.0.1 to właśnie localhost, bez względu czy to IP, czy dedykowana nazwa. 

 

 

db.config.inc.php

 

    $config->db_host = "localhost";
    $config->db_user = "alkoskil_amxbans";
    $config->db_pass = "moje haslo";
    $config->db_db = "alkoskil_amxbans";
    $config->db_prefix = "amx";

 

Podczas instalacji i tak trzeba wybrać host bazy: localhost, bo inaczej nie będzie się dało zainstalować.

Mój hosting - mintshost

Dodanie % też nie przynosi efektów.

 

amxbans stąd http://amxx.pl/topic...oprawki-amxxpl/

Zamiast locala używasz IP strony, które masz przypisane do domeny.

 

 

Can't connect to MySQL server on '193.17.184.51' (111)

 

;s

Nie może połączyć ponieważ nie nadałeś w CP możliwości łączenia się tego adresu IP z Bazą dlatego baza blokuje to połączenie.
Dodajesz albo do zdalnego połączenia to IP, albo dodajesz % i masz możliwość łączenia się każdego IP do którego przypiszesz te bazę.


  • +
  • -
  • 1

TWORZENIE FOR SPOŁECZNOŚCIOWYCH | ZARZĄDZANIE STRONAMI INTERNETOWYMI
WSPARCIE TECHNICZNE SERWERÓW HLDS | MODERNIZACJA, OPTYMALIZACJA, ZABEZPIECZENIA


Zapraszam do mojego profilu ;)


#10 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 16.08.2015 15:12

Nie oszukujmy się ale zero podstawowej wiedzy i skorzystania z instrukcji jaka znajduje się na amxx

Zaczynając od początku:

 

 

127.0.0.1 zamień na localhost

Co za róznica? 127.0.0.1 to właśnie localhost, bez względu czy to IP, czy dedykowana nazwa. 

 

 

db.config.inc.php

 

    $config->db_host = "localhost";
    $config->db_user = "alkoskil_amxbans";
    $config->db_pass = "moje haslo";
    $config->db_db = "alkoskil_amxbans";
    $config->db_prefix = "amx";

 

Podczas instalacji i tak trzeba wybrać host bazy: localhost, bo inaczej nie będzie się dało zainstalować.

Mój hosting - mintshost

Dodanie % też nie przynosi efektów.

 

amxbans stąd http://amxx.pl/topic...oprawki-amxxpl/

Zamiast locala używasz IP strony, które masz przypisane do domeny.

 

 

Can't connect to MySQL server on '193.17.184.51' (111)

 

;s

Nie może połączyć ponieważ nie nadałeś w CP możliwości łączenia się tego adresu IP z Bazą dlatego baza blokuje to połączenie.
Dodajesz albo do zdalnego połączenia to IP, albo dodajesz % i masz możliwość łączenia się każdego IP do którego przypiszesz te bazę.

Czy ty w ogóle czytałeś 1 post ? przez pare dni działało normalnie, dopiero od wczoraj nie łączy się z baza mysql, dodatkowo napisałem też że amxbans normalnie działa, na serwerze jak i ban lista, jedynie nie można jej odczytać z powodu problemów z połączeniem między forum a bazą danych która znajduje się na tym samym hoscie.

 

edit. Jeszcze raz dodam !!! SERWER  ŁĄCZY SIĘ Z BANSEM, a gracze zbanowani nadal nie mogą grać !!


Użytkownik NEQU# edytował ten post 16.08.2015 15:14

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#11 ex0

    Wolny strzelec.

  • Power User

Reputacja: 377
Wszechpomocny

  • Postów:1124
  • GG:
  • Imię:Kacper
  • Lokalizacja:Żywiec
Offline

Napisano 16.08.2015 15:15

Czytać czytałem, to że działało nie znaczy, że wszystko jest dobrze. 
 

- Dygresja dot. tematu

Mnie osobiście też IP.B działało przez kilka dni, a po kilku dniach wystąpił problem z bazą danych bo okazało się, że podczas instalacji był jakiś problem :)

- koniec dygresji. 

Wracając do tematu. 
Skoro AmxBans działa poprawnie, są to jakieś dziwaczne problemy wynikające bardziej ze strony usługodawcy aniżeli konfiguracji strony. 
Natomiast ja bym mimo wszystko sprawdził wszystkie dostępne połączenia jakie są wykonywane i sprawdzić dlaczego baza się nie łączy przez choćby debug.


  • +
  • -
  • 0

TWORZENIE FOR SPOŁECZNOŚCIOWYCH | ZARZĄDZANIE STRONAMI INTERNETOWYMI
WSPARCIE TECHNICZNE SERWERÓW HLDS | MODERNIZACJA, OPTYMALIZACJA, ZABEZPIECZENIA


Zapraszam do mojego profilu ;)


#12 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 16.08.2015 15:20

Czytać czytałem, to że działało nie znaczy, że wszystko jest dobrze. 
 

- Dygresja dot. tematu

Mnie osobiście też IP.B działało przez kilka dni, a po kilku dniach wystąpił problem z bazą danych bo okazało się, że podczas instalacji był jakiś problem :)

- koniec dygresji. 

Wracając do tematu. 
Skoro AmxBans działa poprawnie, są to jakieś dziwaczne problemy wynikające bardziej ze strony usługodawcy aniżeli konfiguracji strony. 
Natomiast ja bym mimo wszystko sprawdził wszystkie dostępne połączenia jakie są wykonywane i sprawdzić dlaczego baza się nie łączy przez choćby debug.

debug po stronie forum ? how?

 

Próbowałem też przeinstalować całego bansa, na nowej bazie danych. Wszystko przebiegło normalnie, jednak już na samym początku wystąpił dokładnie ten sam błąd, więc wróciłem do tej na której są zapisane bany.

 

 

//Kolejna próba ;)
    $config->document_root = "/amxbans";
    $config->path_root = "/home/alkoskil/domains/alkoskill.pl/public_html/amxbans";
    
    $config->db_host = "193.17.184.51";
    $config->db_user = "alkoskil_bany";
    $config->db_pass = "haslo";
    $config->db_db = "alkoskil_bany";
    $config->db_prefix = "amx";

bankfotek.pl/image/1924774

 

I ciągle to samo.

 


Użytkownik NEQU# edytował ten post 16.08.2015 15:26

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#13 ex0

    Wolny strzelec.

  • Power User

Reputacja: 377
Wszechpomocny

  • Postów:1124
  • GG:
  • Imię:Kacper
  • Lokalizacja:Żywiec
Offline

Napisano 16.08.2015 15:29

Proserwer? 

Ogólnie próbowałeś nadać zamiast adresu IP pod względem miejsca na wpisanie hosta nazwę domeny? 

Lub nazwę subdomeny, na której znajduje się bans? 

Chmody masz nadane na pliki?
Chociażby te główne configu. 


  • +
  • -
  • 0

TWORZENIE FOR SPOŁECZNOŚCIOWYCH | ZARZĄDZANIE STRONAMI INTERNETOWYMI
WSPARCIE TECHNICZNE SERWERÓW HLDS | MODERNIZACJA, OPTYMALIZACJA, ZABEZPIECZENIA


Zapraszam do mojego profilu ;)


#14 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 16.08.2015 15:38

include/smarty/templates_c/

include/

chmody 777

 

hosting mintshost.

Dodałem nazwe forum i subdomeny i pojawia się ip 193.17.184.51

 

Nie wiem o co biega.. :D


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png

#15 NEQU#

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:239
  • Lokalizacja:Just-Frags.eu
Offline

Napisano 16.08.2015 21:39

Napisałem do mintshost i podali mi alternatywny adres ip, wszystko zaczęło działać. Zamek. ;)))


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png
b_350_20_FFAD41_E98100_000000_591F11.png





Również z jednym lub większą ilością słów kluczowych: gmamxbans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych