Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Zombie Plague 4.3

[ZP4.3][Problem] Edycja cfg i pluginu.

zombie plague 4.3

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 DJZgon

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Imię:Adek
  • Lokalizacja:Polska
Offline

Napisano 20.07.2013 17:11

Witam wszystkich serdecznie.

 

Tworzę serwer pod ZP4.3 i mam na razie 2 problemy ,których nie umiem sam rozwiązać.

 

Mianowicie:

 

1. Ustawiłem w zp.cfg

 

zp_surv_weapon "weapon_m4a1" // Survivor's weapon (given by default)

Dzięki temu bronią ,która surivor zyskuje jest M4A1.

Problem polega na tym ,że teraz chcę zmienić model tej broni.

W tym celu w pliku zp.ini wprowadziłem taką zmianę:

V_M249 SURVIVOR = models/zombie_plague/v_m4a1.mdl

Wynik? Not working. Wyraźnie widać ,że podać trzeba model v_m249 ,ale zmieniłem tę broń na m4a1 i chcę także dać inny model ,niż podstawowy m4-ki. Próbowałem zmienić ten kod na V_M4A1 SURVIVOR = models/zombie_plague/v_m4a1.mdl ,lecz to jak mogłem się spodziewać nic nie dało ,bo kod pluginu jest inny.

 

Tutaj pytanie: Jak to zrobić ,by działało ,lub jeśli trzeba edytować zombieplague40 (głowny plugin) ,to w którym miejscu?

Przejrzałem kilka razy *.sma i nie umiem tego zrobić ,wywalało błąd przy kompilacji ,lub nie umiałem znaleźć odpowiedzialnej części kodu.

Proszę o pomoc.

 

2. Chciałbym także CAŁKOWICIE wyłączyć system klas zombie z pluginu. Chciałbym usunąć napis "klasa: "tutajklasazombie" z dolnego lewego rogu podczas gry. Nie chcę także tej opcji w menu zombie gracza.

 

W tym celu edytowałem plugin ,lecz tak jak poprzednio - nie umiem znaleźć odpowiedzialnej ścieżki ,lub raczej ścieżek ,bo jeśli coś zmieniłem to gdzie indziej było to dalej i compilacja nie udawała się.

 

Proszę serdecznie o pomoc w uporaniu się z tymi problemami.
Sam nie umiem sobie poradzić i mam nadzieję ,że mądrzejsze osoby pomogą mi w rozwiązaniu moich problemów.

 

Pozdrawiam,

DJZgon.


  • +
  • -
  • 0

#2 ZyciE

    Banned

  • Zbanowany

Reputacja: 30
Życzliwy

  • Postów:225
  • GG:
  • Imię:Mateusz
  • Lokalizacja:Wiąg
Offline

Napisano 20.07.2013 22:45

Jedyne wyjście to użyć  programu który podmienię standardową broń  na twoje wybraną ale przez to każdy bd miał inny wygląd  nie tylko surv


Play-Gaming.pl - Sieć  Serwerów  Gier.

Zapraszamy na nasze serwery : 

MineCraft - S1.E4G.MAXC.PL

Zombie Mod v3 [Otwarcie sobota] - 31.186.84.46:27050

Cod Mod  201 lvl -  193.33.177.117:27081


#3 DJZgon

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Imię:Adek
  • Lokalizacja:Polska
Offline

Napisano 21.07.2013 00:42

Powyższy post uważam za bezsensowne nabicie posta i stratę czasu. Masz użytkowniku pojęcie o tym co piszesz? Na przyszłość polecam czytanie tematów ze zrozumieniem ,a także o ,zaznaczam - mądre wypowiedzi.

Mały update:
-z problemem usunięcia klas z moda się uporałem (zrobiłem rzecz trudniejszą od prostszej ,której na rawie nie poprawiłem ,lol)

Ponawiam prośbę - proszę ,aby ktoś podał mi przyczynę tego ,bez wątpienia bug'a ,lub część kodu odpowiedzialną za to ,tak bym mógł zmienić to ręcznie.

Pozdrawiam,
DJZgon.
  • +
  • -
  • 0

#4 DJZgon

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Imię:Adek
  • Lokalizacja:Polska
Offline

Napisano 21.07.2013 11:58

@UP

@EDIT

 

Uporałem się z problemami ,ale mam nowy. Mianowicie menu extra itemów.

Gdy dodam więcej niż 7 ,nie tworzy się ich druga strona ,tylko po prostu jest cały czas jedna strona i więcej itemów niż 7 się nie pojawia.

Umie ktoś to naprawić? Bo tego już naprawdę sam nie dam rady zrobić...


  • +
  • -
  • 0

#5 DJZgon

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Imię:Adek
  • Lokalizacja:Polska
Offline

Napisano 21.07.2013 13:34

Wychodzi na to ,że wszystkie problemy rozwiązałem sam. Dziękuję za nie zwrócenie uwagi na temat. Dobranoc.


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: zombie plague 4.3

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych