Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

speed zombie


  • Zamknięty Temat jest zamknięty
14 odpowiedzi w tym temacie

#1 PKNCK

    Życzliwy

  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 26.05.2012 16:39

Otóż mam problem z klasami zombie a dokładniej z ich speed i odrzutem(np: jak strzelimy w zombie)
W cvar mam ustawiony max speed 9999 (nawet ustawiałem 99999) ale jak daje zombie speed np: 1200 to porusza się tak samo jak zombie co ma 240 speed..tak samo mam z odrzutem a mianowicie nie ma odrzutu jak trafimy np: z pompy to zombie w ogóle się nie odsuwa (nie odrzuca go)
W logach serva i w consoli nie ma żadnych błędów (errorow) itp
Przykładowa klasa:

/*================================================================================
	
	-----------------------------------
	-*- [ZP] ... Zombie Classes -*-
	-----------------------------------
	
	~~~~~~~~~~~~~~~
	- Description -
	~~~~~~~~~~~~~~~
	
	
================================================================================*/

#include <amxmodx>
#include <fakemeta>
#include <zombieplague>

// Raptor Zombie Attributes
new const zclass1_name[] = { "Raptor Zombie" }
new const zclass1_info[] = { "Szybki" }
new const zclass1_model[] = { "Bichi_frk_14" }
new const zclass1_clawmodel[] = { "v_Bichi_frk_14.mdl" }
const zclass1_health = 2400
const zclass1_speed = 1200
const Float:zclass1_gravity = 0.9
const Float:zclass1_knockback = 2.0
const zclass1_infecthp = 10 // extra hp for infections

// Class IDs
new g_zclass_leech

// Zombie Classes MUST be registered on plugin_precache
public plugin_precache()
{
	register_plugin("[ZP] ... Zombie Classes", "1.4a", "www.....pl")
	
	// Register the new class and store ID for reference
	g_zclass_leech = zp_register_zombie_class(zclass1_name, zclass1_info, zclass1_model, zclass1_clawmodel, zclass1_health, zclass1_speed, zclass1_gravity, zclass1_knockback)
}

// User Infected forward
public zp_user_infected_post(id, infector)
{
	// If attacker is a leech zombie, gets extra hp
	if (zp_get_user_zombie_class(infector) == g_zclass_leech)
		set_pev(infector, pev_health, float(pev(infector, pev_health) + zclass1_infecthp))
}

  • +
  • -
  • 0

#2 Play4Fun

    Zaawansowany

  • Użytkownik

Reputacja: 15
Początkujący

  • Postów:86
  • GG:
  • Imię:Dawid
  • Lokalizacja:Lublin
Offline

Napisano 26.05.2012 16:43

Daj całe .sma bądź wszystkie zmienne odpowiadające za speed i odrzut :)
Tak nikt nic nie zrobi.
  • +
  • -
  • 0

#3 PKNCK

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 26.05.2012 17:55

na każdą klase mam oddzielny plugin (bo jak dodałem klasy vip to zpa_classes40 mi nie czytało wiec oddzielnie zrobiłem każda klase)
w temacie masz 1 z klas
w cvarach mam ustawione:
sv_maxspeed 99999

Użytkownik PKNCK edytował ten post 26.05.2012 18:07

  • +
  • -
  • 0

#4 Play4Fun

    Zaawansowany

  • Użytkownik

Reputacja: 15
Początkujący

  • Postów:86
  • GG:
  • Imię:Dawid
  • Lokalizacja:Lublin
Offline

Napisano 26.05.2012 18:03

Jedynie co to może po prostu cvary ustaw prawidłowo :)
Bo w kodzie nie widzę błędów.

Najlepiej jak byś zrobił wszystkie klasy w jednym modzie :)
  • +
  • -
  • 0

#5 PKNCK

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 26.05.2012 18:10

nie wiem czy to mozliwe bo ja dopiero od niedawna sie w tym bawie jesli chodzi o pluginy (umiem co nieco zmienic zedytowac itp) ale polaczyc to bym chyba nie umial xD(zaduzo klas a kazdy blad spowoduje ze caly plugin nie bedzie dzialal ;P)
a cvar mam dobrze ustawiony:
sv_maxspeed 99999
na odrzut to chyba nie ma cvaru tylko sie w klasie zmienia ale lipa ;/

Użytkownik PKNCK edytował ten post 26.05.2012 18:17

  • +
  • -
  • 0

#6 PKNCK

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 27.05.2012 14:47

@edit
Z odrzutem udało mi się naprawić
Ale speed nadal lipa
Pomoże ktoś?
  • +
  • -
  • 0

#7 ::Gogiel::

    Zaawansowany

  • Użytkownik

Reputacja: 18
Początkujący

  • Postów:77
  • GG:
  • Imię:Hm... xD Patryk xD
  • Lokalizacja:Bydgoszcz
Offline

Napisano 27.05.2012 16:27

WItaj PKNCK :D

Dodaj do plugin init

server_cmd("sv_maxspeed 1500")
zamiast 1500 daj swoją wartość :)

i w Postaci dopis zmoze na takiej zasadzie

set_user_maxspeed(id,500.0)

zamiast 500.0 daj całkowitą liczbę wraz z "kropką" i zerem np 999.0

Na moje powinno zadziałać :)
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika
Dołączona grafika
SERWER SA:MP 194.28.50.14:25064
Zapraszamy Do Gry http://cs-pobojowisko.eu

#8 PKNCK

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 28.05.2012 05:39

Mogbys to po polsku? jak dodaje np: set_user_maxspeed(id,1200.0) (do klasy zombie) to nie da sie skompilowac
a to server_cmd("sv_maxspeed 1500") dodac do plugins.ini?

Użytkownik PKNCK edytował ten post 28.05.2012 05:44

  • +
  • -
  • 0

#9 action

    Życzliwy

  • Zbanowany

Reputacja: 6
Nowy

  • Postów:29
  • Lokalizacja:polska
Offline

Napisano 28.05.2012 12:37

zainstaluj plugin, zmień mapę, i w zp_zombieclasses.ini pojawi się zapis na końcu:

[Raptor Zombie]
NAME = Szybki
INFO = \r[Szybkosc]
MODELS = zombie_source
CLAWMODEL = v_knife_zombie.mdl
HEALTH = 900
SPEED = 225
GRAVITY = 1.00
KNOCKBACK = 1.49

(to moja klasa)

i tu możesz sobie ustawić parametry

Użytkownik action edytował ten post 28.05.2012 12:38


#10 PKNCK

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 28.05.2012 14:59

jak zmienie parametr to na nowo sie zaladuje klasa z pluginu...
Pozatym co mi to da? nie wazne czy ustawie 240 czy 1000.. biega tak samo
HELP!!
Gogiel przetlumacz to co napisales ;P

Użytkownik PKNCK edytował ten post 28.05.2012 14:59

  • +
  • -
  • 0

#11 ::Gogiel::

    Zaawansowany

  • Użytkownik

Reputacja: 18
Początkujący

  • Postów:77
  • GG:
  • Imię:Hm... xD Patryk xD
  • Lokalizacja:Bydgoszcz
Offline

Napisano 30.05.2012 00:08

/*================================================================================

-----------------------------------
-*- [ZP] ... Zombie Classes -*-
-----------------------------------

~~~~~~~~~~~~~~~
- Description -
~~~~~~~~~~~~~~~


================================================================================*/

#include <amxmodx>
#include <fakemeta>
#include <zombieplague>
#include <fun>


// Raptor Zombie Attributes
new const zclass1_name[] = { "Raptor Zombie" }
new const zclass1_info[] = { "Szybki" }
new const zclass1_model[] = { "Bichi_frk_14" }
new const zclass1_clawmodel[] = { "v_Bichi_frk_14.mdl" }
const zclass1_health = 2400
const zclass1_speed = 1200
const Float:zclass1_gravity = 0.9
const Float:zclass1_knockback = 2.0
const zclass1_infecthp = 10 // extra hp for infections

// Class IDs
new g_zclass_leech

// Zombie Classes MUST be registered on plugin_precache
public plugin_init()
{
register_plugin[color=#008000]([/color][color=#FF0000]"Klasa Zmobie[color=#000099][b]"[/b][/color], [color=#000099][b]"v[/b][/color]1.0[color=#000099][b]"[/b][/color], [color=#000099][b]"PKNCK[/b][/color][color=#000099][b]"[/b][/color])[/color]
g_zclass_leech = zp_register_zombie_class(zclass1_name, zclass1_info, zclass1_model, zclass1_clawmodel, zclass1_health, zclass1_speed, zclass1_gravity, zclass1_knockback)
server_cmd("sv_maxspeed 1500") ///zamiast 1500 dajesz ile chcesz :D
}
public plugin_precache()
{

// Register the new class and store ID for reference
/// ja to bym przeniósł do plugin init :D g_zclass_leech = zp_register_zombie_class(zclass1_name, zclass1_info, zclass1_model, zclass1_clawmodel, zclass1_health, zclass1_speed, zclass1_gravity, zclass1_knockback)
}

// User Infected forward
public zp_user_infected_post(id, infector)
{
// If attacker is a leech zombie, gets extra hp
if (zp_get_user_zombie_class(infector) == g_zclass_leech)
set_pev(infector, pev_health, float(pev(infector, pev_health) + zclass1_infecthp))
set_user_maxspeed(id,1200.0) //jak wywali function asumed zero lub wxpresion has no effect znaczy że trzeba wywalić zdefiniowana szybkośc orzy zclass1speed :D
}


Wszelkie adnotacje masz w kodzie zdefiniowałem moduł fun bo wymagany jest do ustawiania szybkości o ile sie nie mylę :D

Możesz również srpóbować z tym
fm_set_user_maxspeed( index, Float:speed = -1.0 )

zamiast 1.0 dajesz warotość wyższą aby przyspieszyć postać :D

I nie zapomnij dodac :D


#include <fakemeta_util>

Użytkownik ::Gogiel:: edytował ten post 30.05.2012 00:08

  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika
Dołączona grafika
SERWER SA:MP 194.28.50.14:25064
Zapraszamy Do Gry http://cs-pobojowisko.eu

#12 PKNCK

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:24
  • Lokalizacja:Krakow
Offline

Napisano 30.05.2012 05:44

/*================================================================================
				
				-----------------------------------
				-*- [ZP] ... Zombie Classes -*-
				-----------------------------------
				
				~~~~~~~~~~~~~~~
				- Description -
				~~~~~~~~~~~~~~~
				
				
================================================================================*/

#include <amxmodx>
#include <fakemeta>
#include <zombieplague>
#include <fun>


// Raptor Zombie Attributes
new const zclass1_name[] = { "Raptor Zombie" }
new const zclass1_info[] = { "Szybki" }
new const zclass1_model[] = { "Bichi_frk_14" }
new const zclass1_clawmodel[] = { "v_Bichi_frk_14.mdl" }
const zclass1_health = 2400
const zclass1_speed = 1200
const Float:zclass1_gravity = 0.9
const Float:zclass1_knockback = 2.0
const zclass1_infecthp = 10 // extra hp for infections

// Class IDs
new g_zclass_leech

// Zombie Classes MUST be registered on plugin_precache
public plugin_init()
{		
				register_plugin("[ZP] PKNCK Zombie Classes", "1.4a", "www.cs-wysypisko.pl")
				 g_zclass_leech = zp_register_zombie_class(zclass1_name, zclass1_info, zclass1_model, zclass1_clawmodel, zclass1_health, zclass1_speed, zclass1_gravity, zclass1_knockback)
				server_cmd("sv_maxspeed 1200")
}

// User Infected forward
public zp_user_infected_post(id, infector)
{
				// If attacker is a leech zombie, gets extra hp
				if (zp_get_user_zombie_class(infector) == g_zclass_leech)
								set_pev(infector, pev_health, float(pev(infector, pev_health) + zclass1_infecthp))
								set_user_maxspeed(id,1200.0)
}

Wywala mi błąd

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright © 1997-2006 ITB CompuPhase, AMX Mod X Team

zp_zombie_raptorPoprawka.sma(38) : warning 217: loose indentation
zp_zombie_raptorPoprawka.sma(39) : warning 217: loose indentation
zp_zombie_raptorPoprawka.sma(48) : warning 217: loose indentation
Header size: 372 bytes
Code size: 472 bytes
Data size: 488 bytes
Stack/heap size: 16384 bytes; estimated max. usage=42 cells (168 bytes)
Total requirements: 17716 bytes

3 Warnings.
Done.

Niby da się pobrać ale i tak nie działa speed

Mógłbyś podać ten sposób co UP gotowy? bo ja niestety nie znam się na podstawach (dopiero w 2klasie będą nas uczyć podstaw) co nie co umiem zrobić na logike xD

Użytkownik PKNCK edytował ten post 30.05.2012 05:57

  • +
  • -
  • 0

#13 ::Gogiel::

    Zaawansowany

  • Użytkownik

Reputacja: 18
Początkujący

  • Postów:77
  • GG:
  • Imię:Hm... xD Patryk xD
  • Lokalizacja:Bydgoszcz
Offline

Napisano 01.06.2012 00:02

To nie jest żaden błąd popraw tabulatory chodzi o to, że nie są Równe odstepy od początku lini :D

Łatwiej by mi bło to ogar jakbyś to dał tu albo na priv .sma i bym sprawdził :) jak to ty masz ułożone :D

a spróbuj zamiast tego

set_user_maxspeed(id,1200.0)


dać

set_user_speed(id,1200.0)

choć nie jestem pewien :D

TO was w szkole takich rzeczy uczą ?

Użytkownik ::Gogiel:: edytował ten post 01.06.2012 00:04

  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika
Dołączona grafika
SERWER SA:MP 194.28.50.14:25064
Zapraszamy Do Gry http://cs-pobojowisko.eu

#14 ::Gogiel::

    Zaawansowany

  • Użytkownik

Reputacja: 18
Początkujący

  • Postów:77
  • GG:
  • Imię:Hm... xD Patryk xD
  • Lokalizacja:Bydgoszcz
Offline

Napisano 08.06.2012 20:45

Problem Rozwiązany przy współpracy na PW okazało się ze vip blokuje szybkośc :)

Można zamknąć :D
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika
Dołączona grafika
SERWER SA:MP 194.28.50.14:25064
Zapraszamy Do Gry http://cs-pobojowisko.eu

#15 speedkill

    Godlike

  • Przyjaciel

Reputacja: 1570
Godlike

  • Postów:2733
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Prudnik
Offline

Napisano 08.06.2012 20:52

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Temat zamknięty na prośbę użytkownika.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0

If you can dream it, you can do it.





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych