Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Stary

Brak huda i pokazywanego zdobywanego doświadczenia

cod stary

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
8 odpowiedzi w tym temacie

#1 Lost

    Zaawansowany

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:80
  • GG:
  • Imię:Piotr
  • Lokalizacja:Łódź
Offline

Napisano 04.05.2012 18:35

Cześć. Robiłem nowe itemy do mojego coda, było by wszystko dobrze, gdyby nie fakt, iż mam stary problem, tak jak w temacie. Dawniej, gdy byłem z codem na bieżąco wiedziałem w czym tkwi problem, teraz zapomniałem. Na pewno to nie jest wina pluginów bo poprzednie wersje działały.

Proszę o konkretne wskazówki, co może być źle, bez próśb o .sma, bo grunt to się uczyć samemu, a nie żeby ktoś odwalał za kogoś całą robotę.
  • +
  • -
  • 0

#2 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 04.05.2012 18:38

skoro uczysz się sam popatrz w logi. najprawdopodobniej nie masz jakieś funkcji (ja tak miałem) albo jest coś źle zapisane. dopisując debug po nazwie w plugin ini wyskoczy CI dlaczego ;)
  • +
  • -
  • 1

b_560_95_1.png


#3 Lost

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:80
  • GG:
  • Imię:Piotr
  • Lokalizacja:Łódź
Offline

Napisano 04.05.2012 18:42

Robiłem, to i tam raczej nie ma problemu, bo przekopiowałem (nadpisałem) fragment z poprzedniej wersji.



L 05/04/2012 - 18:31:57: [AMXX] Run time error 10 (plugin "codmod2.amxx") (native "ShowSyncHudMsg") - debug not enabled!
L 05/04/2012 - 18:31:57: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/04/2012 - 18:31:57: HudSyncObject -1 is invalid
  • +
  • -
  • 0

#4 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 04.05.2012 18:46

podaj linijkę w której jest ten błąd.
  • +
  • -
  • 0

b_560_95_1.png


#5 Trikolo

    Miszczu

  • Zbanowany

Reputacja: 111
Zaawansowany

  • Postów:348
  • GG:
  • Imię:Trikolo
  • Lokalizacja:Komputer
Offline

Napisano 04.05.2012 18:48

@up :D

#6 Lost

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:80
  • GG:
  • Imię:Piotr
  • Lokalizacja:Łódź
Offline

Napisano 04.05.2012 19:47

L 05/04/2012 - 19:10:14: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 05/04/2012 - 19:10:14: [AMXX] [0] codmod2_547338.sma::PokazInformacje (line 2530)
L 05/04/2012 - 19:10:14: HudSyncObject -1 is invalid



ShowSyncHudMsg(id, SyncHudObj, "[Klasa : %s]^n[Doswiadczenie : %i / %i]^n[Poziom : %i]^n[Przedmiot : %s]", nazwy_klas[klasa_gracza[id]], doswiadczenie_gracza[id], doswiadczenie_poziomu[poziom_gracza[id]], poziom_gracza[id], nazwy_przedmiotow[informacje_przedmiotu_gracza[id][0]]);




Domyślam się, juz gdzie tkwi błąd, chociaz dziwi mnie to. Znacznie na górze, miałem zamieszanie z klamrami, z którymi pieprzyłbym się jeszcze tydzień, gdyby nie program do sprawdzania tych klamer, który znalazłem tutaj.

Edit:

Nie działa..
  • +
  • -
  • 0

#7 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 04.05.2012 19:52

pokaż linijke z set_hudmessage.
  • +
  • -
  • 0

b_560_95_1.png


#8 Droso

    Dawniej HubertTM

  • Support Team

Reputacja: 1279
Godlike

  • Postów:2371
  • Steam:steam
  • Imię:Hubert
  • Lokalizacja:Tomaszów Mazowiecki
Offline

Napisano 04.05.2012 19:59

Najlepiej to dać .sma w załączniku.
Pewnie kolega usunął coś z plugin_int
  • +
  • -
  • 1

Piszę pluginy pod: AMX MOD X oraz SOURCE MOD!

Na zlecenie i bez zlecenia zresztą też!


#9 Lost

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:80
  • GG:
  • Imię:Piotr
  • Lokalizacja:Łódź
Offline

Napisano 05.05.2012 13:47

Problem leżał w komendzie /daj, którą bardzo dawno temu edytowałem. Tak to już jest jak się robi nowego coda z przerwami miesięcznymi i nie pamięta na czym zakończyło.

Dzięki za chęci i zapraszam do tego tematu: http://amxx.pl/topic...poczatku-rundy/


każdemu dałem po plusiczku
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod stary

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych