Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

GmAMXBans

GmAMXBans 1.6 Utracone połączenie z bazą danych tuż po instalacjiRozwiązanie problemu: Lost connection to MySQL server at 'reading initial communication packet'

gmamxbans amxbans readinginitial communication packet system error 111

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
2 odpowiedzi w tym temacie

#1 Gość_21977_*

  • Gość

Reputacja: 0

Offline

Napisano 10.03.2012 20:16

Od 2 tygodni się męczyłem i męczyłem i nie mogłem nigdzie znaleźć rozwiązania, ale w końcu wziąłem sprawę w swoje ręce i tak przy instalacji należy podać jako host: localhost zamiast 127.0.0.1
Wówczas instalacja przebiegnie pomyślnie. Ponadto, po zainstalowaniu, pojawi nam się komunikat:

Warning: mysql_connect() [function.mysql-connect]: Lost connection to MySQL server at 'reading initial communication packet', system error: 111 in /home/cs16/www/bany/include/config.inc.php on line 46
Lost connection to MySQL server at 'reading initial communication packet', system error: 111


Aby naprawić ten błąd, nie trzeba zmieniać żadnych ustawień, bug jest w pliku config.inc.php w folderze include, należy linijkę

$config->db_host=getipbyhost($config->db_host);

zamienić na

$config->db_host='localhost';//getipbyhost($config->db_host);

Nie zgłaszałem tego, jako bug, bo i tak 99% osób korzysta ze źle skonfigurowanych serwerów z adresem 127.0.0.1 zamiast localhost. Informację kieruję do osób, które także będą męczyć się z tym błędem, a wystarczy pogooglać, jest ich mnóstwo. Rozwiązanie publikuję, by oszczędzić innym czasu i nerwów nieudolnego napisania linijki 46. pod źle skonfigurowane serwery.

Mam nadzieję, że temat nie zostanie usunięty z powodu uznania przez niektórych moderatorów, że przecież 127.0.0.1 jest poprawną konfiguracją.
Prosiłbym również o, w miarę możliwości, dodanie tego jako naprawa buga dla poprawnie skonfigurowanych serwerów dedykowanych (tj. z adresem lokalnym localhost, a nie 127.0.0.1), bo linikja 46. nie zakłada tej jedynej, bezpiecznej możliwości.

Dziękuję.

edit. Zdaję sobie sprawę, że sprawa dotyczy niewielu osób, ale pomoże ona zaoszczędzić, jak napisałem, mnóstwo czasu, więc liczę, że temat się przyda.

Użytkownik benio101 edytował ten post 10.03.2012 20:23


#2 sebacs2

    Wszechwidzący

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:244
  • Lokalizacja:nie wiem
Offline

Napisano 29.08.2012 19:44

Mi to pomogło dzięki
  • +
  • -
  • 0

;P Zapraszam na sieć serwerów Cs-KoRea.pl ^D^

Serwer [FFA+BF2] 31.186.83.100:27041 Serwer [Cod] 31.186.83.100:27046


#3 TakiSobieLudek

    Nowy

  • Pijawka

Reputacja: 0
zer0.

  • Postów:2
  • Lokalizacja:localhost
Offline

Napisano 22.10.2012 12:21

Po skorzystaniu z twojego rozwiązania , wyrzuca błąd nagłówka. Czyli też nie jest to żadne rozwiązanie.
(22.10.2012 21:46):
Takie false positive błędy można zawsze ukryć.

  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: gmamxbans, amxbans, readinginitial, communication, packet, system, error, 111

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych