Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Stary

[ROZWIĄZANE] Problem z szybkością perku .

cod stary

  • Zamknięty Temat jest zamknięty
16 odpowiedzi w tym temacie

#1 WiWaldi:*

    Wszechwidzący

  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 25.02.2012 16:12

Witam zrobiłem sobie perk do cod moda .
Ale jest mały problem to nie działa .
Mam Perk Speed Szybciora ale nie dostaje speeda 7.0

Hp dodaje ale speeda nie . :( .

 if(informacje_przedmiotu_gracza[id][0] == 13)
{
maksymalne_zdrowie_gracza[id] += 50;
szybkosc_gracza[id] += 7.0;
}


Co zrobiłem źle . :(

#2 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 01.03.2012 00:17

@ Ref

#3 Klakier

    Volenti non fit iniuria

  • Power User

Reputacja: 390
Wszechpomocny

  • Postów:878
  • GG:
  • Imię:Sebastian
  • Lokalizacja:Mogilno
Offline

Napisano 01.03.2012 14:22

Dodajesz to do
public Odrodzenie(id)
?

Użytkownik Klakier edytował ten post 01.03.2012 14:22

  • +
  • -
  • 0

Sell - System Klanów (wojny, top15 etc)

 

Kontakt GG: 7285018


#4 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 02.03.2012 15:37

Głupie pytanie :D , Nie mam 10 lat xD . Ale odpowiem tak dodałem .

#5 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 04.03.2012 18:44

@ ref

#6 Maniek974

    Wszechwiedzący

  • Power User

Reputacja: 351
Wszechpomocny

  • Postów:594
  • Steam:steam
  • Imię:Mariusz
  • Lokalizacja:Tomaszów Maz.
Offline

Napisano 05.03.2012 07:25

Podaj .sma tego coda
  • +
  • -
  • 0

#7 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 05.03.2012 08:01

Sma nie podam . Nie chce aby ktoś sobie zassał . A co do tego może nie może być 7.0 ?? a ma być 7 ??

Bo jak dam - to działa a jak + to nie :(

#8 Maniek974

    Wszechwiedzący

  • Power User

Reputacja: 351
Wszechpomocny

  • Postów:594
  • Steam:steam
  • Imię:Mariusz
  • Lokalizacja:Tomaszów Maz.
Offline

Napisano 05.03.2012 08:05

A spróbuj na 0.7 a nie 7.0
bo z tego co widzę to np jest

   maksymalne_zdrowie_gracza[id] += 50;
szybkosc_gracza[id] -= 0.3;


a u klasy
new const Float:szybkosc_klasy[] = {0.0, 1.1, 1.35, 0.9, 0.8,

Użytkownik Maniek974 edytował ten post 05.03.2012 08:11

  • +
  • -
  • 0

#9 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 05.03.2012 08:30

Ale ja w klasie dałem tak :D .
new const Float:szybkosc_klasy[] = {0.0, 1.2, 1.4, 7.0, 1.3, 2.0, 2.0
Jest 7.0 i w klasie działa

A w perku nie

#10 Maniek974

    Wszechwiedzący

  • Power User

Reputacja: 351
Wszechpomocny

  • Postów:594
  • Steam:steam
  • Imię:Mariusz
  • Lokalizacja:Tomaszów Maz.
Offline

Napisano 05.03.2012 10:11

Z tego co wiem szybkość może być 0.5-2.0 więc może w tym tkwi problem.
  • +
  • -
  • 0

#11 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 05.03.2012 11:02

Z tego co wiem szybkość może być 0.5-2.0 więc może w tym tkwi problem.



Jak to jest możliwe jak w klasie mam 7.0 i z taką prędkością popierdziela .:D

#12 Maniek974

    Wszechwiedzący

  • Power User

Reputacja: 351
Wszechpomocny

  • Postów:594
  • Steam:steam
  • Imię:Mariusz
  • Lokalizacja:Tomaszów Maz.
Offline

Napisano 05.03.2012 11:06

To ja nie wiem próbowałem ci pomóc a jeszcze jedno pytanie używasz tego perka na tej klasie co ma 7.0 czy na innej?
  • +
  • -
  • 0

#13 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 05.03.2012 12:21

Innej

#14 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 13.03.2012 12:00

Problem rozwiązany .
Powinno być tak .

 if(informacje_przedmiotu_gracza[id][0] == 13)
{
maksymalne_zdrowie_gracza[id] += 50;
szybkosc_gracza[id] *= 7.0;
}


#15 Klakier

    Volenti non fit iniuria

  • Power User

Reputacja: 390
Wszechpomocny

  • Postów:878
  • GG:
  • Imię:Sebastian
  • Lokalizacja:Mogilno
Offline

Napisano 13.03.2012 14:22

Po prostu dodawając 7 speeda to wydawało się że to nie działa ponieważ tego nie odczułeś, ponieważ 7 speed to bardzo mało. Mogłeś dać +50 wtedy speed byłby odczuwalny :)
  • +
  • -
  • 0

Sell - System Klanów (wojny, top15 etc)

 

Kontakt GG: 7285018


#16 WiWaldi:*

    Wszechwidzący

  • Autor tematu
  • Zbanowany

Reputacja: 65
Pomocny

  • Postów:267
  • GG:
  • Imię:Waldemar
  • Lokalizacja:Świdnica
Offline

Napisano 13.03.2012 14:30

po 1 dałem
+= 7.0;

po 2 powinno być tak o
*= 7.0;

po 3 na
*= 7.0;

Zapierdziela że uj :D .

#17 MarWit

    The Chosen One

  • Przyjaciel

Reputacja: 840
Czempion

  • Postów:1485
  • GG:
  • Steam:steam
  • Imię:Marcin
  • Lokalizacja:Bystrzyca
Offline

Napisano 13.03.2012 15:16

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0

marwit-0.png






Również z jednym lub większą ilością słów kluczowych: cod stary

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych