Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Błąd w logachW logach jest błąd co do pluginu vip.amxx

vip amxx error błąd logi

  • Zamknięty Temat jest zamknięty
14 odpowiedzi w tym temacie

#1 killerosw

    Początkujący

  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:18
  • Imię:Daniel
  • Lokalizacja:Ostrów Wielkopolski
Offline

Napisano 23.02.2012 19:37

Witam wszystkich. Otóż stawiam serwer TP i po pierwszym dniu działania mam błąd w logach, spowodowany pluginem vip.amxx. Wrzucam info z logów i liczę na pomoc z Waszej strony!

L 02/23/2012 - 14:34:23: Start of error session.
L 02/23/2012 - 14:34:23: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20120223.log")
L 02/23/2012 - 14:34:23: Invalid player id 0
L 02/23/2012 - 14:34:23: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 14:34:23: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 14:34:23: Invalid player id 0
L 02/23/2012 - 14:34:23: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 14:34:23: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 15:37:36: Start of error session.
L 02/23/2012 - 15:37:36: Info (map "de_nuke") (file "addons/amxmodx/logs/error_20120223.log")
L 02/23/2012 - 15:37:36: Invalid player id 0
L 02/23/2012 - 15:37:36: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 15:37:36: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 15:37:36: Invalid player id 0
L 02/23/2012 - 15:37:36: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 15:37:36: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:04:20: Start of error session.
L 02/23/2012 - 16:04:20: Info (map "de_inferno") (file "addons/amxmodx/logs/error_20120223.log")
L 02/23/2012 - 16:04:20: Invalid player id 0
L 02/23/2012 - 16:04:20: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:04:20: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:04:20: Invalid player id 0
L 02/23/2012 - 16:04:20: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:04:20: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:08:27: Invalid player id 0
L 02/23/2012 - 16:08:27: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:08:27: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:08:27: Invalid player id 0
L 02/23/2012 - 16:08:27: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:08:27: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:38:52: Start of error session.
L 02/23/2012 - 16:38:52: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20120223.log")
L 02/23/2012 - 16:38:52: Invalid player id 0
L 02/23/2012 - 16:38:52: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:38:52: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:38:52: Invalid player id 0
L 02/23/2012 - 16:38:52: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:38:52: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:42:47: Invalid player id 0
L 02/23/2012 - 16:42:47: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:42:47: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 16:42:47: Invalid player id 0
L 02/23/2012 - 16:42:47: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 16:42:47: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 17:09:51: Start of error session.
L 02/23/2012 - 17:09:51: Info (map "de_inferno") (file "addons/amxmodx/logs/error_20120223.log")
L 02/23/2012 - 17:09:51: Invalid player id 0
L 02/23/2012 - 17:09:51: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 17:09:51: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 17:09:51: Invalid player id 0
L 02/23/2012 - 17:09:51: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 17:09:51: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 17:30:36: Invalid player id 0
L 02/23/2012 - 17:30:36: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 17:30:36: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/23/2012 - 17:30:36: Invalid player id 0
L 02/23/2012 - 17:30:36: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_user_attacker") - debug not enabled!
L 02/23/2012 - 17:30:36: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Z gory dziękuję za pomoc :)
  • +
  • -
  • 0

#2 psilocybe

    Toasty!

  • Power User

Reputacja: 246
Wszechwidzący

  • Postów:524
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:PL
Offline

Napisano 23.02.2012 19:47

Dopisz debug po nazwie pluginu vip.amxx i wstaw logi jeszcze raz :)

W plugin.ini ma to wyglądać tak:

vip.amxx debug

Od razu możesz dołączyć *.sma tego pluginu aby ktoś obeznany mógł to przeanalizować :)

Użytkownik psilocybe edytował ten post 23.02.2012 19:48

  • +
  • -
  • 1

Dołączona grafika

Dołączona grafika


#3 Roller

    Zaawansowany

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:106
  • GG:
  • Imię:Radosław
  • Lokalizacja:Turek
Offline

Napisano 23.02.2012 19:47

w plugins.ini dopisz:

vip.amxx debug

zamiast:
vip.amxx


Być może pomoże, bynajmiej ja tak miałem.

Uprzedził mnie :(

Użytkownik Roller edytował ten post 23.02.2012 19:48


#4 psilocybe

    Toasty!

  • Power User

Reputacja: 246
Wszechwidzący

  • Postów:524
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:PL
Offline

Napisano 23.02.2012 19:50

To nie pomoże ale będzie wtedy w error_log szczegółowy opis błędu, wtedy można sprawdzić *.sma i ewentualnie edytować.
  • +
  • -
  • 0

Dołączona grafika

Dołączona grafika


#5 Roller

    Zaawansowany

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:106
  • GG:
  • Imię:Radosław
  • Lokalizacja:Turek
Offline

Napisano 23.02.2012 20:28

No sma zdecydowanie było by przydatne, oraz szczegółowe logi wynikające z błędu pluginu. Jeśli już się takowe utworzyły.

#6 psilocybe

    Toasty!

  • Power User

Reputacja: 246
Wszechwidzący

  • Postów:524
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:PL
Offline

Napisano 23.02.2012 23:00

Sprawdź w pliku modules.ini czy masz odblokowany moduł fun.

Jeżeli masz
;fun

To usuń ; aby było:
fun

Jeśli plugin dalej będzie powodował problemy to poczekaj na opinie ludzi którzy programują w Pawnie, zapewne pomogą ;)

Peace.
  • +
  • -
  • 1

Dołączona grafika

Dołączona grafika


#7 killerosw

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:18
  • Imię:Daniel
  • Lokalizacja:Ostrów Wielkopolski
Offline

Napisano 24.02.2012 13:27

Odblokowany moduł! Czekam na inne propozycje, a dla Ciebie oczywiście karma :)
  • +
  • -
  • 0

#8 Roller

    Zaawansowany

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:106
  • GG:
  • Imię:Radosław
  • Lokalizacja:Turek
Offline

Napisano 24.02.2012 17:47

W logach wyraźnie piszę, z którymi funkcjami jest problem. Odnajdź je, zrób spis i się pomyśli.

#9 killerosw

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:18
  • Imię:Daniel
  • Lokalizacja:Ostrów Wielkopolski
Offline

Napisano 24.02.2012 22:28

Ja jestem całkowicie zielony z pluginami... Możesz jaśniej? Niżej daje kod z .sma, w którym jest mowa o "get_user_attacker".

public on_damage(id)
{
new attacker = get_user_attacker(id)
#if defined DAMAGE_RECIEVED
// id should be connected if this message is sent, but lets check anyway
if ( is_user_connected(id) && is_user_connected(attacker) )
if (get_user_flags(attacker) & ADMIN_LEVEL_H)
{

public Damage(id)
{
new weapon, hitpoint, attacker = get_user_attacker(id,weapon,hitpoint)
if(attacker<=maxplayers && is_user_alive(attacker) && attacker!=id)
if (get_user_flags(attacker) & ADMIN_LEVEL_H)
{
  new money = read_data(2) * get_pcvar_num(mpd)
  if(hitpoint==1) money += get_pcvar_num(mhb)
  cs_set_user_money(attacker,cs_get_user_money(attacker) + money)
}

  • +
  • -
  • 0

#10 Roller

    Zaawansowany

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:106
  • GG:
  • Imię:Radosław
  • Lokalizacja:Turek
Offline

Napisano 25.02.2012 09:29

Napisaniu pluginów ja się nie znam (chyba, że korzystanie ze wzoru lub automatyczne funkcje). Usuń ten plugin, a poszukaj jakiegoś innego zamiennika lub poproś by ci zrobiono taki na życzenie. Chyba, będzie to najlepszym rozwiązaniem.

#11 Jak się nazwać

    Wszechmogący

  • Power User

Reputacja: 170
Profesjonalista

  • Postów:617
  • Imię:a
  • Lokalizacja:a
Offline

Napisano 25.02.2012 09:34


public on_damage(id)
{
if(!is_user_connected(id)) return
new attacker = get_user_attacker(id)
#if defined DAMAGE_RECIEVED
// id should be connected if this message is sent, but lets check anyway
if ( is_user_connected(attacker) )
if (get_user_flags(attacker) & ADMIN_LEVEL_H)
{

oraz

public Damage(id)
{
if(!is_user_connected(id)) return
new weapon, hitpoint, attacker = get_user_attacker(id,weapon,hitpoint)
if(attacker<=maxplayers && is_user_alive(attacker) && attacker!=id)
if (get_user_flags(attacker) & ADMIN_LEVEL_H)
{
new money = read_data(2) * get_pcvar_num(mpd)
if(hitpoint==1) money += get_pcvar_num(mhb)
cs_set_user_money(attacker,cs_get_user_money(attacker) + money)
}


@Up

Napisaniu pluginów ja się nie znam

to może się nie wypowiadaj?

Użytkownik Jak się nazwać edytował ten post 25.02.2012 09:36

  • +
  • -
  • 1
Pisze na zamówienie statystyki pod nvault. GG: 15600964

#12 killerosw

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:18
  • Imię:Daniel
  • Lokalizacja:Ostrów Wielkopolski
Offline

Napisano 25.02.2012 15:44

Pomoże ktoś, zamiast się przekomarzać? Potrzebuje pilnej pomocy, a jeszcze nic konkretnego nie dostałem :) Proszę Was!
Hiroshima (25.02.2012 20:10):
nie zauważyłeś postu wyżej?

  • +
  • -
  • -1

#13 Roller

    Zaawansowany

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:106
  • GG:
  • Imię:Radosław
  • Lokalizacja:Turek
Offline

Napisano 25.02.2012 15:51

Może byś zacytował całą wypowiedź, a nie wycinasz 3 słowa ? Ludziom to brak kultury!
*****, skoro nie odniosłem się do tego pluginu to powiedziałem jaki jest najszybszy sposób na naprawienie problemu, a ty pieprzysz głupoty i jakieś wielkie aluzje..w dodatku. Aż ponosi.
Hiroshima (25.02.2012 20:11):
mnie też ponosi jak nie pomagasz a wcinasz swoje 3 słowa w taki sposób, że robi się niedobrze.

Użytkownik Roller edytował ten post 25.02.2012 15:51


#14 killerosw

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:18
  • Imię:Daniel
  • Lokalizacja:Ostrów Wielkopolski
Offline

Napisano 27.02.2012 15:25

Panie adminie/moderatorze, nie skapnalem się, że to jest poprawiony kod. Dziękuję za zwrocenie mojej uwagi :) Problem rozwiązany! Jak najbardziej + dla osob pomagających :) Można zamnkąć!
  • +
  • -
  • 0

#15 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 27.02.2012 16:28

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: vip, amxx, error, błąd, logi

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych