Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Anti "cmd dlfile"Łatka usuwająca możliwość crashowania serwera z dproto za pomocą "cmd dlfile"

anti cmd dlfile plugin dproto łatka

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
26 odpowiedzi w tym temacie

#1 Onyke

    Godlike

  • Przyjaciel

Reputacja: 705
Guru

  • Postów:2178
Offline

Napisano 23.10.2011 19:25

*
Popularny

Anti "cmd dlfile" Plugin


opis
Luka w silniku HLDS pozwala przy zainstalowanym Dproto na crashowanie serwera.
Antidlfile łata tę lukę.

instalacja
1.Wgraj pliki na FTP Twojego serwera zachowując strukturę folderów.
2.
Dla windowsa:

Spoiler

Dla linuxa (kupując serwer w firmie hostingowej na 99% masz właśnie serwer na linuxie):
Spoiler

3. Zrestartuj swój serwer

download
Dla serwerów z stabilną wersją binarek (4883)
Spoiler

Dla serwerów z włączonym parametrem "-beta hlbeta" (wersja binarek <= 5006)
Spoiler


Źródła:
forums.alliedmods.net
pukawka.pl

Hiroshima (24.10.2011 08:03):
Dodatkowo, jeśli posiadasz serwer z AMX'em to również jest aktualne (dla starszych wersji binarek): http://amxx.pl/topic...-rebuy-bug-fix/

  • +
  • -
  • 14

#2 diablix

    emeryt

  • Przyjaciel

Reputacja: 507
Wszechwiedzący

  • Postów:663
  • GG:
  • Steam:steam
  • Imię:Daniel
  • Lokalizacja:Warszawa
Offline

Napisano 23.10.2011 19:48

Automatyczna wiadomość


Ten temat został przeniesiony z forum:
AMX Mod X > Pluginy
do
HLDS > Pliki


  • +
  • -
  • 0

#3 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 23.10.2011 20:43

Czyli jak ma się nowszą wersję silnika, ale bez komendy startowej "-beta hlbeta", to łatka jest bezużyteczna?
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#4 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 23.10.2011 20:56

nie to instalujesz łatkę dla nowszej wersji silnika -,-
  • +
  • -
  • 0

#5 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 23.10.2011 21:08

Nie wiem czy są inne dla nowszych wersji silnika... W temacie napisane jest, że pierwsza wersja jest dla "4883", a druga dla serwera z komendą startową "-beta hlbeta" i chodzi mi właśnie o tą drugą, czy to działa wyłącznie na takich serwera z tą komendą.

Tak po za temat, to forum coś ostro muli...

Użytkownik sebul edytował ten post 23.10.2011 21:11

  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#6 Siemir

    Profesjonalista

  • Użytkownik

Reputacja: 113
Zaawansowany

  • Postów:204
  • Steam:steam
  • Lokalizacja:nie znana
Offline

Napisano 23.10.2011 23:30

Wypadałoby chyba napisać, że ta luka nie istnieje na najnowszym buildzie HLDS'a, a użyteczność tej łatki ogranicza się do wersji <=5006 o czym chyba nie zdaje sobie sprawy autor tematu.
  • +
  • -
  • 0

#7 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 24.10.2011 14:20

Wypadałoby chyba napisać, że ta luka nie istnieje na najnowszym buildzie HLDS'a, a użyteczność tej łatki ogranicza się do wersji <=5006 o czym chyba nie zdaje sobie sprawy autor tematu.

Na poparcie słów: http://forums.allied...5&postcount=124
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#8 Marcinek

    Zaawansowany

  • Zbanowany

Reputacja: 3
Nowy

  • Postów:112
  • Imię:Marcin
  • Lokalizacja:Polska
Offline

Napisano 25.10.2011 19:11

tutaj sa 2 pliki do pobrania a skad mam wiedziec ktory wgrac na serwer?

#9 Cypis'

    Master

  • Przyjaciel

Reputacja: 1139
Super Hero

  • Postów:964
  • GG:
  • Steam:steam
  • Lokalizacja:polska
Offline

Napisano 26.10.2011 12:12

masz napisane które na jaki serwer sa:
Dla serwerów z stabilną wersją binarek (4883)
...
Dla serwerów z włączonym parametrem "-beta hlbeta"
...

Użytkownik Cypis' edytował ten post 26.10.2011 12:13

  • +
  • -
  • 0

#10 darklord199534

    Życzliwy

  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:31
  • Imię:Maciek
  • Lokalizacja:Siedlce
Offline

Napisano 26.10.2011 13:57

Witam. To jest tak:
Jak mam wgrany dproto i tak troszkę ciągle crashować tak?
A jeśli w to wgrane już, to już nie będzie crash tak?

i gdzie mam zobaczyć parametr "-beta hlbeta"
  • +
  • -
  • 0

#11 Lost

    Zaawansowany

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:80
  • GG:
  • Imię:Piotr
  • Lokalizacja:Łódź
Offline

Napisano 26.10.2011 17:48

Kto mi skasował mojego posta??????????????????????????????

Pisałem, że to jest stara łatka i nie działająca, chyba że nowa wersja pod tą samą (podobną) nazwą,

Trzeba przetestować.
  • +
  • -
  • 0

#12 Marcinek

    Zaawansowany

  • Zbanowany

Reputacja: 3
Nowy

  • Postów:112
  • Imię:Marcin
  • Lokalizacja:Polska
Offline

Napisano 26.10.2011 18:59

ale jak mam sprawdzic jaki ja mam serw czyli ktora wersja pasuje pod moj serwer bo pierwsze slysze o czyms takim jak -beta hlbeta" czy binarek

#13 sebuli

    Zaawansowany

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:128
  • Lokalizacja:Bydgoszcz
Offline

Napisano 05.11.2011 22:26

Mam problem, otóż testowałem programem czy mogę scrashować mój serwer po tej poprawce, no i nie mogę. Ale teraz problem, bo chyba się dodało gdzieś moje IP i pisze mi wciąż, że serwer jak by jest off i nawet wpisując connect w konsolu nie mogę na niego wejść. Ktoś ma jakieś pomysły w jaki sposób może mi to blokować dostęp do serwera?
  • +
  • -
  • 0

#14 hary

    Pomocny

  • Zbanowany

Reputacja: 1
Nowy

  • Postów:66
  • Imię:Szymon
  • Lokalizacja:Torun
Offline

Napisano 06.11.2011 16:14

Witam jeżeli mam wersję 5006 to które pliki mam wgrać na serwer bo już się pogubiłem... Ogólnie historia jest taka, że zrobiłem downgrade do wersji 5006 żeby pozbyć się problemu z VALVE_ID_LAN czyli nie czytania Steam'owców później z panelu pukawki wgrałem anti dllfile żeby zabezpieczyć się przed crashami, ale to nie pomaga bo i tak milusińscy pseudo gracze kładą mi serwer zostawiając w logach ten piękny komunikat NET_QueuePacket: Oversize packet from 217.**.**.***

Zapomniał bym dodać ważnej informacji mianowicie ustawień linii startowej (screen)

Załączone miniatury

  • panel.PNG

Użytkownik hary edytował ten post 06.11.2011 16:40


#15 Siemir

    Profesjonalista

  • Użytkownik

Reputacja: 113
Zaawansowany

  • Postów:204
  • Steam:steam
  • Lokalizacja:nie znana
Offline

Napisano 06.11.2011 23:17

Bug z dlfile kładzie serwer bez info w konsoli, więc to nie to. Na NET_QueuePacket użyj http://forums.allied...ad.php?t=155230 - wymaga Orpheu.
  • +
  • -
  • 0

#16 _nothing_

    NO ACTA !

  • Zbanowany

Reputacja: 134
Zaawansowany

  • Postów:377
  • GG:
  • Imię:Nothing
  • Lokalizacja:Poland
Offline

Napisano 15.11.2011 17:42

czy ma to coś do rzeczy . Więc tak posiadam serwer COD:MOD na hostingu OwnServer.pl Łódź wersja LITE . Teraz prawie często mam full serwer. I przy zmianie mapy ale nie tylko przy zmianie serwer sie crashuje i wlacza sie podstawowa mapa. Czy to może być wina słabego hostingu chodzi mi o tą wersje LITE o ile się nie mylę to max 100FPS . Proszę o szybką pomoc . Bo ostatnio dowiedziałem się, że aby sprawdzić czy serwer w ogóle już nie crashuje to sprawdza się w głównym FTP serwera czy jest plik " debug.log " jeżeli jest to znaczy, że serwer crashuje a my nie znamy przyczyny i to jest chyba wina binnarków. I chciałbym abyście mi pomogli co muszę wgrać na serwer . Dodam jeszcze, że będę kupował lepszy pakiet serwera z 350 FPS lub więcej .

#17 D@ruc

    Profesjonalista

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:201
  • Lokalizacja:Ostrowiec Św.
Offline

Napisano 17.11.2011 22:08

Czyli jak mam wersję binarek 5006 to mam cofnąć binarki do wersji4883 i wgrać plugin autobuyfix?

Użytkownik D@ruc edytował ten post 17.11.2011 22:20

  • +
  • -
  • 0

#18 freetu

    Wszechwiedzący

  • Power User

Reputacja: 71
Pomocny

  • Postów:504
  • Lokalizacja:Kwidzyn
Offline

Napisano 06.12.2011 17:27

witam, niestety nie do końca rozumiem...

Mam ustawiony parametr startowy -beta hlbeta i mimo to ktoś crashował mi server - miałem komunikat w konsoli

NET_QueuePacket: Oversize packet from 83.25.58.167:27005


Więc wgrałem te binarki z downloadu (tego tematu) które są w spoilerze

Dla serwerów z włączonym parametrem "-beta hlbeta"

przeczytałem ostrzeżenie od Onyke, co jest dziwne, bo skoro hlbeta naprawia ten błąd to po co te binarki są w downloadzie? Wracając do sedna, wgrałem te binarki, a crashe nie ustąpiły, dalej ktoś mi sypał serwer tym samym sposobem (tą samą miałem komendę w konsoli). Poszperałem na googlach i znalazłem temat:

http://forums.allied...950#post1505950

Jednak tych binarek nie mogę pobrać, nie wiem czemu - mam komunikat że nie mam dostępu - ale wyżej jest napisane że jest to wersja która działa właśnie z tym parametrem hlbeta. Czy może ktoś wyjaśnić kwestię czy trzeba wgrywać jakieś łątki (posiadając binarki 5006)? Czy jest działająca wersja? Jak naprawiać tą lukę...

Napisałem post tutaj, bo wydaje mi się że to się odnosi bardziej do ogółu. Jeśli powinienem założyć osobny temat, to sory.
  • +
  • -
  • 0

#19 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 06.12.2011 21:03

Fuuuuuuuuuuu......... Ile razy można wałkować to samo.... http://amxx.pl/topic...post__p__331028

Pod -beta hlbeta obecnie biega stabilna wersja 5408 na której chciał czy nie cmd dlfile tak czy siak nie działa - chwała za to że przeglądacie logi (!), usuwasz -autoupdate -beta hlbeta, wgrywasz ręcznie 5006, dodatkowo to co z linku wyżej i biega.
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#20 matti9410

    Wszechpomocny

  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 08.12.2011 21:30

Z góry przepraszam, ale czy mógłbym dostać linka do downloadu dla binarek 5006 poniewaz mam problemy z tą stroną i nic się niedzieje gdy klikam "show".
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: anti, cmd, dlfile, plugin, dproto, łatka

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych