Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

Jak przestawić amxbans na nową bazę

GmAMXBans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
20 odpowiedzi w tym temacie

#1 Qmi

    Wszechpomocny

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 02.10.2011 11:26

Witam, mam pewien problem w logach mianowicie

L 10/02/2011 - 10:48:33: [AMXX] Run time error 25 (plugin "amxbans_main.amxx") - debug not enabled!
L 10/02/2011 - 10:48:33: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).


I podobno jak się ustawi nową bazę to ten problem minie, także postawiłem nową bazę i zmieniam ja w include/db.config.inc.php ale jak zmienię na nową i odświeżę stronę to się psuje

i wyskakuje błąd.

Table 'qmi_amxbans.amx_webconfig' doesn't exist



#2 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 02.10.2011 13:48

w plugins.ini zamiast

amxbans_main.amxx

daj

amxbans_main.amxx debug

i nie musisz bazy zmieniać
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#3 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 02.10.2011 16:26

I będzie wszystko prawidłowo działać?

#4 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 02.10.2011 17:34

tak powinno działać
  • +
  • -
  • -1

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#5 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 06.10.2011 19:07

tak powinno działać


Cóż za absurd..

Nie będzie działać poprawnie tylko wypluje błędy pluginu
  • +
  • -
  • 1

#6 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 19:46

To jak to naprawić?

~refresz

#7 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 19:58

Table 'qmi_amxbans.amx_webconfig' doesn't exist

nie masz tabeli
  • +
  • -
  • 0

DarkGL to mój autorytet.


#8 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 20:31

Jak to naprawić?

#9 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 20:37

wykonaj zapytanie sql

CREATE TABLE `amx_webconfig` (
`id` int(11) NULL auto_increment,
`cookie` varchar(32) NULL,
`bans_per_page` int(11) NULL,
`design varchar`(32) NULL,
`banner varchar`(64) NULL,
`banner_url varchar`(128) NOT NULL,
`default_lang varchar`(32) NULL,
`start_page varchar`(64) NULL,
`show_comment_count` int(1) NULL DEFAULT '1',
`show_demo_count` int(1) NULL DEFAULT '1',
`show_kick_count` int(1) NULL DEFAULT '1',
`demo_all int`(1) NOT NULL DEFAULT '0',
`comment_all` int(1) NOT NULL DEFAULT '0',
`use_capture` int(1) NULL DEFAULT '1',
`max_file_size` int(11) NULL DEFAULT '2',
`file_type` varchar(64) NULL DEFAULT 'dem,zip,rar,jpg,gif',
`auto_prune` int(1) NOT NULL DEFAULT '0',
`max_offences` SMALLINT NOT NULL DEFAULT '10',
`max_offences_reason` VARCHAR( 128 ) NOT NULL DEFAULT 'max offences reached',
`use_demo` int(1) NULL DEFAULT '1',
`use_comment` int(1) NULL DEFAULT '1',
PRIMARY KEY (id)
);

  • +
  • -
  • 0

DarkGL to mój autorytet.


#10 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 20:37

bo to jest nowa baza danych i tam nie ma nic zainstalowane



(To miało być dołączenie do tamtego wyżej posta)


Coś takiego się pojawia

Załączone miniatury

  • za.PNG

Użytkownik Qmi edytował ten post 11.10.2011 20:40


#11 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 20:45

bo to jest nowa baza danych i tam nie ma nic zainstalowane

to zainstaluj :facepalm:
nie rozumiem cię

zapytanie na tabele amx_webconfig
CREATE TABLE `amx_webconfig` (
id int(11) NULL auto_increment,
cookie varchar(32) NULL,
bans_per_page int(11) NULL,
design varchar(32) NULL,
banner varchar(64) NULL,
banner_url varchar(128) NOT NULL,
default_lang varchar(32) NULL,
start_page varchar(64) NULL,
show_comment_count int(1) NULL DEFAULT '1',
show_demo_count int(1) NULL DEFAULT '1',
show_kick_count int(1) NULL DEFAULT '1',
demo_all int(1) NOT NULL DEFAULT '0',
comment_all int(1) NOT NULL DEFAULT '0',
use_capture int(1) NULL DEFAULT '1',
max_file_size int(11) NULL DEFAULT '2',
file_type varchar(64) NULL DEFAULT 'dem,zip,rar,jpg,gif',
auto_prune int(1) NOT NULL DEFAULT '0',
`max_offences` SMALLINT NOT NULL DEFAULT '10',
`max_offences_reason` VARCHAR( 128 ) NOT NULL DEFAULT 'max offences reached',
use_demo int(1) NULL DEFAULT '1',
use_comment int(1) NULL DEFAULT '1',
PRIMARY KEY (id)
);

  • +
  • -
  • 0

DarkGL to mój autorytet.


#12 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 20:54

To nie wystarczy tylko to że stworzę nową bazę danych i podmienię dane w include/db.config.inc.php ?

Czyli musze usunąć cały folder bany (bo tam mam amxbans) i zainstalować to od nowa?

#13 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 21:02

usuń db.config.inc.php
wrzuć setup.php i zainstaluj :)
chyba że masz dużo czasu to wywal all pliki i wrzuć na nowo

Użytkownik Kawon edytował ten post 11.10.2011 21:03

  • +
  • -
  • 0

DarkGL to mój autorytet.


#14 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 21:04

Admini mi zostaną czy będę musiał na nowo każdego dopisywać?

#15 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 21:07

zainstaluj na ta samą bazę danych to zostanie ona zaktualizowana i admini zostaną
  • +
  • -
  • 0

DarkGL to mój autorytet.


#16 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 21:11

zainstaluj na ta samą bazę danych


Ale przecież chodzi o to aby zainstalować właśnie na nowej bazie a nie na starej, przynajmniej tak rozumiem to co napisałeś.

#17 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 21:31

w obecnej bazie nie masz tabeli, jeżeli zainstalujesz na nowo na starej bazie zostanie ona zaktualizowana. Nie ma potrzeby robić nowej bazy
  • +
  • -
  • 0

DarkGL to mój autorytet.


#18 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 21:35

Nie, tak mi się dzieje gdy wpisuje dane tej nowej bazy tej na której to nie jest zainstalowane, tam kompletnie nic nie ma 0.00kb.
jeśli w db.confing.inc.php wpiszę dane do nowej bazy w której nic nie ma to wtedy wyskakuje to

Table 'qmi_amxbans.amx_webconfig' doesn't exist



A jak jestem na obecnej bazie danych to wyskakuje error.

L 10/11/2011 - 21:50:16: Info (map "de_dust2_long") (file "addons/amxmodx/logs/error_20111011.log")
L 10/11/2011 - 21:50:16: String formatted incorrectly - parameter 7 (total 6)
L 10/11/2011 - 21:50:16: [AMXX] Run time error 25 (plugin "amxbans_main.amxx") - debug not enabled!
L 10/11/2011 - 21:50:16: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes)



#19 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 11.10.2011 21:38

AHA :facepalm:
trzeba było tak od razu
wpisz w plugins.ini
amxbans_main.amxx debug
wtedy pokaż logi jakie wyrzuci




Table 'qmi_amxbans.amx_webconfig' doesn't exist

wywala ci to bo baza jest zupełnie pusta nic w niej nie ma

Użytkownik Kawon edytował ten post 11.10.2011 21:39

  • +
  • -
  • 0

DarkGL to mój autorytet.


#20 Qmi

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:373
  • GG:
Offline

Napisano 11.10.2011 21:40

L 10/09/2011 - 09:48:14: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20111009.log")
L 10/09/2011 - 09:48:14: String formatted incorrectly - parameter 7 (total 6)
L 10/09/2011 - 09:48:14: [AMXX] Displaying debug trace (plugin "amxbans_main.amxx")
L 10/09/2011 - 09:48:14: [AMXX] Run time error 25: parameter error



coś w tym stylu





Również z jednym lub większą ilością słów kluczowych: GmAMXBans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych