Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[Pokemod] Serwer się wyłącza.


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Tomkowic

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:53
  • GG:
  • Steam:steam
  • Lokalizacja:Tomkowice
Offline

Napisano 15.04.2011 21:13

Witam, mam problem z poke modem serwer się przez niego wyłącza.
Log:
L 04/15/2011 - 15:35:24: Start of error session.
L 04/15/2011 - 15:35:24: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 15:35:24: [nVault] Invalid vault id: 0

L 04/15/2011 - 15:35:24: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 15:35:24: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 04/15/2011 - 15:37:23: Start of error session.
L 04/15/2011 - 15:37:23: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 15:37:23: [nVault] Invalid vault id: 0

L 04/15/2011 - 15:37:23: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 15:37:23: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 04/15/2011 - 17:12:18: Start of error session.
L 04/15/2011 - 17:12:18: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 17:12:18: [nVault] Invalid vault id: 0

L 04/15/2011 - 17:12:18: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 17:12:18: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 04/15/2011 - 17:31:04: Start of error session.
L 04/15/2011 - 17:31:04: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 17:31:04: [nVault] Invalid vault id: 0

L 04/15/2011 - 17:31:04: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 17:31:04: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 04/15/2011 - 17:37:05: Start of error session.
L 04/15/2011 - 17:37:05: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 17:37:05: [nVault] Invalid vault id: 0

L 04/15/2011 - 17:37:05: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 17:37:05: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 04/15/2011 - 17:40:50: Start of error session.
L 04/15/2011 - 17:40:50: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 17:40:50: [nVault] Invalid vault id: 0

L 04/15/2011 - 17:40:50: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 17:40:50: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 04/15/2011 - 18:51:53: Start of error session.
L 04/15/2011 - 18:51:53: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20110415.log")
L 04/15/2011 - 18:51:53: [nVault] Invalid vault id: 0

L 04/15/2011 - 18:51:53: [AMXX] Run time error 10 (plugin "pokemod.amxx") (native "nvault_prune") - debug not enabled!
L 04/15/2011 - 18:51:53: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Mod pobrany stąd: [PokeMod] PokeMod v1.2.3 RC + RC2 Test for Public - AMXX.pl: Support AMX Mod X
Zmiany jakie w nim zaszły tylko w pliku custom zostało zmienione:
#define SAVE_NVAULT
na
#define SAVE SAVE_MYSQL
//how to save data ( 0 - steamid ; 1 - nickname )
 #define SAVE_ID            0
na
//how to save data ( 0 - steamid ; 1 - nickname )
 #define SAVE_ID            1

Użytkownik Tomkowic edytował ten post 15.04.2011 21:19

  • +
  • -
  • 0

b_350_20_6699FF_000000_FFFFFF_000000.png - 193.33.177.10:27015 = Gwarancja świetnej zabawy =

b_350_20_6699FF_000000_FFFFFF_000000.png - NaIbizie.pl = Publiczny darmowy serwer TeamSpeak! =


#2 b0niek

    Zaawansowany

  • Użytkownik

Reputacja: 87
Zaawansowany

  • Postów:133
  • Imię:Bartek
  • Lokalizacja:Tuż przed tobą
Offline

Napisano 15.04.2011 21:16

W plugins.ini po pokemod.amxx dodaj spację i wyraz debug. Ma to wyglądać tak:
pokemod.amxx debug
Po aktywacji tego dostaniesz więcej informacji o błędzie w konsoli.
  • +
  • -
  • 0

Dołączona grafika
Dołączona grafika
AVE SOAD!


#3 Tomkowic

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:53
  • GG:
  • Steam:steam
  • Lokalizacja:Tomkowice
Offline

Napisano 15.04.2011 22:16

Server IP address 79.133.192.40:27036

Metamod version 1.19p32 Copyright (c) 2001-2006 Will Day
Patch: Metamod-P (mm-p) v32 Copyright (c) 2004-2007 Jussi Kivilinna
Metamod comes with ABSOLUTELY NO WARRANTY; for details type `meta gpl'.
This is free software, and you are welcome to redistribute it
under certain conditions; type `meta gpl' for details.


AMX Mod X version 1.8.1.3746 Copyright (c) 2004-2006 AMX Mod X Development Team
AMX Mod X comes with ABSOLUTELY NO WARRANTY; for details type `amxx gpl'.
This is free software and you are welcome to redistribute it under
certain conditions; type 'amxx gpl' for details.

[DPROTO]: Version 0.9.87 Linux
[DPROTO]: Loading config './dproto.cfg'
[DPROTO]: LoggingMode = 2
[DPROTO]: Config sucessfully loaded.
[DPROTO]: Done.
L 04/16/2011 - 00:09:59: -------- Mapchange to de_dust2 --------
[] Loaded 2 admins from file
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.

Executing AMX Mod X Configuration File
Scrolling message displaying frequency: 10:00 minutes
Executing AMX Mod X Configuration File
Scrolling message displaying frequency: 10:00 minutes
[] No admins found.
L 04/16/2011 - 00:10:00: [pokemod.amxx] MySQL connect error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)' (localhost,root,pokemod)
L 04/15/2011 - 23:01:48: -------- Mapchange to de_dust2 --------
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] ---
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] Loading File: "addons/amxmodx/configs/roundsound.ini"
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] Error - Inexistent File: "Rs-Tomkowic-13-14-11/4.mp3"
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] Error - Inexistent File: "Rs-Tomkowic-13-14-11/3.mp3"
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] Error - Inexistent File: "Rs-Tomkowic-13-14-11/2.mp3"
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] Error - Inexistent File: "Rs-Tomkowic-13-14-11/1.mp3"
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] ---
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] [ Loading 7 CTs Sounds ]
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/8.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/9.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/10.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/11.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/12.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/13.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/14.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] ---
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] [ Loading 7 Ts Sounds ]
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/7.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/6.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/5.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/4.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/3.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/2.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] - Rs-Tomkowic-13-04-11/1.mp3
L 04/15/2011 - 23:01:49: [alt_end_round_sounds.amxx] ---
[] Loaded 2 admins from file
Executing AMX Mod X Configuration File
Scrolling message displaying frequency: 10:00 minutes
Executing AMX Mod X Configuration File
Scrolling message displaying frequency: 10:00 minutes
[] No admins found.
Writing banned.cfg.
Menu item 17 added to Menus Front-End: "Plugin Cvars" from plugin "pluginmenu.amxx"
Menu item 18 added to Menus Front-End: "Plugin Commands" from plugin "pluginmenu.amxx"
Connection to Steam servers successful.
"pm_debug_key" is ""
PokeMod - Successfully Loaded PokeMod Config File
VAC secure mode is activated.

z tego wynika że zle do bazy podałem.
Ale jestem pewny że zrobiłem to dobrze,tym prędzej że mam w bazie ścieżki z pokemoda.... baza danych mam z zabijaka.pl, była dołączona do serwera.


Kombinowałem na różne sposoby teraz wyłączyłem admin_sql.amxx w plugins.ini (który uruchomiłem przy robieniu serwera, na jakimś forum pisało że ma być włączone), i tamten błąd zniknął a pojawił się inni:
Plugin "pokemod.amxx" failed to load: Module/Library Class "dbi" required for plugin. Check modules.ini.




Mój modules.ini:
;;;
; To enable a module, remove the semi-colon (<img src='http://img.amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;mysql
;sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;fun
;engine
;fakemeta
;geoip
;sockets
;regex
;nvault
;hamsandwich
Przy uruchumieniu sql, pojawia się z powrotem błąd:
L 04/16/2011 - 00:25:07: [pokemod.amxx] MySQL connect error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)' (localhost,root,pokemod)

Po usunięci w modules.ini: ";" przed mysql i sqlite, pojawił się inny błąd:
L 04/16/2011 - 00:32:04: [pokemod.amxx] Error Making Tables: 'near "binary": syntax error' - 'CREATE TABLE IF NOT EXISTS `pm_save` ( `SAVE_KEY` varchar(34) binary NOT NULL default '', `XPS` varchar(255) binary NOT NULL default '', `LAST_PLAY_DATE` timestamp(14) NOT NULL, PRIMARY KEY (`SAVE_KEY
L 04/16/2011 - 00:32:04: [pokemod.amxx] Couldn't Erase XP: 'near "'30'": syntax error' - 'DELETE FROM `pm_save` WHERE pm_save.`LAST_PLAY_DATE` <> (SYSDATE() - INTERVAL '30' DAY)' - 1

Po tym usunełem ";" przed admin_sql.amxx w plugins.ini i błąd pozostał ten sam co wyżej.

Użytkownik Tomkowic edytował ten post 15.04.2011 23:48

  • +
  • -
  • 0

b_350_20_6699FF_000000_FFFFFF_000000.png - 193.33.177.10:27015 = Gwarancja świetnej zabawy =

b_350_20_6699FF_000000_FFFFFF_000000.png - NaIbizie.pl = Publiczny darmowy serwer TeamSpeak! =


#4 speedkill

    Godlike

  • Przyjaciel

Reputacja: 1570
Godlike

  • Postów:2733
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Prudnik
Offline

Napisano 16.04.2011 06:13

Ustaw sobie zapis na nick i nvalut polecam :P
Z ciekawości działał ci wogógle jakiś plugin
odblokuj moduły w modules.ini
;mysql
;sqlite
;fun
;engine
;fakemeta
;geoip
;sockets
;regex
;nvault
;hamsandwich
wszystkie masz wyłaczone a powinny wyglądać tak :
mysql
sqlite
fun
engine
fakemeta
geoip
;sockets
;regex
nvault
hamsandwich
i gotowe plugin powinien działać bez problemów :)

Użytkownik speedkill123 edytował ten post 16.04.2011 06:13

  • +
  • -
  • 0

If you can dream it, you can do it.


#5 Tomkowic

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:53
  • GG:
  • Steam:steam
  • Lokalizacja:Tomkowice
Offline

Napisano 16.04.2011 08:24

na nvault, jest lipa :/
  • +
  • -
  • 0

b_350_20_6699FF_000000_FFFFFF_000000.png - 193.33.177.10:27015 = Gwarancja świetnej zabawy =

b_350_20_6699FF_000000_FFFFFF_000000.png - NaIbizie.pl = Publiczny darmowy serwer TeamSpeak! =





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych