Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Stary

Problem z Itemkami 1/xxxPomocy!!

CoD Stary

  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 Jakubiak

    Zaawansowany

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:78
  • Lokalizacja:Łódź
Offline

Napisano 11.03.2011 19:30

Witam. Mam problem, który strasznie mnie irytuje. Polega on na tym, że zachciało mi się nauki w edytowaniu COD'a na własną rękę i standardowy item "AWP Sniper", który powinien zabijać 1/1 z AWP chciałem zmienić tak, aby można wylosować działanie od 1/1 do 1/4. Innymi słowy nie chciałem, aby zawsze wylosowana - zdejmowała na hita.

Mam wrażenie, że wystarczyło gdzieś zmienić jakąś jedną cyferkę a ja zmieniłem zbyt wiele.

Tak to wygląda teraz:

	if(idinflictor != idattacker && entity_get_int(idinflictor, EV_INT_movetype) != 5)
	{
		if(informacje_przedmiotu_gracza[idattacker][0] == 13 && random_num(1, 5) || informacje_przedmiotu_gracza[idattacker][0] == 10)
			damage = float(health);	
	}


A! I proszę o naprawienie tego, tj. o zrobienie od 1/1 do 1/4. Proszę także o jakieś zaznaczenie i opisanie błędu i dokonanej poprawki:/

Z góry dziękuje i za pomoc daję +:)
  • +
  • -
  • 0

#2 c0nst

    Nowy

  • Zbanowany

Reputacja: 2
Nowy

  • Postów:8
  • Lokalizacja:Węglówka
Offline

Napisano 11.03.2011 23:11

powinienes mieć nie random_num(1, 5) a random_num (5, 1)

i reszty to nie musisz edytować tylko ten znak(mam na myśli oryginalna resztę )

Użytkownik c0nst edytował ten post 11.03.2011 23:12


#3 Jakubiak

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 7
Nowy

  • Postów:78
  • Lokalizacja:Łódź
Offline

Napisano 12.03.2011 13:05

Zrozumiałem, działa. Dzięki wielkie za pomoc. + Dla Ciebie:)
  • +
  • -
  • 0

#4 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 21.07.2011 16:52

Automatyczna wiadomość


Ten temat został przeniesiony z forum:
Mody -> Call of Duty Mod -> Poradniki, Łatki oraz Pluginy
do
Mody -> Call of Duty Mod -> Problemy

  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: CoD Stary

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych