Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

Crash serwera co mapeCrash serwera co mape

GmAMXBans

  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 rycchhu

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Lokalizacja:ta myśl?
Offline

Napisano 02.12.2010 00:27

Witajcie, mam problem. Posiadam amxbansa 1.4 GM i wyskakują mi takie oto logi:
(bez debug)
L 12/02/2010 - 00:01:57: Start of error session.
L 12/02/2010 - 00:01:57: Info (map "de_aztec2") (file "addons/amxmodx/logs/error_20101202.log")
L 12/02/2010 - 00:01:57: [MySQL] Thread worker was unable to start.
L 12/02/2010 - 00:01:57: [AMXX] Run time error 10 (plugin "amxbans_main.amxx") (native "SQL_ThreadQuery") - debug not enabled!
L 12/02/2010 - 00:01:57: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

{z debug)
L 12/02/2010 - 00:02:59: Start of error session.
L 12/02/2010 - 00:02:59: Info (map "de_nuke") (file "addons/amxmodx/logs/error_20101202.log")
L 12/02/2010 - 00:02:59: [MySQL] Thread worker was unable to start.
L 12/02/2010 - 00:02:59: [AMXX] Displaying debug trace (plugin "amxbans_main.amxx")
L 12/02/2010 - 00:02:59: [AMXX] Run time error 10: native error (native "SQL_ThreadQuery")
L 12/02/2010 - 00:02:59: [AMXX]    [0] init_functions.inl::banmod_online_ (line 97)


Wyskakują gdy jest zmiana mapy i następuje crash - mapa zmienia się ponad minute lub w ogóle restart serwera. Wgrałem amxbansa z amxx.pl Szyfrant'a. Bany na ogół działają - połączenie z bazą jest.


Serwer S/NS - dproto
AMXMOD - 1.8.2

Załączone pliki


Użytkownik rycchhu edytował ten post 02.12.2010 00:28

  • +
  • -
  • 0

#2 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 02.12.2010 11:44

pokaz sql.cfg
  • +
  • -
  • 0

#3 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 02.12.2010 11:49

spróbuj zmiany modules.ini na:
;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
mysql
;sqlite
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;


;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
;engine
fakemeta
;geoip
;sockets
;regex
nvault
cstrike
csx
hamsandwich

  • +
  • -
  • 0

#4 Truposz WWL

    Profesjonalista

  • Użytkownik

Reputacja: 41
Pomocny

  • Postów:159
  • Lokalizacja:Duczki
Offline

Napisano 02.12.2010 16:17

Witam miałem chyba ten sam problem nie pamiętam czy to samo miałem w logach ale jak mapa zmieniała się sama to 4/5 zmieniała się bez crasha ale jak zmieniałem przez amxmodmenu zawsze padał serwer zmieniłem baze danych miałem na webd.pl mam na xaa.pl i teraz wszystko śmiga.
  • +
  • -
  • 0

#5 rycchhu

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Lokalizacja:ta myśl?
Offline

Napisano 02.12.2010 16:47

// SQL configuration file
// File location: $moddir/addons/amxmodx/configs/sql.cfg

// *NOTE* Linux users may encounter problems if they specify "localhost" instead of "127.0.0.1"
// We recommend using your server IP address instead of its name

// *NOTE* amx_sql_type specifies the DEFAULT database type which admin.sma will use.

amx_sql_host	"94.23.92.159"
amx_sql_user	"shoot_ban"
amx_sql_pass	"***"
amx_sql_db "shoot_ban"
amx_sql_table	"amxbans"
amx_sql_type	"mysql"


Tylko serwer ma połączenie z bazą - w tym problem...

Dodano 04 grudzień 2010 - 11:42:
Ktoś ma jakiś pomysł?
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: GmAMXBans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych