Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Menu Wyboru Renderingu


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 AmD

    aemde

  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 21.11.2010 00:28

Witam!

zrobiłem sobie menu Rendringu, ale coś nie działa :(
Powinno zmieniać Kolor Gracza, na taki jaki sobie wybierze, ale zamiast tego jest ciągle standardowy kolor który zdefiniowałem...

wyciąłem kod z głównego pluginu i zrobiłem mały plugin, byście pomogli mi naprawić:

Spoiler


co tutaj jest źle? :)

ps. a dodam że nawet jak się naciśnie na obojętnie jaki przycisk to pokazuje ciągle zwiększenie Koloru R


Pozdrawiam!

Użytkownik AmD edytował ten post 21.11.2010 00:29

  • +
  • -
  • 0

#2 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 21.11.2010 00:41

nie zarejestrowałeś menu, register_menucmd() luknij tutka o menusa
  • +
  • -
  • 1

#3 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 21.11.2010 00:53

co ma wyrażać zmienna "get" ? bo inicjujesz ją, porównujesz z get_user_userid ale nigdzie nie ustawiasz jej wartości o_O
poza tym nie brakuje ci przypadkiem register_menu ?
no i dziwnie kombinujesz dając w register_clcmd "ustaw_rgb" a nie tworzenie menu - "menu_rgb"
przez to "klawisz" z ustaw_rgb(id, klawisz) nie ma nigdy przypisanej wartości (==0), a dzięki temu zawsze odpala się rgb[id][0] += 16 :mur:

Polecam ci poczytać: Tworzenie menu - Nieoficjalny polski support AMX Mod X
  • +
  • -
  • 1

#4 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 21.11.2010 01:33

kk register_clcmd ma już menu_rgb

a mogę zarejestrować menu tak?

register_menucmd(register_menuid("Menu Renderingu"), 1023,"menu_rgb")
??


ps. pierwszy raz robię menu takim sposobem :) zawsze robiłem przez menu_additem ;) więc proszę nie bić :D


@edit. zrobiłem tak jak napisałem wyżej ale teraz nie mogę nacisnąć żadnego klawisza...

@edit2.
dobrze miałem jeśli chodzi o register_clcmd.

teraz już all działa :)

dzięki można close.

Użytkownik AmD edytował ten post 21.11.2010 01:42

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych