Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

hns_myshop


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Prospect

    Życzliwy

  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:39
  • Lokalizacja:Katowice
Offline

Napisano 09.10.2010 12:49

Powie mi ktoś w czym tkwi problem ? Otóż problem dotyczy pluginu hns_myshop. Co w tym kodzie jest źle ?

case LOTTO_DEAGLE:{
			if(cs_get_user_bpammo(id, CSW_DEAGLE)>=0) {
			return PLUGIN_HANDLED;
			}
			if(cs_set_weapon_ammo(id, CSW_DEAGLE)>=1) {
			return PLUGIN_HANDLED;
			}
			fm_give_item(id, "weapon_deagle");
		}

Błąd odnosi się do ustawiania graczowi 1 ammo. Niby wszystko się kompiluje, ale w konsoli pokazuje się błąd "(native "cs_set_weapon_ammo") - debug not enabled!" i plugin w pełni nie działa. Prosiłbym o pomoc ;)

Użytkownik Prospect edytował ten post 09.10.2010 12:50

  • +
  • -
  • 0

#2 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 14:08


case LOTTO_DEAGLE:
{
give_item(id, "weapon_deagle")
cs_set_user_bpammo(id, CSW_DEAGLE, 0)

new dgl_id = find_ent_by_owner(-1, "weapon_deagle", id)
if(dgl_id)
{
cs_set_weapon_ammo(dgl_id, 5) // ustawi tylko 5 naboi ogólnie jak dostanie dgl'a
}
}


Nie wiem czy o taki efekt ci chodziło.

Użytkownik hardbot edytował ten post 09.10.2010 14:14


#3 Prospect

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:39
  • Lokalizacja:Katowice
Offline

Napisano 09.10.2010 20:37

O ten efekt mi chodziło, jednak błąd w kompilacji.

error 017: undefined symbol "give_item"
error 017: undefined symbol "find_ent_by_owner"

  • +
  • -
  • 0

#4 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 09.10.2010 22:49

O ten efekt mi chodziło, jednak błąd w kompilacji.

error 017: undefined symbol "give_item"
error 017: undefined symbol "find_ent_by_owner"

xD
give_item // dodaj moduł FUN
czyli na samą górę #include <fun>
find_ent_by_owner // dodaj moduł ENGINE
czyli na samą górę #include <engine>

#5 Prospect

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:39
  • Lokalizacja:Katowice
Offline

Napisano 10.10.2010 11:28

Ehe :P Mój głupi błąd. Można zamknąć.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych