Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

AMXBans 5.1 by d3f3nd3r - nie banuje


  • Zamknięty Temat jest zamknięty
33 odpowiedzi w tym temacie

#21 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 20:17

Logi zapisują się co jakiś czas nie?
Więc dzisiaj ich nie ma ;/

Ale sprawdze.

Dodano 09 październik 2010 - 20:20:
Edit: Adma mam, ale dalej banować się nie da ;(
  • +
  • -
  • 0

#22 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 20:21

pokaż jeszcze modules.ini i sql.cfg oraz logi
  • +
  • -
  • 0

#23 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 20:29

Mówię ci, logi się jeszcze nie zapisały. Jutro będą.

modules.ini:

;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
;sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
netdb


sql.cfg:

amx_sql_host "polserwerek.xaa.pl"
amx_sql_user "polserwerek_forum"
amx_sql_pass "*******"
amx_sql_db "polserwerek_amxbans"
amx_sql_table "bany"
amx_sql_type "mysql"


A logi się jutro zapiszą... chyba że jakoś mam przyspieszyć zapisywanie?
  • +
  • -
  • 0

#24 PiotrEE3

    Pomocny

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:44
  • GG:
  • Lokalizacja:Krosno
Offline

Napisano 09.10.2010 20:33

nie może być http:// w nazwie hosta
Ma być tak:

Od strony serwera:

amx_sql_host    "polserwerek.xaa.pl:2082" 	//adres twojej domeny, może być IP (nigdy localhost!) 
amx_sql_user    "*****"		//użytkownik bazy danych 
amx_sql_pass    "*****"		//twoje hasło 
amx_sql_db        "****"		//nazwa bazy danych 
amx_sql_table    [color="#FF0000"]*[/color]"bany"			//nie zmieniaj 
amx_sql_type    "mysql"			//tego też nie

* zwróć uwagę jak się nazywa prefix u ciebie w bazie !!
A także w pliku amxbans.cfg :
amx_sql_prefix "bans"

A także ip+ port w server.cfg


I powinno śmigać :]



Co do tego żeby amxbans czytało z users.ini to w pliku amxbans.cfg zmieniasz linijke:
amxbans_use_admins_file 0
na
amxbans_use_admins_file 1

  • +
  • -
  • 0
Dołączona grafika
e-Wroblik.pl Serwer ZM [Testy/Beta]

#25 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 20:41

Dobra, mam pare pytań. Ten amx_sql_table mam dać taki, jak jest w amxbans.cfg amx_sql_prefix?? Bo ja nie mam czegoś takiego w amxbans.cfg...

A ten prefix u mnie w bazie jak mam sprawdzić jaki jest?
I co mam dokładnie wpisać w server.cfg?
  • +
  • -
  • 0

#26 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 09.10.2010 21:23

Nie wiem czy można takie coś wkleić: (jakby coś nie bijcie :confused:)
Instrukcja instalacji. Zrób all po kolei i masz 100%, że pójdzie.

Mieliście nie bić, jakbyście mieli taką instrukcję to nie było by problemu ...

Użytkownik ProMil edytował ten post 09.10.2010 22:04

  • +
  • -
  • 0

#27 PiotrEE3

    Pomocny

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:44
  • GG:
  • Lokalizacja:Krosno
Offline

Napisano 10.10.2010 21:24

jak sprawdzić? wchodząc do bazy xD , masz początek np: "amx_"(nazwy)

zrób tak ! : sprawdź jaki masz prefix w swojej bazie danych ja mam amx_
następnie amx_sql_table "amx" *(przykład)
a potem w pliku amxbans.cfg edytujesz linijkę(na 100% masz taką linijkę) : amx_sql_prefix "amx" *(przykład)


i ma działać. A poradziłeś sobie z przypisaniem adminów z pliku users.ini ??
  • +
  • -
  • 0
Dołączona grafika
e-Wroblik.pl Serwer ZM [Testy/Beta]

#28 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 12.10.2010 17:45

Tak, poradziłem sobie (do users.ini oczywiście).

PiotrEE3 napisał:
zrób tak ! : sprawdź jaki masz prefix w swojej bazie danych ja mam amx_

W której bazie danych?

Dodano 12 październik 2010 - 17:47:
Edit:
user 'polserwerek_foru'@'ks311766.kimsufi.com' (using password: YES) (1045)
L 10/12/2010 - 04:44:39: [amxbans.amxx] [Amxbans] Status zapytania: 
L 10/12/2010 - 04:44:39: [amxbans.amxx] [Amxbans] Polaczenie nieudane!
L 10/12/2010 - 04:44:39: [amxbans.amxx] [Amxbans] Blad zapyania, lokacja: 5
L 10/12/2010 - 04:44:39: [amxbans.amxx] [Amxbans] Wiadomosc: Access denied for user 'polserwerek_foru'@'ks311766.kimsufi.com' (using password: YES) (1045)
L 10/12/2010 - 04:44:39: [amxbans.amxx] [Amxbans] Status zapytania: 
L 10/12/2010 - 05:07:37: [mapchooser.amxx] Vote: Voting for the nextmap started
L 10/12/2010 - 05:07:52: [mapchooser.amxx] Vote: Voting for the nextmap finished.

Logi ;d

Dodano 13 październik 2010 - 14:39:
amx_sql_prefix "amx" *(przykład)

Ja nie mam takiej linijki ;/. Dopisać?

Dodano 13 październik 2010 - 14:48:
Edit3: Jak dałem prawidłowe dane do sql.cfg(wcześniej coś źle dałem ;P) to mi się serw zwiesił, i jest notresponding. Co robić?
  • +
  • -
  • 0

#29 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 13.10.2010 16:14

'polserwerek_foru'@'ks311766.kimsufi.com' (using password: YES) (1045)

Może poczytaj instrukcje instalacji? xD Nie nadałeś dostępu do bazy z zewnątrz.

Użytkownik ProMil edytował ten post 13.10.2010 16:14

  • +
  • -
  • 0

#30 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 13.10.2010 16:53

Gdybyś przeczytał wcześniej, wiedziałbyś, że dodałem...


Serw działa, ale amxbans nie :(

Dodano 14 październik 2010 - 07:22:
Edit: Logi:

L 10/14/2010 - 00:22:27: [amxbans.amxx] [Amxbans] Polaczenie nieudane!
L 10/14/2010 - 00:22:27: [amxbans.amxx] [Amxbans] Blad zapyania, lokacja: 1
L 10/14/2010 - 00:22:27: [amxbans.amxx] [Amxbans] Wiadomosc: Lost connection to MySQL server at 'reading initial communication packet', system error: 0 (2013)
L 10/14/2010 - 00:22:27: [amxbans.amxx] [Amxbans] Status zapytania: 
L 10/14/2010 - 00:23:27: [amxbans.amxx] [Amxbans] Polaczenie nieudane!
L 10/14/2010 - 00:23:27: [amxbans.amxx] [Amxbans] Blad zapyania, lokacja: 5
L 10/14/2010 - 00:23:27: [amxbans.amxx] [Amxbans] Wiadomosc: Lost connection to MySQL server at 'reading initial communication packet', system error: 0 (2013)
L 10/14/2010 - 00:23:27: [amxbans.amxx] [Amxbans] Status zapytania:


Serwer dodałem do połączeń zdalnych (bez portu), dane w sql.cfg mam dobrze wpisane. Co robić?
  • +
  • -
  • 0

#31 Jablonka

    Zaawansowany

  • Zbanowany

Reputacja: 14
Początkujący

  • Postów:139
  • Imię:Niewazne
  • Lokalizacja:Polska
Offline

Napisano 14.10.2010 08:01

Nie nadales!!!
MAsz takie cos dodac %

#32 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 14.10.2010 08:13

Jakbyś poprawnie dodał to nie było by tego problemu. :|
  • +
  • -
  • 0

#33 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 14.10.2010 08:13

Gdybyś zobaczyć stronę wcześniej, zobaczyłbyś screena, a na nim, że jest dodane...

Dodano 14 październik 2010 - 08:53:
Edit: Yfrog Image : yfrog.com/49polserwerekp

Tak ma być?

Dodano 14 październik 2010 - 09:00:
Edit2: Patrzcie:

Logi
L 10/14/2010 - 09:56:49: [amxbans.amxx] [AMXBANS DEBUG] The server IP:PORT is: xxx.xxx.xxx.xx:xxxx:xxxx
L 10/14/2010 - 09:57:13: [amxbans.amxx] [cmdBan function 1]Playerid: 1
L 10/14/2010 - 09:57:13: [amxbans.amxx] [AMXBANS DEBUG cmdBan] Banned a player by SteamID

Tak się stało, jak próbowałem kogoś zbanować.
Dlaczego jest tak?:
xxx.xxx.xxx.xx:xxxx:xxxx
??
2 porty??
  • +
  • -
  • 0

#34 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 14.10.2010 11:42

moze ci źle czyta pokaż server.cfg i amxbans.cfg
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych