Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

AMXBans 5.1 by d3f3nd3r - nie banuje


  • Zamknięty Temat jest zamknięty
33 odpowiedzi w tym temacie

#1 wowolek

    Życzliwy

  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 12:43

Więc, gdy próbuje kogoś zbanować na serwerze, robię tak:
amxmodmenu -> zbanuj gracza -> wybieram czas -> wybieram kogo zbanować -> piszę powód
Ale gdy dam enter to nie banuje.

Przez stronę też nie banuje.
CHMODY ustawiłem.

Logi czyste.

Modules.ini:

;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
netdb


Plugins.ini:
; AMX Mod X plugins

; Admin Base - Always one has to be activated

admin.amxx		; admin base (required for any admin-related)
;admin_sql.amxx		; admin base - SQL version (comment admin.amxx)
amxbans.amxx
; Basic

"debug" nie pomaga.


Sql.cfg:

amx_sql_host    "http://polserwerek.xaa.pl:2082" 	//adres twojej domeny, może być IP (nigdy localhost!)
amx_sql_user    "*****"		//użytkownik bazy danych
amx_sql_pass    "*****"		//twoje hasło
amx_sql_db        "****"		//nazwa bazy danych
amx_sql_table    "bany"			//nie zmieniaj
amx_sql_type    "mysql"			//tego też nie


Wersja amxx'a : 1.8.1


Proszę o pomoc.
  • +
  • -
  • 0

#2 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 13:07

sqlite wyłacz w modules.ini

polserwerek.xaa.pl:2082

bez portu wpisz


btw zaisntaluj gm 1.4 defender to syf
  • +
  • -
  • 0

#3 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 13:50

Nic nie pomogło ;(.

A po 2 mam na serwie zainstalowany war3FT mod, który wymaga SQLlite
  • +
  • -
  • 0

#4 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 13:52

wyłacz serwer i włacz
  • +
  • -
  • 0

#5 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 15:28

Dalej nic :(


amx_sql_host "http://polserwerek.xaa.pl"
Tak mam wpisane w sgl.cfg.
  • +
  • -
  • 0

#6 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 09.10.2010 15:32

amx_sql_host "polserwerek.xaa.pl"
amx_sql_user "polserwerek_user"
amx_sql_pass "hasło"
amx_sql_db "polserwerek_baza"
amx_sql_table "bany"
amx_sql_type "mysql"

NAJWAŻNIEJSZE: ;admin.amxx

Użytkownik ProMil edytował ten post 09.10.2010 15:34

  • +
  • -
  • 0

#7 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 18:17

Mhm... dałem przed admin.amxx średnik i teraz adma nie mam...
  • +
  • -
  • 0

#8 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 09.10.2010 18:24

Mhm... dałem przed admin.amxx średnik i teraz adma nie mam...

To znaczy, że źle skonfigurowałeś amxbans.
Ponieważ to w amxbans masz mieć admina, a nie w admins.amxx
  • +
  • -
  • 0

#9 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 18:27

http://polserwerek.xaa.pl/bany/admin/server_admins.php

Tutaj mam dodanego admina pod SID STEAM_0:1:31968652


A nie mam adma. To raz.
A dwa, że i tak nie mogę dodawać bany "na żywo"...
  • +
  • -
  • 0

#10 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 09.10.2010 18:30

A przypisałeś go do serwera?
  • +
  • -
  • 0

#11 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 18:32

W users.ini? Tak...

Dodano 09 październik 2010 - 18:33:
Daje admini i poziomy -> zarządzaj adminami amxx
No i tam dałem

W users.ini też .

Dodano 09 październik 2010 - 18:35:
Edit: A najgorsze jest to, że jak daje "Admini na serwerach", to jest napisany mój login i SID. Ale na serwie go nie mam.
  • +
  • -
  • 0

#12 ProMil

    Profesjonalista

  • Użytkownik

Reputacja: 73
Pomocny

  • Postów:186
  • GG:
  • Steam:steam
  • Imię:Artur
  • Lokalizacja:Warszawa
Offline

Napisano 09.10.2010 18:42

1. musisz wyłączyć tego admin.amxx czyli dodać ;
2. Musisz zobaczyć jakie błędy będziesz miał wtedy z amxbansa w logach.
  • +
  • -
  • 0

#13 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 18:56

1. musisz wyłączyć tego admin.amxx czyli dodać ;

przy 5 nie trzeba

po prostu mu sie baza nie łaczy logi pokaż

[MySQL] Nadawanie dostępu do bazy z zewnątrz - Nieoficjalny polski support AMX Mod X

zrobiłeś to?
  • +
  • -
  • 0

#14 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 18:56

L 10/09/2010 - 13:55:49: [amxbans.amxx] [Amxbans] Status zapytania: 
L 10/09/2010 - 13:55:50: [amxbans.amxx] [Amxbans] Polaczenie nieudane!
L 10/09/2010 - 13:55:50: [amxbans.amxx] [Amxbans] Blad zapyania, lokacja: 17
L 10/09/2010 - 13:55:50: [amxbans.amxx] [Amxbans] Wiadomosc: Unknown MySQL server host 'http' (1) (2005)

To w jednych logach.

A w drugich:

L 10/09/2010 - 16:52:10: [AMXX] Run time error 10 (plugin "amxbans.amxx") (native "SQL_ThreadQuery") - debug not enabled!


Od razu mówię, że debug nic nie pomogło.
  • +
  • -
  • 0

#15 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 19:05

no więc nadaj dostep do bazy z zewnatrz
  • +
  • -
  • 0

#16 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 19:26

Dużo to nie dało ;/

A jaki był cvar, żeby adminów czytał w users.ini?
  • +
  • -
  • 0

#17 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 19:34

a dodałes w nadawaniu dostępu % aby akceptowało wszytskie połaczenia?
  • +
  • -
  • 0

#18 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 09.10.2010 19:42

L 10/09/2010 - 13:55:50: [amxbans.amxx] [Amxbans] Blad zapyania, lokacja: 17
L 10/09/2010 - 13:55:50: [amxbans.amxx] [Amxbans] Wiadomosc: Unknown MySQL server host 'http' (1) (2005)


Usuń z cvaru amx_sql_host http na początku i zadziała :mur:

Nauczcie Wy się w końcu logi czytać...
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#19 wowolek

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:31
  • Imię:Wojciech
  • Lokalizacja:Niepołomice
Offline

Napisano 09.10.2010 19:45

Nie rozumiem ;/. Proszę troszkę jaśniej wytłumaczyć.

Screen z dostępami:

Yfrog Image : yfrog.com/49polserwerekp



Coś dodać?

Dodano 09 październik 2010 - 19:47:
Edit: Portek, to nie było do ciebie ;d

Zmienione, za chwile powiem czy działa.

Dodano 09 październik 2010 - 19:49:
Edit2: Dalej nie mam adma i nie mogę banować.
Jaka była komenda w amxbans.cfg, żeby odczytywało adminów z users.ini?
  • +
  • -
  • 0

#20 Szyfrant

    Godlike

  • Przyjaciel

Reputacja: 1365
Godlike

  • Postów:3072
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Sztokholm
Offline

Napisano 09.10.2010 19:56

ProMil wprowadził Cię w pewien błąd

zostaw plugins.ini tak:

; AMX Mod X plugins

; Admin Base - Always one has to be activated

admin.amxx ; admin base (required for any admin-related)
;admin_sql.amxx ; admin base - SQL version (comment admin.amxx)
amxbans.amxx
; Basic


i powinno działać a teraz pokaż logi
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych