Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[nVault] Zdobywanie doswiadczenia. [bez klas!]


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
58 odpowiedzi w tym temacie

#21 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 13.11.2010 12:30

ale co tu naprawiać ? skompilowało się
  • +
  • -
  • 0

#22 ric0

    Wszechwiedzący

  • Power User

Reputacja: 172
Profesjonalista

  • Postów:558
  • Imię:Łukasz
  • Lokalizacja:Ostrołęka
Offline

Napisano 13.11.2010 14:12

Popraw te Warningi:
Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team

xpmodnew.sma(51) : warning 204: symbol is assigned a value that is never used: "iVictim"
xpmodnew.sma(109) : warning 213: tag mismatch
xpmodnew.sma(121) : warning 213: tag mismatch
Header size: 884 bytes
Code size: 5496 bytes
Data size: 2640 bytes
Stack/heap size: 16384 bytes; max. usage is unknown, due to recursion
Total requirements: 25404 bytes

3 Warnings.
Done.


Dodano 13 listopad 2010 - 14:23:
to nie działa. wszystko mam zainstalowane poprawnie muduly odblokowane i nie działa.
  • +
  • -
  • 0

To co piszę się nie liczy...

 


#23 Harsay

    Harsayus pospolitus

  • Autor tematu
  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 13.11.2010 21:29

Warning: Symbol is assigned a value that is never used: "iVictim" on line 51
Warning: Tag mismatch on line 109
Warning: Tag mismatch on line 121

1. iVictim nie jest użyte, zostawiłem to aby ktoś już mógł szybko dodać funkcję. (nie jest to błąd!)
Jeżeli nie używasz iVictim a nie chcesz tego błędy najlepiej usuń lub dodaj przed //
new iVictim = read_data(2)
2/3. Tag mismatch - użyłem poprawnego ale skróconego set_hudmessage

Wszystko powinno działać.

Użytkownik Harsay edytował ten post 13.11.2010 21:31

  • +
  • -
  • 0

#24 ric0

    Wszechwiedzący

  • Power User

Reputacja: 172
Profesjonalista

  • Postów:558
  • Imię:Łukasz
  • Lokalizacja:Ostrołęka
Offline

Napisano 13.11.2010 21:33

Wzucilem to na serwer i nie dziala;/

Dodano 13 listopad 2010 - 21:42:
PLugin jest zainstalowany na serwerze ale w Hudzie sie zadne informacje nie wyswietlaja i w folderze data/vault nie tworzy sie plik "exp" gdzie maja byc zapisywane dane
  • +
  • -
  • 0

To co piszę się nie liczy...

 


#25 Harsay

    Harsayus pospolitus

  • Autor tematu
  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 13.11.2010 22:52

Rzeczywiście tylko nie wiem dlaczego nie powstaje ten plik :wstyd:

@edit


g_vault=nvault_open("doswiadczenie")


Dodaj to zamiast "exp"

Użytkownik Harsay edytował ten post 13.11.2010 22:53

  • +
  • -
  • 0

#26 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 13.11.2010 23:03

A ja bym to poprawił xD

Spoiler


//UPDATE KODU!

Użytkownik hardbot edytował ten post 14.11.2010 11:41


#27 ric0

    Wszechwiedzący

  • Power User

Reputacja: 172
Profesjonalista

  • Postów:558
  • Imię:Łukasz
  • Lokalizacja:Ostrołęka
Offline

Napisano 13.11.2010 23:29

[H]ARDBO[T] no twój kod jest lepszy i masz za to plsua. BO tworzy sie plik w data/vault i cos sie w nim zapisuje ale podczas gry nie ma informacji w hudzie i nie nalicza sie exp.

Użytkownik Squady edytował ten post 13.11.2010 23:44

  • +
  • -
  • 0

To co piszę się nie liczy...

 


#28 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 14.11.2010 00:35

Zmobilizowałem z leksza kod zobacz go teraz.

#29 Harsay

    Harsayus pospolitus

  • Autor tematu
  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 14.11.2010 11:21

Hardbot masz ode mnie 2 plusy lecz jednej kwestii nie rozumiem.

Dlaczego:
g_vault = nvault_open("CallofDuty_Mod")

Tworzy plik vault a z "exp" nie tworzy? Z deka jest to samo.
  • +
  • -
  • 0

#30 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 14.11.2010 11:42

xD Bo mi się pomyliło się :D

Myślałem że to jest pod cod mod xD jak większość postów na tym forum teraz xD

My error :D

#31 ric0

    Wszechwiedzący

  • Power User

Reputacja: 172
Profesjonalista

  • Postów:558
  • Imię:Łukasz
  • Lokalizacja:Ostrołęka
Offline

Napisano 14.11.2010 14:00

Zaraz to przetestuje.

Dodano 14 listopad 2010 - 14:11:
Dalej nie wyswietla informacji w hudzie;/ . A plis zostal stworzony w data/vault.

Dodano 14 listopad 2010 - 14:30:
Jeżeli są 2 osoby na serwerze to plik się tworzy i są jakieś dane w tym pliku. Ale informacje w hud nadal się nie wyswietlają.
  • +
  • -
  • 0

To co piszę się nie liczy...

 


#32 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 14.11.2010 14:57

Spoiler
doszedł 1 cvar amx_refresh_time w którym ustawiamy częstość odświeżania no a teraz poprawiajcie mój kod ^^
  • +
  • -
  • 0

#33 ric0

    Wszechwiedzący

  • Power User

Reputacja: 172
Profesjonalista

  • Postów:558
  • Imię:Łukasz
  • Lokalizacja:Ostrołęka
Offline

Napisano 14.11.2010 14:58

Zaraz sprawdze czy dziala :D

Dodano 14 listopad 2010 - 15:16:
Nadal to samo. Nie ma wiadomosci zadnych w hudzie.

Dodano 14 listopad 2010 - 20:30:
Czekam aż ktoś poprawi ten kod aż będzie w pełni sprawny :) Bo bardzo mi jest potrzebny :)
  • +
  • -
  • 0

To co piszę się nie liczy...

 


#34 Harsay

    Harsayus pospolitus

  • Autor tematu
  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 14.11.2010 22:52

DarkGL malutki błąd zrobiłeś w set_hudmessage

        set_hudmessage(255, 0, 0, 0.02, 0.23, 0, 0.0, 0.3, 0.0, 0.0);

zmień na:
        set_hudmessage(255, 0, 0, 0.02, 0.23, 0, 0.0, 0.3, 0.0, 3.0);

Wtedy powinno hulać, już dzisiaj nie przetestuje bo muszę spadać.

Dzięki za pomoc.

@offtop
Fajne ascii z pikaczu xD

Użytkownik Harsay edytował ten post 14.11.2010 22:53

  • +
  • -
  • 0

#35 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 14.11.2010 23:13

to jest dobrze holdtime ustawiam na 0.3 można by to krócej napisać
set_hudmessage(255, 0, 0, 0.02, 0.23, 0, 0.0, 0.3);
  • +
  • -
  • 1

#36 ric0

    Wszechwiedzący

  • Power User

Reputacja: 172
Profesjonalista

  • Postów:558
  • Imię:Łukasz
  • Lokalizacja:Ostrołęka
Offline

Napisano 16.11.2010 16:43

Hmm. Podejmie sie kots jeszcze poprawce kodu??

Dodano 19 listopad 2010 - 20:28:
Ref
  • +
  • -
  • 0

To co piszę się nie liczy...

 


#37 Zaszka

    Banned

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:215
  • Imię:Ja
Offline

Napisano 03.12.2010 17:06

Wiec tak sciaglem orgynalny kod Normalnie sie kompiluje (3 Waringi)
Wrzucam na serva i blad :


L 12/03/2010 - 17:05:04: [AMXX] Run time error 10 (plugin "Untitled.amxx") (native "nvault_set") - debug not enabled!
L 12/03/2010 - 17:05:04: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes

Jakies porady ?

#38 radek_b11

    Hero

  • Zbanowany

Reputacja: 29
Życzliwy

  • Postów:1019
  • Lokalizacja:Rajowo
Offline

Napisano 29.12.2010 16:07

naprawi ktoś ten plugin ?

Cs 1.6:   GoldGame.pl [Only DD2/INF/NUK] #1         IP: 31.186.81.62:27062  |  GoldGame.pl [Hns Ganiany][100aa] #2  IP: 31.186.84.46:27074

               GoldGame.pl [Hns Treningowy] #3  IP: 31.186.81.70:27059  |  GoldGame.pl [Unikatowy JailBreak] #4   IP: 31.186.84.46:27050

Ts3:        GoldGame.pl [TeamSpeak3]               IP: 178.217.191.232:6310

Cs:GO:   [PL] GoldGame.pl [Only DD2/INF/NUK][FastDrop]   IP: 185.36.170.231:27024


#39 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 29.12.2010 17:47

Spoiler
a co nie działa :D?
  • +
  • -
  • 0

#40 radek_b11

    Hero

  • Zbanowany

Reputacja: 29
Życzliwy

  • Postów:1019
  • Lokalizacja:Rajowo
Offline

Napisano 01.01.2011 13:37

najwyraźniej nie:

L 01/01/2011 - 13:29:54: Function "eDeath" was not found
L 01/01/2011 - 13:29:54: [AMXX] Displaying debug trace (plugin "explvl.amxx")
L 01/01/2011 - 13:29:54: [AMXX] Run time error 19: function not found
L 01/01/2011 - 13:29:54: [AMXX] [0] explvl.sma::plugin_init (line 44)

Cs 1.6:   GoldGame.pl [Only DD2/INF/NUK] #1         IP: 31.186.81.62:27062  |  GoldGame.pl [Hns Ganiany][100aa] #2  IP: 31.186.84.46:27074

               GoldGame.pl [Hns Treningowy] #3  IP: 31.186.81.70:27059  |  GoldGame.pl [Unikatowy JailBreak] #4   IP: 31.186.84.46:27050

Ts3:        GoldGame.pl [TeamSpeak3]               IP: 178.217.191.232:6310

Cs:GO:   [PL] GoldGame.pl [Only DD2/INF/NUK][FastDrop]   IP: 185.36.170.231:27024





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych