Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Erroor logi


  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 Wiewiorek

    Wszechobecny

  • Zbanowany

Reputacja: 1
Nowy

  • Postów:438
  • Lokalizacja:Wawa
Offline

Napisano 24.10.2009 23:04

Mam problemy z moim servem JailBreak.
Mam taki error log przez to raz na dzien wylacza mi sie serv

L 10/23/2009 - 19:57:34: Start of error session.
L 10/23/2009 - 19:57:34: Info (map "jail_white_new") (file "addons/amxmodx/logs/error_20091023.log")
L 10/23/2009 - 19:57:34: [CSTRIKE] Invalid player 5
L 10/23/2009 - 19:57:34: [AMXX] Run time error 10 (plugin "ctbron.amxx") (native "cs_get_user_team") - debug not enabled!
L 10/23/2009 - 19:57:34: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/23/2009 - 19:57:34: [CSTRIKE] Invalid player 3
L 10/23/2009 - 19:57:34: [AMXX] Run time error 10 (plugin "ctbron.amxx") (native "cs_get_user_team") - debug not enabled!
L 10/23/2009 - 19:57:34: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/23/2009 - 19:57:34: [CSTRIKE] Invalid player 5
L 10/23/2009 - 19:57:34: [AMXX] Run time error 10 (plugin "ctbron.amxx") (native "cs_get_user_team") - debug not enabled!
L 10/23/2009 - 19:57:34: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/23/2009 - 19:57:34: [CSTRIKE] Invalid player 10
L 10/23/2009 - 19:57:34: [AMXX] Run time error 10 (plugin "ctbron.amxx") (native "cs_get_user_team") - debug not enabled!
L 10/23/2009 - 19:57:34: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/23/2009 - 19:57:34: [CSTRIKE] Invalid player 13
L 10/23/2009 - 19:57:34: [AMXX] Run time error 10 (plugin "ctbron.amxx") (native "cs_get_user_team") - debug not enabled!
L 10/23/2009 - 19:57:34: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

proszę o pomoc co mam zrobic no i jest oczywiscie napisane w plugins.ini ctbron.amxx debug

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 25.10.2009 09:11

dopisz do plugins.ini "debug" za ctbron.amxx czyli:
ctbron.amxx debug
no i daj ctbron.sma
  • +
  • -
  • 0

#3 Wiewiorek

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:438
  • Lokalizacja:Wawa
Offline

Napisano 25.10.2009 12:31

sma
#include <amxmodx>
#include <fun>
#include <hamsandwich>
#include <cstrike>

#define PLUGIN "menu broni na spawnie"
#define VERSION "1.0"
#define AUTHOR "naven"


public plugin_init() {
	register_plugin(PLUGIN, VERSION, AUTHOR)
	RegisterHam(Ham_Spawn, "player", "runda", 1);
}
public runda(id){
	set_task(0.1, "menu", id)
}
public menu(id)
{
	if (cs_get_user_team(id) == CS_TEAM_CT)
	{
	new menu = menu_create("yMenu broni","wybor_menu")
	
	menu_additem(menu,"wak47+ dgl + kamizelka i helm","1",0)
	menu_additem(menu,"wwm4a1+ dgl + kamizelka i helm","2",0)
	menu_additem(menu,"wTMP+ dgl + kamizelka i helm ","3",0)
	menu_additem(menu,"wMAC10+ dgl + kamizelka i helm ","4",0)
	menu_additem(menu,"wXM1014+ dgl + kamizelka i helm ","5",0)
	menu_additem(menu,"wSG552+ dgl + kamizelka i helm ","6",0)
	menu_additem(menu,"wAWP+ dgl + kamizelka i helm ","7",0)
	menu_setprop(menu,MPROP_EXIT,MEXIT_ALL)
	menu_display(id,menu,0)
}
}
public wybor_menu(id,menu,item)
{

    if(item==MENU_EXIT)
    {
        menu_destroy(menu)
        return PLUGIN_HANDLED
    }

    new data[6], iName[64]
    new access, callback

    menu_item_getinfo(menu, item, access, data,5, iName, 63, callback);

    new key = str_to_num(data)

    switch(key)
    {
        case 2 : {
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "weapon_m4a1")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_556nato")
		give_item(id, "ammo_556nato")
		give_item(id, "ammo_556nato")
		give_item(id, "item_kevlar")
	}
        case 1 : {
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_ak47")
		give_item(id, "weapon_deagle")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_762nato")
		give_item(id, "ammo_762nato")
		give_item(id, "ammo_762nato")
		give_item(id, "item_kevlar")
	}
        case 3 : {
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "weapon_tmp")
		give_item(id, "ammo_9mm")
		give_item(id, "ammo_9mm")
		give_item(id, "ammo_9mm")
		give_item(id, "ammo_9mm")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "item_kevlar")
	}
	case 4 :{
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "weapon_mac10")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_45acp")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "item_kevlar")
	}
	case 5 : {
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "weapon_xm1014")
		give_item(id, "ammo_buckshot")
		give_item(id, "ammo_buckshot")
		give_item(id, "ammo_buckshot")
		give_item(id, "ammo_buckshot")
		give_item(id, "ammo_buckshot")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "item_kevlar")
	}
	case 6 : {
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "weapon_sg552")
		give_item(id, "ammo_556nato")
		give_item(id, "ammo_556nato")
		give_item(id, "ammo_556nato")
		give_item(id, "ammo_556nato")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "item_kevlar")
	}
	case 7 : {
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "weapon_awp")
		give_item(id, "ammo_338magnum")
		give_item(id, "ammo_338magnum")
		give_item(id, "ammo_338magnum")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		
		give_item(id, "item_kevlar")
	}
    }
    return PLUGIN_HANDLED
}  
/*
		strip_user_weapons(id)
		give_item(id, "weapon_knife")
		give_item(id, "weapon_deagle")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		give_item(id, "ammo_50ae")
		
		give_item(id, "item_kevlar")
*/

Tak jak pisałem zrobiłem ctbron.amxx debug już dawno temu.

Tak mam również z pluginem xredirect.amxx i tak samo dałem debug i dalej się server wyłącza.

#4 DaddyKuba

    Godlike

  • Użytkownik

Reputacja: 253
Wszechwidzący

  • Postów:1227
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Pszczyna
Offline

Napisano 26.10.2009 10:32

Crashe mogą być spowodowane także mapami, tzn. nie które mapy mogą działać ale crashować serwer.
  • +
  • -
  • 0

#5 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 26.10.2009 10:51

debug nie jest magiczną komendą która eliminuje błędy, to tylko daje więcej danych na temat błędu.

Zamień:

if (cs_get_user_team(id) == CS_TEAM_CT)

na:
if (is_user_connecter(id) && cs_get_user_team(id) == CS_TEAM_CT)

  • +
  • -
  • 0

#6 Wiewiorek

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:438
  • Lokalizacja:Wawa
Offline

Napisano 26.10.2009 16:45

Nie da sie tego skompilowac probowalem lokalnie i przez ten kompilator na amxx.pl i dalej nic

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team

/groups/amxmodx/tmp3/textL2aVtC.sma(20) : error 017: undefined symbol "is_user_connecter"

1 Error.
Could not locate output file /home/groups/amxmodx/public_html/websc3/textL2aVtC.amx (compile failed).


#7 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 26.10.2009 17:24

ehh... literówka
zamiast is_user_connected napisałem is_user_connecter
  • +
  • -
  • 0

#8 Wiewiorek

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:438
  • Lokalizacja:Wawa
Offline

Napisano 27.10.2009 15:16

dzięki wielkie, ty to zawsze mi pomozesz :D

Oczywiscie pomogl daje i zapraszam na jaila, ktory sie nie wylacza ^^




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych