Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Inny

Zapytanie HTTP - Błąd 400

inny

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
1 odpowiedź w tym temacie

#1 Ogen Dogen

    Guru

  • Power User

Reputacja: 222
Profesjonalista

  • Postów:713
  • GG:
  • Steam:steam
  • Imię:Marcin
  • Lokalizacja:Dąbrowa Górnicza
Offline

Napisano 10.08.2016 18:21

Witam. Problem pośrednio związany z programowaniem, ale nie znalazłem lepszego działu. Mianowicie nie mogę napisać poprawnego zapytania HTTP.

Obojętnie na jaką stronę je wyślę zawsze dostaje błąd 400 "niepoprawne zapytanie". Docelowo potrzebuje odpytać skrypt PHP, ale aktualnie nawet głównej strony nie mogę pobrać.

Dodatkowo docelowy serwer stoi za CloudFlare (jeśli to ma znaczenie). Zapytanie wysyłałem przez windowsowy Telnet i prosty programik do testowania socketów SocketTest. Efekt ten sam.

np.

GET /index.php HTTP/1.1\r\nHost: amxx.pl\r\nConnection: close\r\n\r\n

Zwraca:

HTTP/1.1 400 Bad Request
Server: nginx/1.9.10
Date: Wed, 10 Aug 2016 17:10:56 GMT
Content-Type: text/html
Content-Length: 173
Connection: close

<html>
<head><title>400 Bad Request</title></head>
<body bgcolor="white">
<center><h1>400 Bad Request</h1></center>
<hr><center>nginx/1.9.10</center>
</body>
</html>


  • +
  • -
  • 0

b_350_20_360204_C20008_FFFFFF_000000.png 193.33.176.115:27015

 

94e23d811c.png

 


#2 l3szcz

    Wszechwidzący

  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:272
  • GG:
  • Imię:Tomek
  • Lokalizacja:Pomorze
Offline

Napisano 19.08.2016 14:51

Za wiki:

 

Błąd 400 - Nieprawidłowe zapytanie – żądanie nie może być obsłużone przez serwer z powodu nieprawidłowości postrzeganej jako błąd użytkownika (np. błędna składnia zapytania)

 


  • +
  • -
  • 0
Zanim napiszesz wiedz, że nie toleruje dzieci Neo i pomagam odpłatnie ;]

Dołączona grafika

Pisząc do mnie "Cześć, Hej, Jesteś" bez podania informacji o tym czego dokładnie chcesz - skazujesz siebie na ignorowanie! :giggle:





Również z jednym lub większą ilością słów kluczowych: inny

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych