Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Brak zmiany skina przy podniesieniu


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 zasepa

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:49
  • Lokalizacja:polska
Offline

Napisano 11.05.2016 21:51

Witam

Mam pewien problem. Potrzebuje aby gdy gracz podniesie lub zmieni bron to ma się zmienić jej skin. Zmianę udało mi się ogarnąć gorzej z podniesieniem. Gdy gracz podnosi bron to skin jej się nie zmienia.

 

Do plugin _init:

register_event("WeapPickup", "weapon_skin_pick", "b")

Gdzieś tam w kodzie:

public weapon_skin_pick(id)
{
	new weapon_id = read_data(1) // id broni	
	if(weapon_id == CSW_AWP){
		entity_set_string(id, EV_SZ_viewmodel, "models/testowo/AWP/v_Green_glass.mdl")  
		entity_set_string(id, EV_SZ_weaponmodel, "models/testowo/AWP/p_Green_glass.mdl")  
	//	set_pev(id, pev_viewmodel2, "models/testowo/AWP/v_Green_glass.mdl")
	//	set_pev(id, pev_weaponmodel2, "models/testowo/AWP/p_Green_glass.mdl")	
	}
}

Testowałem z engine i z fakemeta i w żadnym z przypadku nie działa.

Podniesiona broń nie zmienia skinu.

Uwaga: Uprzedzam że skin jest wgrany i działa. gdyż w innym kodzie na zmianę broni skin się zmienia pomyślnie. Nie działa jak widać tylko przy podniesieniu. Po wywaleniu if również nie działa.

Proszę o pomoc

 


  • +
  • -
  • 0

#2 camilost

    ^ BotQ - STER.owiec ^

  • Power User

Reputacja: 430
Wszechobecny

  • Postów:968
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Tychy
Offline

Napisano 12.05.2016 08:40

Podniesienie broni a takze kupienie. Na starcie rundy sie uruchomi gdy dostajemy noz i pistolet (2 razy). Jest wywolywany takze gdy kupimy cos, ale nie bedziemy mieli tego w rekach (np. granat).

 

Spróbuj korzystając z set_pev(id, pev_viewmodel2, "models/testowo/AWP/v_Green_glass.mdl");


  • +
  • -
  • 1

#3 zasepa

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:49
  • Lokalizacja:polska
Offline

Napisano 12.05.2016 09:05

 

Podniesienie broni a takze kupienie. Na starcie rundy sie uruchomi gdy dostajemy noz i pistolet (2 razy). Jest wywolywany takze gdy kupimy cos, ale nie bedziemy mieli tego w rekach (np. granat).

 

Spróbuj korzystając z set_pev(id, pev_viewmodel2, "models/testowo/AWP/v_Green_glass.mdl");

 

To na zakomentowane linie w kodzie uwagi się nie zwraca?

Tam widnieje właśnie "set_pev" i pisałem że to też nie działa mi.

Proszę o pomoc


  • +
  • -
  • 0

#4 Asiap

    Wszechwidzący

  • Girl

Reputacja: 139
Zaawansowany

  • Postów:275
  • Lokalizacja:Kętrzyn
Offline

Napisano 12.05.2016 09:26

register_event("WeapPickup", "weapon_skin_pick", "be")

 
a najlepiej bez sprawdzania id broni w publicku tylko od razu ustalenie w hooko'owaniu:

register_event("WeapPickup", "weapon_skin_pick", "be", "1=18")

public weapon_skin_pick(id)
{
	entity_set_string(id, EV_SZ_viewmodel, "models/testowo/AWP/v_Green_glass.mdl")  
	entity_set_string(id, EV_SZ_weaponmodel, "models/testowo/AWP/p_Green_glass.mdl")  
	//set_pev(id, pev_viewmodel2, "models/testowo/AWP/v_Green_glass.mdl")
	//set_pev(id, pev_weaponmodel2, "models/testowo/AWP/p_Green_glass.mdl")	
}

  • +
  • -
  • 1

#5 zasepa

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:49
  • Lokalizacja:polska
Offline

Napisano 12.05.2016 11:36

Niestety nie działa

 

 

Pozmieniałem trochę:

register_event("WeapPickup", "weapon_skin_pick", "be")
public weapon_skin_pick(id)
{
	set_pev(id, pev_viewmodel2, "models/testowo/AWP/v_Green_glass.mdl")
	set_pev(id, pev_weaponmodel2, "models/testowo/AWP/p_Green_glass.mdl")	
}

Czyli ten event się wykona jeżeli podniosę jaką kolwiek bron. Nawet oprócz awp. co ciekawe nie ma żadnych errorów podczas podnoszenia oraz co dziwne.

Jeżeli podniosę awp oraz pistolet równocześnie to awp zmienia poprawnie skin.

A jeżeli będzie niewielka różnica w czasie czyli pistolet będzie leżał obok awp to już nie zadziała. Pistolet musi leżeć w awp to wtedy działa.

Czyli co? Za wcześnie skin jest dawany? 

Proszę o pomoc

Albo czy jest coś innego co pozwoliło by mi zmieniać skin przy zmianie broni oraz przy podnoszeniu.

 


  • +
  • -
  • 0

#6 Asiap

    Wszechwidzący

  • Girl

Reputacja: 139
Zaawansowany

  • Postów:275
  • Lokalizacja:Kętrzyn
Offline

Napisano 13.05.2016 05:28

Uzyj Ham_Item_Deploy z hamsandwich


  • +
  • -
  • 1

#7 zasepa

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:49
  • Lokalizacja:polska
Offline

Napisano 13.05.2016 07:54

Używam tego tylko że to nie wywołuje eventu jak gracz podniesie broń. Dlatego chciałem to połączyć z tym eventem o którym pisałem wyżej.

Dziwne ale jak dodałem set_task z czasem"0.0" do kolejnej funkcji i dopiero w niej dawanie skina to zaczęło chodzić poprawnie.

Testuje czy rzeczywiście poprawnie działa.


  • +
  • -
  • 0

#8 Asiap

    Wszechwidzący

  • Girl

Reputacja: 139
Zaawansowany

  • Postów:275
  • Lokalizacja:Kętrzyn
Offline

Napisano 13.05.2016 17:46

Ham_Item_Deploy wykonuje sie gdy gracz wyciagnie przedmiot wiec czy to podniesienie czy wyciagniecie z 'plecaka' to nie ma znaczenia

o ile po podniesieniu przedmiot trafia od razu do reki


  • +
  • -
  • 1

#9 zasepa

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:49
  • Lokalizacja:polska
Offline

Napisano 13.05.2016 18:39

No właśnie że u mnie jest to inaczej. Działa tylko przy zmianie lub gdy dostaje na początku. ale na podniesienie nie działało. Hmm potestuje.


  • +
  • -
  • 0

#10 grankee

    Godlike

  • Support Team

Reputacja: 507
Wszechwiedzący

  • Postów:1500
  • Lokalizacja:Radom
Offline

Napisano 26.05.2016 01:48

ham_setusermaxspeed?

event curweapon?


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych