Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

Błąd instalacji AMXBansa (PHP)

gmamxbans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 Poftorek

    Zaawansowany

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:92
  • GG:
  • Imię:Damian
  • Lokalizacja:Polska Wieś
Offline

Napisano 17.10.2015 11:14

Witam, mam problem, gdyż mam forum na mybb, wersja php nie zmieniona.

Zainstalowałem sobie mybb na proserwer (XAA), dvz_shoutbox oraz inne pluginy, wersji php nie zmieniałem.

Chciałem zainstalować amxbansa i wyskakują errory, spowodowane złą wersją php.

 

I teraz pytanie jak pogodzić dvz_shoutbox (mybb 1.8) oraz GmAMXBans 1.6 jedną wersją php nie da się niestety :C


  • +
  • -
  • 0

#2 Fatality Kill

    Życzliwy

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:28
  • Lokalizacja:Trzcianka
Offline

Napisano 17.10.2015 16:28

Przetestowałem i u mnie wszystko się sprawdza. Napisz dokładnie jaki wyskakuje Ci błąd.


  • +
  • -
  • 0

#3 Poftorek

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 3
Nowy

  • Postów:92
  • GG:
  • Imię:Damian
  • Lokalizacja:Polska Wieś
Offline

Napisano 17.10.2015 17:42

Po zainstalowaniu:

 

Warning: Creating default object from empty value in /home/zjaranis/public_html/bany/include/config.inc.php on line 7

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/include/config.inc.php on line 46

Warning: Cannot modify header information - headers already sent by (output started at /home/zjaranis/public_html/bany/include/config.inc.php:7) in /home/zjaranis/public_html/bany/index.php on line 38

 

 

Strona:

http://zjarani-skillem.pl/bany


  • +
  • -
  • 0

#4 Misiaczek ;c

    /dev/null

  • Moderator

Reputacja: 1662
Godlike

  • Postów:2495
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Halemba
Offline

Napisano 17.10.2015 22:28

Po zainstalowaniu:

 

Warning: Creating default object from empty value in /home/zjaranis/public_html/bany/include/config.inc.php on line 7

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/include/config.inc.php on line 46

Warning: Cannot modify header information - headers already sent by (output started at /home/zjaranis/public_html/bany/include/config.inc.php:7) in /home/zjaranis/public_html/bany/index.php on line 38

 

 

Strona:

http://zjarani-skillem.pl/bany

 

Otwórz plik index.php

Znajdź

<?php

dopisz pod tym to

ob_start();

powinno to wyglądać tak

<?php
ob_start();

następnie znajdź 

?>

dopisz przed tym to

ob_end_flush();

powinno to wyglądać tak

ob_end_flush();
?>

Zapisz plik i podmień ;)

 

Otwórz plik config.inc.php

znajdź

$config->v_web = "1.6";

dopisz przed tym to

$config = new stdClass();

powinno to wyglądać tak

$config = new stdClass();
$config->v_web = "1.6";

Zapisz plik i podmień ;)


  • +
  • -
  • 0

#5 Poftorek

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 3
Nowy

  • Postów:92
  • GG:
  • Imię:Damian
  • Lokalizacja:Polska Wieś
Offline

Napisano 18.10.2015 10:44

Po zalogowaniu jako admin: (po powrocie do głównej strony, zalogowany jestem) (SCREEN: http://scr.hu/9i6i/zewrs)

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/include/config.inc.php on line 47

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/login.php on line 26

Warning: Cannot modify header information - headers already sent by (output started at /home/zjaranis/public_html/bany/include/config.inc.php:1) in /home/zjaranis/public_html/bany/login.php on line 89

 

 

 

Strona główna:  (SCREEN: http://scr.hu/9i6i/w20ag)

Błąd config.inc.php -  $config->db_host=getipbyhost($config->db_host);

 

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/include/config.inc.php on line 47

 

 

 

 

Strefa Adminów (page default): (SCREEN: http://scr.hu/9i6i/srcsj)
 

 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/zjaranis/public_html/bany/include/smarty/Smarty_Compiler.class.php on line 270

 

 

 

 

Wylogowanie: (SCREEN: http://scr.hu/9i6i/19zbg

 

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/include/config.inc.php on line 47

Warning: Cannot modify header information - headers already sent by (output started at /home/zjaranis/public_html/bany/include/config.inc.php:1) in /home/zjaranis/public_html/bany/logout.php on line 7

Warning: Cannot modify header information - headers already sent by (output started at /home/zjaranis/public_html/bany/include/config.inc.php:1) in /home/zjaranis/public_html/bany/logout.php on line 24

 

 

 

 

Zmiana stylu z default na DarkGold: (SCREEN: http://scr.hu/9i6i/ddcjq)

 

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/zjaranis/public_html/bany/include/config.inc.php on line 47

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/zjaranis/public_html/bany/include/smarty/Smarty_Compiler.class.php on line 270

 

Dodatkowe info:

 

Usunąłem version checker z amxbans.js.php.

Strona główna: http://zjarani-skill...ny/ban_list.php


  • +
  • -
  • 0

#6 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 18.10.2015 10:49

Informacje typu "Deprecated: mysql_connect()" będziesz miał, bo tak już jest napisany amxbans, że używa starych metod, tutaj może pomóc albo przepisanie tego pod najnowszego php, albo wyłączenie tych informacji od strony php, ale to już musisz sam poszukać jak to wyłączyć, bo sam dokładnie nie wiem, ale zapewne zrobisz to w pliku php.ini.
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#7 Poftorek

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 3
Nowy

  • Postów:92
  • GG:
  • Imię:Damian
  • Lokalizacja:Polska Wieś
Offline

Napisano 18.10.2015 11:27

A nie da się tego inaczej zrobic? Ktoś ma inny pomysł?


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: gmamxbans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych