Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Problem z errorami [Display_Fade] oraz Początkiem Rundy

cod nowy

Najlepsza odpowiedź radim, 13.11.2014 09:13


Znalazłem rozwiązanie w tym temacie : http://amxx.pl/topic...26-id-0-crashe/
Ale jednak jak dodaje kod Darka mam problem 

Error: Undefined symbol "Display_Fade" on line 403
Warning: Symbol is assigned a value that is never used: "MsgScreenfade" on line 1743

Pewnie nadmnieniłeś stocki, ale nie zmieniłeś Display_Fade na Create_ScreenFade w funkcji Poczatek_Rundy. Przejdź do postu


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
2 odpowiedzi w tym temacie

#1 Warjat

    Profesjonalista

  • Użytkownik

Reputacja: 25
Życzliwy

  • Postów:193
  • Lokalizacja:Warszawa
Offline

Napisano 12.11.2014 10:16

L 11/12/2014 - 08:50:47: Plugin called message_begin with an invalid message id (0).
L 11/12/2014 - 08:50:47: [AMXX] Displaying debug trace (plugin "CODMOD.amxx")
L 11/12/2014 - 08:50:47: [AMXX] Run time error 10: native error (native "message_begin")
L 11/12/2014 - 08:50:47: [AMXX]    [0] CODMOD.sma::Display_Fade (line 1567)
L 11/12/2014 - 08:50:47: [AMXX]    [1] CODMOD.sma::PoczatekRundy (line 400)
public PoczatekRundy()	
{
	freezetime = false;
	for(new id=0;id<=32;id++)
	{
		if(!is_user_alive(id))
			continue;

		Display_Fade(id, 1<<9, 1<<9, 1<<12, 0, 255, 70, 100); // Błąd
		
		set_task(0.1, "UstawSzybkosc", id+ZADANIE_USTAW_SZYBKOSC);
		set_task(5.0, "Regeneracja", id+TASK_REGENERACJA);
		
		switch(get_user_team(id))
		{
			case 1: client_cmd(id, "spk CodMod_Sound/start2");
			case 2: client_cmd(id, "spk CodMod_Sound/start");
		}
	}
}
stock Display_Fade(id,duration,holdtime,fadetype,red,green,blue,alpha)
{
	message_begin( MSG_ONE, MsgScreenfade,{0,0,0},id ); // Błąd
	write_short( duration );	// Duration of fadeout
	write_short( holdtime );	// Hold time of color
	write_short( fadetype );	// Fade type
	write_byte ( red );		// Red
	write_byte ( green );		// Green
	write_byte ( blue );		// Blue
	write_byte ( alpha );	// Alpha
	message_end();
}

Znalazłem rozwiązanie w tym temacie : http://amxx.pl/topic...26-id-0-crashe/

Ale jednak jak dodaje kod Darka mam problem 

Error: Undefined symbol "Display_Fade" on line 403
Warning: Symbol is assigned a value that is never used: "MsgScreenfade" on line 1743

A j/w w temacie przed postem Darka jest jeszcze inne rozwiązanie chodź mam już to dodane to nie wiem czy mam podmienić? 

new MsgScreenfade;
public plugin_init()
MsgScreenfade = get_user_msgid("ScreenFade");

Może ktoś pomóc ?


  • +
  • -
  • 0

#2 radim

    Godlike

  • Moderator

Reputacja: 932
Master

  • Postów:2725
  • Steam:steam
  • Imię:Arkadiusz
  • Lokalizacja:Janów Lub.
Offline

Napisano 13.11.2014 09:13   Najlepsza odpowiedź


Znalazłem rozwiązanie w tym temacie : http://amxx.pl/topic...26-id-0-crashe/
Ale jednak jak dodaje kod Darka mam problem 

Error: Undefined symbol "Display_Fade" on line 403
Warning: Symbol is assigned a value that is never used: "MsgScreenfade" on line 1743

Pewnie nadmnieniłeś stocki, ale nie zmieniłeś Display_Fade na Create_ScreenFade w funkcji Poczatek_Rundy.
  • +
  • -
  • 0

Chcąc napisać do mnie prywatną wiadomość, wpierw zapoznaj się ze stroną "O mnie" w moim profilu użytkownika [ radim ] !


#3 Warjat

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 25
Życzliwy

  • Postów:193
  • Lokalizacja:Warszawa
Offline

Napisano 13.11.2014 22:33

 


Znalazłem rozwiązanie w tym temacie : http://amxx.pl/topic...26-id-0-crashe/
Ale jednak jak dodaje kod Darka mam problem 
Error: Undefined symbol "Display_Fade" on line 403
Warning: Symbol is assigned a value that is never used: "MsgScreenfade" on line 1743

Pewnie nadmnieniłeś stocki, ale nie zmieniłeś Display_Fade na Create_ScreenFade w funkcji Poczatek_Rundy.

 

Rozwiązane już wcześniej 


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych