Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z hudsync


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Ziolek

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Kacper
  • Lokalizacja:Sosnowiec
Offline

Napisano 06.02.2014 19:14

Witam czy mógł by mi ktoś pomóc z tym błędem? bo niestety nie wiem czemu ale to crashuje mi serwer

 

dziękuje oraz pozdrawiam

 

 

 

L 02/05/2014 - 21:09:06: HudSyncObject -1 is invalid
L 02/05/2014 - 21:09:06: [AMXX] Displaying debug trace (plugin "Zombie_TheHeroEX.amxx")
L 02/05/2014 - 21:09:06: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 02/05/2014 - 21:09:06: [AMXX]    [0] Zombie_TheHeroEX.sma::Show_Scorehud (line 1130)
L 02/05/2014 - 21:09:06: [AMXX]    [1] Zombie_TheHeroEX.sma::Event_Time (line 993)

 

SHOW_SCOREHUD

public Show_Scorehud()
{
    static ScoreHud[80]
    
    formatex(ScoreHud, sizeof(ScoreHud), "%L", LANG_OFFICIAL, "GAME_SCOREHUD1", g_Round)
    set_dhudmessage(250, 250, 250, SCORE_HUD_X, SCORE_HUD_Y, 0, 2.0, 2.0)
    show_dhudmessage(0, ScoreHud)
    
    formatex(ScoreHud, sizeof(ScoreHud), "%L", LANG_OFFICIAL, "GAME_SCOREHUD2", g_TeamScore[TEAM_ZOMBIE], g_TeamScore[TEAM_HUMAN])
    set_hudmessage(250, 250, 250, SCORE_HUD_X, SCORE_HUD_Y, 0, 2.0, 2.0)
    ShowSyncHudMsg(0, g_SyncHud_Score, ScoreHud)
}

 

EVENT_TIME

public Event_Time()
{
    if(!g_Game_PlayAble && GetPlayerCount(0) >= MIN_PLAYER)
    {
        g_Game_PlayAble = 1
        TerminateRound(TEAM_START)
    }
    
    // Loop
    for(new i = 0; i < g_MaxPlayers; i++)
    {
        if(!is_user_connected(i))
            continue
        if(!is_user_alive(i))
            continue
            
        Show_EvolHud(i)
        ExecuteForward(g_Forward[FWD_SKILL_SHOW], g_fwResult, i, Get_BitVar(g_IsZombie, i) ? 1 : 0)
    }
    
    Show_Scorehud()
    Check_Gameplay()
    
    // Exec
    ExecuteForward(g_Forward[FWD_TIME_CHANGE], g_fwResult)
}

  • +
  • -
  • 0

#2 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 06.02.2014 20:06

Czy g_SyncHud_Score jest odpowiednio zadeklarowany i przypisana do niego wartość? 


  • +
  • -
  • 1

b_560_95_1.png


#3 Ziolek

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Kacper
  • Lokalizacja:Sosnowiec
Offline

Napisano 06.02.2014 20:28

myślę że tak

 

new g_SyncHud_Score
 
g_SyncHud_Score = CreateHudSyncObj(1)

  • +
  • -
  • 0

#4 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 07.02.2014 08:38

nie wiem po co ta 1 w parametrze ale to pewnie z mojej niewiedzy wynika. Pokaż całe logi przy zmianie mapy - błąd z nieprawidłowym obiektem HUD który kiedyś miałem w starym Codzie był wtedy gdy zapomniałem przed deklaracją obiektu był błąd i on się nie zadeklarował. Nie powodował on wywalenia serwera , natomiast zasypaną konsole.


  • +
  • -
  • 0

b_560_95_1.png


#5 Ziolek

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • Imię:Kacper
  • Lokalizacja:Sosnowiec
Offline

Napisano 07.02.2014 17:17

Niestety to wszystkie logi które są one się powtarzają i nic więcej proszę o pomoc :)


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych