Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

serwer nie łączy z amxbansem

gmamxbans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
7 odpowiedzi w tym temacie

#1 Carbon

    Profesjonalista

  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:170
  • Imię:Kuba
  • Lokalizacja:Warsaw
Offline

Napisano 05.01.2014 15:24

Wszystko podłączone jak powinno, wiem bo nie raz już to robiłem.

Tylko, że tym razem pojawił się taki error:

L 01/05/2014 - 15:30:03: Start of error session.
L 01/05/2014 - 15:30:03: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20140105.log")
L 01/05/2014 - 15:30:03: [MySQL] Invalid info tuple handle: 0
L 01/05/2014 - 15:30:03: [AMXX] Run time error 10 (plugin "amxbans_core.amxx") (native "SQL_Connect") - debug not enabled!
L 01/05/2014 - 15:30:03: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

 


Użytkownik Carbon edytował ten post 05.01.2014 15:31

  • +
  • -
  • 0

Jeżeli Ci pomogłem, nie wahaj się i naciśnij  repup.jpg

 

 

Nie kłóć się z debilem.

Najpierw sprowadzi Cię do swojego poziomu, a następnie pokona doświadczeniem.


#2 Carbon

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:170
  • Imię:Kuba
  • Lokalizacja:Warsaw
Offline

Napisano 05.01.2014 15:55

Nie mogę już edytować tak więc podrzucam nowe logi:

L 01/05/2014 - 15:53:13: Start of error session.
L 01/05/2014 - 15:53:13: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20140105.log")
L 01/05/2014 - 15:53:13: [MySQL] Invalid info tuple handle: 0
L 01/05/2014 - 15:53:13: [AMXX] Run time error 10 (plugin "amxbans_core.amxx") (native "SQL_Connect") - debug not enabled!
L 01/05/2014 - 15:53:13: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 01/05/2014 - 15:53:34: Function is not present (function "check_player") (plugin "amxbans_main.amxx")
L 01/05/2014 - 15:53:34: [AMXX] Displaying debug trace (plugin "amxbans_main.amxx")
L 01/05/2014 - 15:53:34: [AMXX] Run time error 10: native error (native "set_task")
L 01/05/2014 - 15:53:34: [AMXX]    [0] amxbans_main_1980379.sma::client_authorized (line 289)

  • +
  • -
  • 0

Jeżeli Ci pomogłem, nie wahaj się i naciśnij  repup.jpg

 

 

Nie kłóć się z debilem.

Najpierw sprowadzi Cię do swojego poziomu, a następnie pokona doświadczeniem.


#3 Don Komar

    Życzliwy

  • Zbanowany

Reputacja: 5
Nowy

  • Postów:25
  • GG:
  • Steam:steam
  • Lokalizacja:Wszędzie :D
Offline

Napisano 05.01.2014 16:41

Wgraj te pluginy. Sprawdzone na własnym serwerze.

Załączone pliki



#4 skibos

    Zaawansowany

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:121
  • Lokalizacja:Grudziądz
Offline

Napisano 05.01.2014 17:14

i dodaj do plugins.ini przed admin.amxx

 

Podaj co masz w konsoli serwera


  • +
  • -
  • 0

Cs-lod.com.pl


#5 Carbon

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:170
  • Imię:Kuba
  • Lokalizacja:Warsaw
Offline

Napisano 13.01.2014 15:26

Niestety nadal nic, tak mam ustawione:

amx_sql_host	"localhost"
amx_sql_user	"w301_bany"
amx_sql_pass	"hasło"
amx_sql_db	"w301_amxbans"
amx_sql_table	"admins"
amx_sql_type	"mysql"
;AMX Mod X plugins

; Admin Base - Always one has to be activated
amxbans_core.amxx		; amxbans
amxbans_main.amxx debug	; amxbans
;admin.amxx             ; admin base (required for any admin-related)
admin_sql.amxx          ; admin base - SQL version (comment admin.amxx)

; Basic
admincmd.amxx		; basic admin console commands
adminhelp.amxx		; help command for admin console commands
adminslots.amxx		; slot reservation
multilingual.amxx	; Multi-Lingual management

Error:

L 01/13/2014 - 15:19:19: Start of error session.
L 01/13/2014 - 15:19:19: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20140113.log")
L 01/13/2014 - 15:19:19: [MySQL] Invalid info tuple handle: 0
L 01/13/2014 - 15:19:19: [AMXX] Run time error 10 (plugin "amxbans_core.amxx") (native "SQL_Connect") - debug not enabled!
L 01/13/2014 - 15:19:19: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Logi: 

L 01/13/2014 - 15:24:58: -------- Mapchange to de_dust2 --------
L 01/13/2014 - 15:24:58: [amxbans_core.amxx] [AMXBans] WARNING: admin_sql.amxx plugin running! Stopped.
L 01/13/2014 - 15:24:58: [amxbans_main.amxx] [AMXBans] Connection failed!
L 01/13/2014 - 15:24:58: [amxbans_main.amxx] [AMXBans] Threaded Query Error, Place: 1
L 01/13/2014 - 15:24:58: [amxbans_main.amxx] [AMXBans] Message: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (2002)
L 01/13/2014 - 15:24:58: [amxbans_main.amxx] [AMXBans] Query statement: SELECT `motd_delay` FROM `amx_serverinfo` WHERE address = '178.19.106.148:27091'
L 01/13/2014 - 15:24:59: [amxbans_main.amxx] [AMXBans] Connection failed!
L 01/13/2014 - 15:24:59: [amxbans_main.amxx] [AMXBans] Threaded Query Error, Place: 5
L 01/13/2014 - 15:24:59: [amxbans_main.amxx] [AMXBans] Message: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (2002)
L 01/13/2014 - 15:24:59: [amxbans_main.amxx] [AMXBans] Query statement: 
L 01/13/2014 - 15:24:59: [amxbans_main.amxx] [AMXBans] No Reasons found in Database. Static reasons were loaded instead.

  • +
  • -
  • 0

Jeżeli Ci pomogłem, nie wahaj się i naciśnij  repup.jpg

 

 

Nie kłóć się z debilem.

Najpierw sprowadzi Cię do swojego poziomu, a następnie pokona doświadczeniem.


#6 Zabijaka Gryps

    Wszechwiedzący

  • Power User

Reputacja: 266
Wszechwidzący

  • Postów:563
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Świdnica
Offline

Napisano 13.01.2014 15:42

Błędny host. Nie będzie to localhost. Spróbuj wpisać tam adres strony, do której jest ta baza. Pamiętaj też o dodaniu zezwolenia na łączenie z bazą z ip serwera.
  • +
  • -
  • 1

#7 Carbon

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:170
  • Imię:Kuba
  • Lokalizacja:Warsaw
Offline

Napisano 13.01.2014 15:58

Błędny host. Nie będzie to localhost. Spróbuj wpisać tam adres strony, do której jest ta baza. Pamiętaj też o dodaniu zezwolenia na łączenie z bazą z ip serwera.

Masz racje, gdzieś wyczytałem, że na tej bazie musi pisać "localhost" ale jednak nie, plusik dla Ciebie. ;)


  • +
  • -
  • 0

Jeżeli Ci pomogłem, nie wahaj się i naciśnij  repup.jpg

 

 

Nie kłóć się z debilem.

Najpierw sprowadzi Cię do swojego poziomu, a następnie pokona doświadczeniem.


#8 skibos

    Zaawansowany

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:121
  • Lokalizacja:Grudziądz
Offline

Napisano 13.01.2014 16:02

tak jak kolega, dodaj zamiast loclhost swoją stronkę na której masz bazę.

 

Dodaj uprawnienia do bazy z zewnątrz, CPanel, menadżer zdalnego zarządzania Mysql i dodaj tam %

 

Jeśli nie pokaż plik modules.ini

 

Musisz mieć tam odblokowane pierwsze 2 moduły czyli mysql oraz sqllite chyba.


  • +
  • -
  • 0

Cs-lod.com.pl






Również z jednym lub większą ilością słów kluczowych: gmamxbans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych