Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Stary

Problem plugin - połączenie z bazą danych

CoD Stary

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 Scorpion Flail

    Wszechobecny

  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 19.08.2013 21:16

Witam.

Posiadam CoD MoD stary do którego był robiony zapis lvl do bazy.

Niestety plugin nie chce w ogóle łączyć z bazą:

L 08/14/2013 - 17:40:14: [cod_4001(4).amxx] [ startSQLHandle ] Query failed: 
L 08/14/2013 - 17:40:14: [cod_4001(4).amxx] [ startSQLHandle ] Couldn't connect with db

Hosting unixstorm, zezwolenia hosta dawałem, próbowałem też z %, bez skutku. Sprawdzałem również na 2 serwerach hlds z różnych hostingów.

 

Części kodu odpowiadająca za połączenie:

pCvarHost = register_cvar( "sql_save_host" , "host" );
    pCvarUser = register_cvar( "sql_save_user" , "user" );
    pCvarPass = register_cvar( "sql_save_pass" , "pass" );
    pCvarDB = register_cvar( "sql_save_db" , "db" );
public plugin_cfg(){

    
    new szHost[ 256 ],
        szUser[ 256 ],
        szPass[ 256 ],
        szDB[ 256 ];
        
    get_pcvar_string( pCvarHost , szHost , charsmax( szHost ) );
    get_pcvar_string( pCvarUser , szUser , charsmax( szUser ) );
    get_pcvar_string( pCvarPass , szPass , charsmax( szPass ) );
    get_pcvar_string( pCvarDB , szDB , charsmax( szDB ) );
    
    tupleSQL = SQL_MakeDbTuple( szHost , szUser , szPass , szDB );
    
    startSQL()
}
public startSQLHandle(FailState, Handle:Query, Errorcode, Error[], Data[], DataSize){
    if(Errorcode)
        log_amx("[ startSQLHandle ] Query failed: %s", Error)
    
    if(FailState == TQUERY_CONNECT_FAILED){
    
        log_amx("[ startSQLHandle ] Couldn't connect with db")
        
        return PLUGIN_CONTINUE;
    }
    else if(FailState == TQUERY_QUERY_FAILED){
    
        log_amx("[ startSQLHandle ] Query failed");
        
        return PLUGIN_CONTINUE;
    }
    
    return PLUGIN_CONTINUE;
}

Tworzenie tabeli:

public startSQL(){
    SQL_ThreadQuery( tupleSQL , "startSQLHandle" , "CREATE TABLE IF NOT EXISTS codLVL ( name TEXT NOT NULL , class INT , experience INT , lvl INT , intelligence INT , health INT , durability int , condition int , protect int , experiencePoints int, PRIMARY KEY ( name ) )" );
}


#2 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 20.08.2013 12:22

Automatyczna wiadomość


Ten temat został przeniesiony z forum

Scripting AMXXProblemy

do

ModyCall of Duty ModProblemy
  • +
  • -
  • 0

DarkGL to mój autorytet.


#3 BlackPerfum

    Pseudo interakcja??

  • Power User

Reputacja: 453
Wszechobecny

  • Postów:575
  • Lokalizacja:...
Offline

Napisano 22.08.2013 18:13

L 08/14/2013 - 17:40:14: [cod_4001(4).amxx] [ startSQLHandle ] Couldn't connect with db

Serwer nie może się połączyć z bazą danych. Nie wina zapytań czy pluginu. Sprawdź czy cvary poprawnie uzupełnione i czy samemu możesz się połączyć z bazą danych. Oraz czy na twoim hoście istnieje baza danych o nazwie zawartej w cvarze: "sql_save_db"


  • +
  • -
  • 0
Chcesz napisać do mnie na PW to:
Spoiler

Mój tok myślenia jest błędny? Wskaż mi błąd zmienie to!

Aktualnie bije limit 32 graczy (łącze serwery) ale nadal są lagi przy zbyt dużym przesyłu informacji Dołączona grafika
Gra się płynnie do 40~50 graczy potem łącze pada i zamiast biegać ludzie się teleportują Dołączona grafika

#4 Scorpion Flail

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 22.08.2013 23:35

Serwer nie może się połączyć z bazą danych. Nie wina zapytań czy pluginu. Sprawdź czy cvary poprawnie uzupełnione i czy samemu możesz się połączyć z bazą danych. Oraz czy na twoim hoście istnieje baza danych o nazwie zawartej w cvarze: "sql_save_db"

 

 

Takie banały były dokładnie sprawdzane. Dane do bazy probówalem zarówno przez cvara jak i amxx.cfg + sprawdzałem cvarami na serwerze czy się zgadzają.

Z bazą danych bez problemu łączę się z mysql font.

 

Serwer bez problemu łączy się z amxbans, który stoi na tym samym hoście.

 

Wina musi leżec po stronie kodu pluginu.



#5 .K3K

    Ja tu tylko sprzątam :s

  • Zbanowany

Reputacja: 46
Pomocny

  • Postów:263
  • Imię:Karol
  • Lokalizacja:Poznań
Offline

Napisano 24.08.2013 18:05

sprawdź moduły :)
b_350_20_18CE03_051005_FFFFFF_111111.png

#6 Scorpion Flail

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 24.08.2013 20:17

MySQL                   1.8.1.3710  AMX Mod X Dev Team   running    
SQLite                  1.8.1.3710  AMX Mod X Dev Team   running    
Fun                     1.8.1.3710  AMX Mod X Dev Team   running    
Engine                  1.8.1.3710  AMX Mod X Dev Team   running    
FakeMeta                1.8.1.3711  AMX Mod X Dev Team   running    
GeoIP                   1.8.1.3710  AMX Mod X Dev Team   running    
nVault                  1.8.1.3710  AMX Mod X Dev Team   running    
CStrike                 1.8.1.3710  AMX Mod X Dev Team   running    
CSX                     1.8.1.3710  AMX Mod X Dev Team   running    
Ham Sandwich            1.8.1.3710  AMX Mod X Dev Team   running    
Sockets                 1.8.1.3710  HLSW Dev Team        running    
RegEx                   1.8.1.3710  AMX Mod X Dev Team   running 

To na pewno nie wina modułów.

 

Jeszcze raz przeanalizowałem logi. Błąd Couldn't connect with db występuje tylko za pierwszym razem po uruchomieniu serwera do końca mapy.

Po zmianie mapy(i kolejnych) zostaje już tylko błąd:

Query failed:

Błąd chyba tkwi w tworzeniu tabeli - brak w tym atrybutów. Gdy ręcznie tworzyłem zapytanie sql miałem taki błąd:

#1170 - BLOB column 'name' used in key specification without a key length

Proszę kogoś o pomoc


Użytkownik Scorpion Flail edytował ten post 24.08.2013 20:32






Również z jednym lub większą ilością słów kluczowych: CoD Stary

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych