Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Użycie submodela


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 pewex

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:27
  • Lokalizacja:ijijijiji
Offline

Napisano 30.11.2012 17:38

Witam, posiadam jeden model z funkcja pakietu submodelów, który zawiera: Submodel 1, Submodel 2, Submodel 3, Submodel 4. Posiadam moda jailbreak

Chciałem nadac Submodel 2 dla druzyny CT:


//precache
	precache_model("models/player/MODEL_TEST/MODEL_TEST.mdl");


// wycinek kodu z publica

  }
  case CS_TEAM_CT:
  {
   gTeam[id] = 2;
  
   cs_set_player_model(id, "MODEL_TEST")
   set_user_info(id, "model", "MODEL_TEST") // potrzebne aby ustawiło także model
   entity_set_int(id, EV_INT_body, 2) // numer sub modelu
   get_user_team(id) == 1 ? entity_set_int(id, EV_INT_skin, 0) : entity_set_int(id, EV_INT_skin, 4)


Po powyższej edycji ze zwykłej podmiany standardowego modelu na sub model - ustawiony model dla ct - nie dziala. Pobiera się lecz ct jest przezroczysty, a nie posiada modelu ktory wyznaczylem - czyli submodel 2 modelu MODEL_TEST.


proszę o pomoc

Użytkownik pewex edytował ten post 30.11.2012 17:40

  • +
  • -
  • 0

#2 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 30.11.2012 17:39

Automatyczna wiadomość


Ten temat został przeniesiony z forum

AMX Mod XProblemy

do

Scripting AMXXProblemy
  • +
  • -
  • 0

b_560_95_1.png


#3 AztekHQS

    Banned

  • Zbanowany

Reputacja: 98
Zaawansowany

  • Postów:279
  • Lokalizacja:Polska
Offline

Napisano 30.11.2012 17:57

pamiętaj że pierwszy skin to 0 :)
Najlepszy serwer JailBreak!
IP: 31.186.83.208:27043
Dołączona grafika

#4 pewex

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:27
  • Lokalizacja:ijijijiji
Offline

Napisano 30.11.2012 18:12

pamiętaj że pierwszy skin to 0 :)


//Zmieniona wartosc:

entity_set_int(id, EV_INT_body, 1) // numer sub modelu

Nadal model ct jest przezroczysty
  • +
  • -
  • 0

#5 K!113r

    Czempion

  • Power User

Reputacja: 385
Wszechpomocny

  • Postów:865
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Piotrków Tryb.
Offline

Napisano 01.12.2012 23:14

Sam robiłeś model? Sprawdzałeś czy działa na HLMV?
  • +
  • -
  • 0

DarkGL to mój autorytet.

skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować skomplikować





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych