Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Łączenie z bazą na local

mysql; localhost;

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 dog_1

    Profesjonalista

  • Użytkownik

Reputacja: 23
Życzliwy

  • Postów:150
  • Lokalizacja:Gdańsk
Offline

Napisano 13.11.2012 16:56

Witam.
Mam mały problem, gdyż nie udaje mi się ustawić połączenie z bazą MySQL która znajduje się na lapku, jak i odpalany serwer.
Instalaka pobrana z http://dev.mysql.com/downloads/mysql/ pod Windows. Wszystko skonfigurowane, mogę przeglądać bazy przez cmd. Tak wygląda kod sql.cfg
amx_sql_host "127.0.0.1"
amx_sql_user "root"
amx_sql_pass "haslo"
amx_sql_db  "test"
amx_sql_table "diablo"
amx_sql_type "mysql"
Błąd wyskakujący na konsoli serwera
Could not connect to SQL database.
Nie wiem co jeszcze, wyczytałem gdzieś że muszę wprowadzić uprawnienia dla bazy, nie zrobiłem tego, bo jak dobrze zrozumiałem to można je zmienić wtedy jeśli chce się ją uzewnętrznić.
  • +
  • -
  • 0

#2 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 13.11.2012 16:58

Automatyczna wiadomość


Ten temat został przeniesiony z forum

AMX Mod X > Pytania

do

Inne > Oprogramowanie > Problemy
  • +
  • -
  • 0

DarkGL to mój autorytet.


#3 MarWit

    The Chosen One

  • Przyjaciel

Reputacja: 840
Czempion

  • Postów:1485
  • GG:
  • Steam:steam
  • Imię:Marcin
  • Lokalizacja:Bystrzyca
Offline

Napisano 15.11.2012 18:45

Uruchom cmd, wpisz polecenie "mysql -u root -h 127.0.0.1 -p" i wpisz hasło. Jeżeli wyskoczy ci błąd, oznacza to iż demon mysql'a nie dziala.

Nie wiem co jeszcze, wyczytałem gdzieś że muszę wprowadzić uprawnienia dla bazy, nie zrobiłem tego, bo jak dobrze zrozumiałem to można je zmienić wtedy jeśli chce się ją uzewnętrznić.


Tworząc nowego użytkownika zawsze trzeba dodać mu dostęp do bazy ( nie dotyczy root'a ).
  • +
  • -
  • 0

marwit-0.png


#4 dog_1

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 23
Życzliwy

  • Postów:150
  • Lokalizacja:Gdańsk
Offline

Napisano 17.11.2012 08:40

Napisałem już że mogę przeglądać sobie bazę przez cmd . Łącze się, tworzę baze, kolumny, select itd. Nie wiem dlaczego serwer nie widzi bazy.
  • +
  • -
  • 0

#5 gslot

    Banned

  • Zbanowany

Reputacja: -1
Mniej niż zer0.

  • Postów:39
  • Lokalizacja:Bydgoszcz
Offline

Napisano 17.11.2012 09:32

A włączyłeś moduł mysql w modules.ini??

#6 dog_1

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 23
Życzliwy

  • Postów:150
  • Lokalizacja:Gdańsk
Offline

Napisano 17.11.2012 09:49

Tak, jest włączony :) Mam nadzieję że jakoś się ten problem rozwiąże, Na razie to korzystam z db4free ale strasznie zlagowany serwis, i nie da się dostać do tabel :)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych