Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Nowy Plugin

Prośba o napisanie - co 3 min wpisuje komende

Nowy Plugin

  • Zamknięty Temat jest zamknięty
17 odpowiedzi w tym temacie

#1 bakul. <3

    Wszechmogący

  • Użytkownik

Reputacja: 88
Zaawansowany

  • Postów:612
  • GG:
  • Imię:Przemek
  • Lokalizacja:Warszawa
Offline

Napisano 14.04.2009 21:24

Proszę o napisanie pluginu, który by co 3 min wpisywał komendę
amx_reloadadmins

  • +
  • -
  • 0

#2 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 14.04.2009 21:38

#include <amxmodx>



public plugin_init() {

	register_plugin("Reload Admin","1.0","Knopers")

	set_task(180.0, "reload")

}

public reload(){

	server_cmd("amx_reloadadmins")

	set_task(180.0, "reload")

}

  • +
  • -
  • 0

#3 darkman

    Wszechwiedzący

  • Przyjaciel

Reputacja: 85
Zaawansowany

  • Postów:553
  • Lokalizacja:inactive
Offline

Napisano 14.04.2009 21:51

#include <amxmodx>

public plugin_init() {
	register_plugin("Reload Admin","1.0","Knopers")
	set_task(180.0, "reload")
}
public reload(){
	server_cmd("amx_reloadadmins")
	set_task(180.0, "reload")
}


jeżeli nie zadziała to:

#include <amxmodx>

public plugin_init() {
	register_plugin("Reload Admin","1.0","Knopers")
	reload()
}
public reload(){
	server_cmd("amx_reloadadmins")
	set_task(180.0, "reload")
}

  • +
  • -
  • 0

#4 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 15.04.2009 13:44

darkman Po co ma od razu po zmianie mapy wpisywać tą komendę jak na początku mapy admini są automatycznie ładowani ;) (chciał co trzy minuty to niech ma xP )
  • +
  • -
  • 0

#5 bakul. <3

    Wszechmogący

  • Autor tematu
  • Użytkownik

Reputacja: 88
Zaawansowany

  • Postów:612
  • GG:
  • Imię:Przemek
  • Lokalizacja:Warszawa
Offline

Napisano 15.04.2009 13:55

Knopers, ale ten plugin jest mi potrzebny po to, bo jak się zmieni mapa, to adminów nie wyszukuje. Dopiero amx_reloadadmins naprawia problem.
  • +
  • -
  • 0

#6 darkman

    Wszechwiedzący

  • Przyjaciel

Reputacja: 85
Zaawansowany

  • Postów:553
  • Lokalizacja:inactive
Offline

Napisano 15.04.2009 14:20

nie chodzi mi o sam odstęp przy wywołaniu funkcji, ale o problemy przy ustawianiu tasków w plugin_init()
  • +
  • -
  • 0

#7 Knopers

    Nie patrz tak na mnie !

  • Przyjaciel

Reputacja: 587
Wszechwiedzący

  • Postów:2013
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Cz-wa
Offline

Napisano 15.04.2009 14:22

to wybierz sobie coś masz 2 kody ;)

Chyba coś z amxx'em masz zj*****go ;>
  • +
  • -
  • 0

#8 bakul. <3

    Wszechmogący

  • Autor tematu
  • Użytkownik

Reputacja: 88
Zaawansowany

  • Postów:612
  • GG:
  • Imię:Przemek
  • Lokalizacja:Warszawa
Offline

Napisano 15.04.2009 14:37

Nawet nie chyba, ale na pewno. Serwer na 2 protokoły, dałem temat na forum, ale nikt nie zna odpowiedzi na ten problem.
  • +
  • -
  • 0

#9 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 15.04.2009 15:12

co 3 minuty, to nie czasem tak?
/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <amxmisc>

#define PLUGIN "admin reload"
#define VERSION "1.0"
#define AUTHOR "naven"


public plugin_init() {
	register_plugin("admin reload", "1.0", "naven")
	
	set_task(180.0,"przeladuj",_,_, _, "b")
}

public przeladuj()
{
	server_cmd("amx_reloadadmins")
}

  • +
  • -
  • 0

#10 emblaze

    Koniec z cs/amxx

  • Użytkownik

Reputacja: 166
Profesjonalista

  • Postów:973
  • Lokalizacja:Mój steam: emblaze_95
Offline

Napisano 15.04.2009 15:22

naven, twój kod chyba tylko raz reloaduje adminów O:)
  • +
  • -
  • 0

#11 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 15.04.2009 15:26

http://www.amxmodx.o... ... &go=search
przeczytaj co oznacza flaga "b"
  • +
  • -
  • 0

#12 emblaze

    Koniec z cs/amxx

  • Użytkownik

Reputacja: 166
Profesjonalista

  • Postów:973
  • Lokalizacja:Mój steam: emblaze_95
Offline

Napisano 15.04.2009 15:34

R3X, aha no tak, tego nie wiedziałem O:)
ps. thx za lekturke x.
  • +
  • -
  • 0

#13 Misiaczek ;c

    /dev/null

  • Moderator

Reputacja: 1662
Godlike

  • Postów:2495
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Halemba
Offline

Napisano 15.04.2009 17:37

~bakul, jeśli masz sv_lan 1 daj na 0 jeśli masz sv_lan 0 daj na 1 też taki problem miałem :P
  • +
  • -
  • 0

#14 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 15.04.2009 17:40

~bakul, jeśli masz sv_lan 1 daj na 0 jeśli masz sv_lan 0 daj na 1 też taki problem miałem :P


O ile umiem czytać, sv_lan nie ma znaczenia.
  • +
  • -
  • 0

#15 bakul. <3

    Wszechmogący

  • Autor tematu
  • Użytkownik

Reputacja: 88
Zaawansowany

  • Postów:612
  • GG:
  • Imię:Przemek
  • Lokalizacja:Warszawa
Offline

Napisano 15.04.2009 17:47

No w tym przypadku możliwe, że daje. Serwery stoją na AMD i po wpisaniu w poleceniu startowym sv_lan 1 VAC się nie włączał i nie można było przez Steam`a wejść, ale to nie temat o tym.

Pluginy już sprawdzam.
  • +
  • -
  • 0

#16 Misiaczek ;c

    /dev/null

  • Moderator

Reputacja: 1662
Godlike

  • Postów:2495
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Halemba
Offline

Napisano 15.04.2009 17:52

naven, miałem ten sam na serwerze stea& non-steam, gdy zmieniłem na sv_lan 1 wszystko zaczło działać....
  • +
  • -
  • 0

#17 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 15.04.2009 18:06

A to ciekawe...Pewnie dlatego mi kiedyś nie chciało działać
  • +
  • -
  • 0

#18 bakul. <3

    Wszechmogący

  • Autor tematu
  • Użytkownik

Reputacja: 88
Zaawansowany

  • Postów:612
  • GG:
  • Imię:Przemek
  • Lokalizacja:Warszawa
Offline

Napisano 15.04.2009 18:25

Dobra, problem rozwiązany. naven dał działający plugin.

Temat można zamknąć.

P.S. Jeżeli ktoś wie coś na temat lagów na serwerze z 2 protokołami http://amxx.pl/viewtopic.php?t=12427

P.S.2 Problem jest na tym samym serwerze, co z adminami ^^
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: Nowy Plugin

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych