Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Plugin xrediret nie pokazuje serwera


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 phoeN.dll

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Patryk
  • Lokalizacja:Słupsk
Offline

Napisano 07.11.2012 17:03

Serdecznie witam.
Na początku tematu chciałbym napisać :
Proszę nie pisać abym poszukał o tym problemie w google bo gdybym nie szukał to bym nie pisal tego posta.
Link do pluginu : http://amxx.pl/topic...ate-09-02-2011/
A więc tak. Mój problem polega na tym że zainstalowałem na 2 serwerach plugin xredirect.
Plugin działa ale jest problem.
Oznaczmy serwer A i B
Kiedy jestem na serwerze A i wpisze /serwer to pokazuje status serwera A , a przy serwerze B pisze (down)
Dokładnie tak samo jest kiedy jestem na serwerze B .
Na 2 serwerach plugin jest skonfigurowany tak samo.

Serwers.ini serwera A
[Only DD2]
address=31.186.82.130
port=27181
[Cod Mod]
address=31.186.83.100
port=27306

serwers.ini serwera B
[Cod Mod]
address=31.186.83.100
port=27306
[Only DD2]
address=31.186.82.130
port=27181


Cvary w amxx.cfg
redirect_active 1
redirect_auto 1
redirect_manual 3
redirect_follow 1
redirect_check_method 2
redirect_announce 60
redirect_announce_mode 3
redirect_adminslots 1
redirect_maxadmins 0
redirect_retry 0
redirect_hidedown 0

Użytkownik phoeN.dll edytował ten post 07.11.2012 17:03

  • +
  • -
  • 0

#2 Filip1512

    Wszechmogący

  • Power User

Reputacja: 136
Zaawansowany

  • Postów:641
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:Poland
Offline

Napisano 07.11.2012 17:37

Serwery STEAM czy STEAM/NS?


DPROTO/Sprawdzanie protokołu
Standardowo plugin nie działa na DPROTO.
Tzn że jeżeli mamy na liście serwer z innym protokołem (także dproto) to może nas nie przekierować.
Aby to wyłączyć należy znaleźć linijkę:
#define MOD_DETECTION true
i zamienić na
#define MOD_DETECTION false
Po tym zabiegu oczywiście czeka nas ponowna kompilacja pluginu.


Użytkownik `NN edytował ten post 07.11.2012 17:39

  • +
  • -
  • 1
Filip / `NN
Wymuszanie rate'ów co spawna - update v2.1!

#3 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 07.11.2012 18:34

Serwers.ini serwera A
[Only DD2]
address=31.186.82.130
port=27181
[Cod Mod]
address=31.186.83.100
port=27306

serwers.ini serwera B
[Cod Mod]
address=31.186.83.100
port=27306
[Only DD2]
address=31.186.82.130
port=27181

kolejność serwerów w tym pliku ma być taka sama.


Serwers.ini serwera A
[Only DD2]
address=31.186.82.130
port=27181
[Cod Mod]
address=31.186.83.100
port=27306

serwers.ini serwera B
[Only DD2]
address=31.186.82.130
port=27181
[Cod Mod]
address=31.186.83.100
port=27306

  • +
  • -
  • 0

DarkGL to mój autorytet.


#4 phoeN.dll

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Patryk
  • Lokalizacja:Słupsk
Offline

Napisano 07.11.2012 19:41

Zrobiłem wszystko to co napisane powyżej.
Nadal nie działa.
  • +
  • -
  • 0

#5 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 07.11.2012 19:51

sprawdź tak:

[Only DD2]
address=31.186.82.130
port=27181
cmdbackup=3
noauto=0
nomanual=0
nodisplay=0

[Cod Mod]
address=31.186.83.100
port=27306
cmdbackup=3
noauto=0
nomanual=0
nodisplay=0

  • +
  • -
  • 0

DarkGL to mój autorytet.


#6 phoeN.dll

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Imię:Patryk
  • Lokalizacja:Słupsk
Offline

Napisano 07.11.2012 20:03

Niestety , nadal nie działa.
Nie wiem o co chodzi.
Mam pytanie. Z tego linku http://amxx.pl/topic...ate-09-02-2011/
Mam wgrac wersje beta czy nie ?
Bo jeśli nie beta to nie ma tam czegoś takiego jak :
[color=#282828][font=helvetica, arial, sans-serif][size=3][background=rgb(247, 247, 247)]#define MOD_DETECTION true[/background][/size][/font][/color]
więc nie moge ustawić

DPROTO/Sprawdzanie protokołu
Standardowo plugin nie działa na DPROTO.
Tzn że jeżeli mamy na liście serwer z innym protokołem (także dproto) to może nas nie przekierować.
Aby to wyłączyć należy znaleźć linijkę:
#define MOD_DETECTION true
i zamienić na
#define MOD_DETECTION false
Po tym zabiegu oczywiście czeka nas ponowna kompilacja pluginu.


Chciałbym dopisać jeszcze że zauważyłem ze nie działa żaden serwer z pukawki.
Jak dodam serwer z zanijaki mojeserwery czy inny hosting to wszystko działa
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych