Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Problem z funkcją client_connect


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Ogen Dogen

    Guru

  • Power User

Reputacja: 222
Profesjonalista

  • Postów:713
  • GG:
  • Steam:steam
  • Imię:Marcin
  • Lokalizacja:Dąbrowa Górnicza
Offline

Napisano 26.09.2012 22:25

Witam. Od jakiegoś czasu plugin mi sypie error logami z tej funkcji. W grze działa normalnie , ale coś jest nie halo :/

L 09/26/2012 - 21:37:13: [AMXX] Displaying debug trace (plugin "menusparing.amxx")
L 09/26/2012 - 21:37:13: [AMXX] Run time error 4: index out of bounds
L 09/26/2012 - 21:37:13: [AMXX] [0] colorchat.inc::ColorChat (line 53)
L 09/26/2012 - 21:37:13: [AMXX] [1] menusparing.sma::client_connect (line 747)

Zamieszczam kod tej funkcji :
public client_connect(id)
{
get_user_name(id,nick,31);
get_user_authid(id,sid,31);
ColorChat(0,BLUE,"%s SID: %s wchodzi na serwer",nick,sid);
return PLUGIN_HANDLED;
}

Tablice "nick" i "sid" są globalne.
  • +
  • -
  • 0

b_350_20_360204_C20008_FFFFFF_000000.png 193.33.176.115:27015

 

94e23d811c.png

 


#2 Zapalka

    Wszechwidzący

  • Użytkownik

Reputacja: 192
Profesjonalista

  • Postów:283
  • GG:
  • Steam:steam
  • Imię:Dawid
  • Lokalizacja:Janów Lubelski
Offline

Napisano 27.09.2012 06:10

Nie używaj w ColorChacie pierwszego parametru zerowego bo jest to zbugowane. Zamiast tej jednej linijki wstaw to:
new Player[32],iNum;
get_players(Player,iNum);
for(new i=0;i<iNum;i++) {
new pid=Player[i];
ColorChat(pid,BLUE,"%s SID: %s wchodzi na serwer",nick,sid);
}

  • +
  • -
  • 0
Zapraszam na http://zapalka.net.pl

#3 Gość_21977_*

  • Gość

Reputacja: 0

Offline

Napisano 14.10.2012 20:47

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych