Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[Pytanie] Jak zmienic liczbe os. aby dostawac?diablomod od onyke


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
11 odpowiedzi w tym temacie

#1 loqbega

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Krzysiek
  • Lokalizacja:KrK
Offline

Napisano 19.07.2012 12:44

witam. planuje zmienic diablomod na ten od onyke (amxx.pl/topic/51197-diablomod-by-onyke/page__st__0) tylko tutaj jest napisane ze xp idzie od 4 os. jak zmienic zeby xp szlo od 2 os?
  • +
  • -
  • 0

#2 ogieR8

    Wszechmogący

  • Power User

Reputacja: 203
Profesjonalista

  • Postów:637
  • Imię:Mariusz
  • Lokalizacja:Ruda Śląska
Offline

Napisano 19.07.2012 15:21

W:

public Give_Xp(id,amount)


Masz linijkę:

if(zablokuj < 4 && amount < 200) return PLUGIN_CONTINUE;


Jest to linia 2609, zamiast 4 ustaw sobie ile chcesz - zabezpieczenie to jest pred tymi, którzy wchodzą w dwójkę np w nocy i sobie expią klasy ;]
  • +
  • -
  • 1
DiabloEwenement v.2.0 [||||||_____]
 

Irytuje mnie nieczytelny kod, jeśli oczekujesz ode mnie pomocy - zmień to !
CodeGenerators.pl - skopiuj kod do okna po prawej, kliknij 'Ułóż". To wszystko, trudne ?


#3 loqbega

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Krzysiek
  • Lokalizacja:KrK
Offline

Napisano 19.07.2012 18:37

Ok thx udało się :). pytanie nr 2 dlaczego mimo admina nie moge wybrac premium postaci?
  • +
  • -
  • 0

#4 ogieR8

    Wszechmogący

  • Power User

Reputacja: 203
Profesjonalista

  • Postów:637
  • Imię:Mariusz
  • Lokalizacja:Ruda Śląska
Offline

Napisano 19.07.2012 19:01

Pokaż jakie masz flagi admina.

if( get_user_flags(id) & ADMIN_LEVEL_F)


http://amxx.pl/topic/60353-flagi/

Musisz mieć flagę : R

Pozdrawiam.
  • +
  • -
  • 1
DiabloEwenement v.2.0 [||||||_____]
 

Irytuje mnie nieczytelny kod, jeśli oczekujesz ode mnie pomocy - zmień to !
CodeGenerators.pl - skopiuj kod do okna po prawej, kliknij 'Ułóż". To wszystko, trudne ?


#5 loqbega

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Krzysiek
  • Lokalizacja:KrK
Offline

Napisano 19.07.2012 19:05

AA jednak nie działa :P przy kompilacji wyskakuje mi cos takiego...

Załączone miniatury

  • kompilacja.jpg

  • +
  • -
  • 0

#6 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 19.07.2012 19:20

wrzuć to do include kompilatora to ci z kompiluje :)

Załączone pliki


  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#7 ogieR8

    Wszechmogący

  • Power User

Reputacja: 203
Profesjonalista

  • Postów:637
  • Imię:Mariusz
  • Lokalizacja:Ruda Śląska
Offline

Napisano 19.07.2012 19:20

Działa, nie masz modułu colorchat.inc, ściągnij to i wrzuć to do compilera, do folderu : include

Załączone pliki


  • +
  • -
  • 1
DiabloEwenement v.2.0 [||||||_____]
 

Irytuje mnie nieczytelny kod, jeśli oczekujesz ode mnie pomocy - zmień to !
CodeGenerators.pl - skopiuj kod do okna po prawej, kliknij 'Ułóż". To wszystko, trudne ?


#8 loqbega

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Krzysiek
  • Lokalizacja:KrK
Offline

Napisano 19.07.2012 19:22

Jezeli chodzi o flagi to tu masz ( o to ci chodzi? :P)

Załączone miniatury

  • asdfg.jpg

  • +
  • -
  • 0

#9 ogieR8

    Wszechmogący

  • Power User

Reputacja: 203
Profesjonalista

  • Postów:637
  • Imię:Mariusz
  • Lokalizacja:Ruda Śląska
Offline

Napisano 19.07.2012 19:36

Yyyy.. dałeś flagi dostępu 'de', a je się nadaje, jeśli admin jest na IP, jeśli na nick daję się 'a', a na dodatek nie ustawiłeś mu hasła. Zmień to na :

"loopback" "HASLO" "abcdefghijklmnopqrstu" "a"


Oczywiście rozumiem, że Twój to jest nick loopback ?


Yyyy.. dałeś flagi dostępu 'de', a je się nadaje, jeśli admin jest na IP, jeśli na nick daję się 'a', a na dodatek nie ustawiłeś mu hasła. Zmień to na :

"loopback" "HASLO" "abcdefghijklmnopqrstu" "a"


Oczywiście rozumiem, że Twój to jest nick loopback ?

Jeśli Twoj nick to LoqBega to nie działa CI on, gdyż przed nim masz średnik ';', usuń go jeśli tamten to Twoj nick (LoqBega - czy coś takiego)

Użytkownik ogieR- edytował ten post 19.07.2012 19:38

  • +
  • -
  • 0
DiabloEwenement v.2.0 [||||||_____]
 

Irytuje mnie nieczytelny kod, jeśli oczekujesz ode mnie pomocy - zmień to !
CodeGenerators.pl - skopiuj kod do okna po prawej, kliknij 'Ułóż". To wszystko, trudne ?


#10 loqbega

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Krzysiek
  • Lokalizacja:KrK
Offline

Napisano 19.07.2012 19:37

nawet po poprawnej kompilacji nie dostaje xp...
  • +
  • -
  • 0

#11 ogieR8

    Wszechmogący

  • Power User

Reputacja: 203
Profesjonalista

  • Postów:637
  • Imię:Mariusz
  • Lokalizacja:Ruda Śląska
Offline

Napisano 19.07.2012 19:39

Hmm, zabezpieczenie usunięte. A na pewno te 4 zamieniłeś na 2 i zapisałeś zmiany ? A potem kompilacja i wrzucenie na serwer FTP ? Jesli jest Was 2 i zrobiłeś wszystko dobrze to coś jest nie tak w silniku Diablo_by_Onyke.. ; /
  • +
  • -
  • 0
DiabloEwenement v.2.0 [||||||_____]
 

Irytuje mnie nieczytelny kod, jeśli oczekujesz ode mnie pomocy - zmień to !
CodeGenerators.pl - skopiuj kod do okna po prawej, kliknij 'Ułóż". To wszystko, trudne ?


#12 loqbega

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Imię:Krzysiek
  • Lokalizacja:KrK
Offline

Napisano 19.07.2012 21:47

ja to hostuje na hldsie wiec raczej na server ftp nie wrzuce :P
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych