Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Zle wyswietla lvl w menu


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 teles190

    Życzliwy

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:30
  • Lokalizacja:Przemyśl
Offline

Napisano 23.05.2012 14:28

Witam. Znalazlem kolejny problem u siebie Zle wyswietla lvl w menu klas "Inne" Pokazuje mi ze mam 7lvl na klasie Skryptobojca a tak naprawdę mam 7 lvl na Wampirze. Usunelem klase Zabojczyni i nie weim czy dlatego sie tak stalo. Co moze pomoc ? Na wszelki wypadek umieszcze sma w zalaczniku

screen
Dołączona grafika
Dołączona grafika

Załączone pliki


  • +
  • -
  • 0

#2 dog_1

    Profesjonalista

  • Użytkownik

Reputacja: 23
Życzliwy

  • Postów:150
  • Lokalizacja:Gdańsk
Offline

Napisano 25.05.2012 13:37

Bo zmienną źle wpisałeś :)
format(text2, 511,"\yInne: ^n\w1. \yMagneto^t\wLevel: \r%i^n\w2. \ySkryptobojca^t\wLevel: \r%i^n\w3. \yWampir^t\wLevel: \r%i^n\w4. \yVerona^t\wLevel: \r%i^n\w5. \yTytan^t\wLevel: \r%i^n\w6. \yAmazonka^t\wLevel: \r%i^n\w7. \yUpadly^t\wLevel: \r%i^n\w8. \yImp^t\wLevel: \r%i^n^n\w0. \yWstecz^n^n\yPrzed wyborem klasy poczekaj 7sek^n\dwww.bestmod.xaa.pl^n\dDiablomod edit by \yTele$",
player_class_lvl[id][9],player_class_lvl[id][10],player_class_lvl[id][11],player_class_lvl[id][12],player_class_lvl[id][13],player_class_lvl[id][8],player_class_lvl[id][15],player_class_lvl[id][16])
Wystarczy player_class_lvl[id][8] przenieść na początek, przed player_class_lvl[id][9] i będzie dobrze.
  • +
  • -
  • 1

#3 teles190

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:30
  • Lokalizacja:Przemyśl
Offline

Napisano 25.05.2012 19:34

a no fakt :D wielkie dzięki :) do zamkniecia

EDIT

a nie bo player_class_lvl[id][8], jest do klasy Amazonka i dlatego jest tam dgzie jest . :D proszę nei zamykac tematu. Oraz taki sam blad jest z ninja ze lvl ninjy jest na klasie wyzej nie pamietam jzu an jakiej. to na pewno wiaze sie z tym ze usunelem te 2 klasy : Gigantyczny pajak oraz Zabojczyni.

Użytkownik teles190 edytował ten post 25.05.2012 19:56

  • +
  • -
  • 0

#4 Koniarek

    Wszechwidzący

  • Zbanowany

Reputacja: 28
Życzliwy

  • Postów:250
  • Imię:Filip
  • Lokalizacja:Daleko
Offline

Napisano 25.05.2012 20:10

Daj .sma Zrobie Ci

#5 dog_1

    Profesjonalista

  • Użytkownik

Reputacja: 23
Życzliwy

  • Postów:150
  • Lokalizacja:Gdańsk
Offline

Napisano 26.05.2012 00:20

new Race[26][18] = { "None","Czarodziejka","Druid","Paladyn","Nekromanta","Barbarzynca", "Ninja", "Amazonka","Magnweto", "Skryptobojca", "Wampir", "Verona", "Tytan", "Zolnierz", "Upadly", "Imp", "Izual", "Skoczek", "Zniewolony", "Diabel", "Strzelec", "Sniegowy Tulacz","Griswold","Kowal","Demonolog","VipCztery" }

Tablica indeksuje od 0 czyli Amazonka jest ma id=[8] a ty to id przypisałeś aha dobrze :) ale nie do reszty. Licząc dalej wampir ma id=10 ty mu przypisałeś w menu id=11 czy;i veroma itd. pozmieniaj w tablicach odpowienie id to będzie ok :)
Dodatkowo jak zmniejszyłeś liczbę klas to zmniejsz np. tablicę z HP oraz tablicę z początkowym expem z zawartością new srv_avg[28], każdą tablicę lx zmniejsz o dwa, popatrz na pętle for(new i=1;i<28;i++) którą też powinieneś zmniejszyć o 2(powinny być ich 4 albo 2 ) to chyba tyle.
  • +
  • -
  • 0

#6 teles190

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:30
  • Lokalizacja:Przemyśl
Offline

Napisano 26.05.2012 08:05

Nie ogarniam tego ;/ wstawie nowe sma bo troszke edytowalem dalej. Dalbys rade mi to poprawic ? będę wdzieczny.

Załączone pliki


  • +
  • -
  • 0

#7 teles190

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:30
  • Lokalizacja:Przemyśl
Offline

Napisano 27.05.2012 15:17

ref + nowe sma

Załączone pliki


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych