Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

AMXBans MIX Nie banuje (może czasem)

gmamxbans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Egbert

    Pomocny

  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:70
  • GG:
  • Imię:Egbert
  • Lokalizacja:Gdańsk
Offline

Napisano 11.05.2012 20:35

Witam, pobrałem AMXBans MIX + Odpowiednia Konfiguracja DPROTO wrzuciłem do siebie i niestety chyba jest problem z połączeniem z bazą danych. Czasem się zdarza, że banowanie zaskoczy i zbanuje delikwenta od razu, czasem dopiero po jakimś czasie, kilku kickach i kolejnych banach. Dodam, że raz zbanowany gracz do póki jest na serwerze jest w menu jakby wyłączony.

Ostatnio wymieniłem AMX na 1.8.2 ale na 1.8.1 też było tak samo. Pierwszej nocy po zainstalowaniu działało dobrze może 3 lub 4 bany poszły bez problemu. Rano utworzyłem nową bazę danych (obecną), w sql.cfg dopisałem co trzeba. Robiłem to w pracy więc jak się domyślacie nie miałem czasu wejść na serwer i sprawdzić czy wszystko przed zmianą bazy było ok. Okazało się, że nie. Był problem z połączeniem się z bazą. Przywróciłem więc poprzednią bazę ale dalej było to samo. Obecnie plugin i www są świerze, dzisiaj wgrywane.

Bez wątpienia potrzebuję pomocy ponieważ walczę już z tym od tygodnia sprawdzając różne konfiguracje.

Link do: www.uniontm.pl/amxbans
Host serwera: Pukawka.pl
Host bazy: webd.pl
AMX 1.8.2
version : 48/1.1.2.6/Stdio 5408 insecure (10)
meta list
Spoiler

plugins.ini
Spoiler

modules.ini
Spoiler

amxbans.cfg
Spoiler

sql.cfg
Spoiler

dproto.cfg
Spoiler

W logach zaznaczyłem na zielono kiedy ban się udał od razu i na czerwono jak po chwili wszedł kolega, któremu dałem bana - niestety już nie dostał go od razu tylko po restarcie serwera.
Obydwa bany pokazały się na stronie.
LOGI
Spoiler


EDIT: W menadżerze zdalnego połączenia MySQL dałem % więc wszyscy mogą się łączyć.

Użytkownik Egbert edytował ten post 11.05.2012 20:44

  • +
  • -
  • 0

#2 LokalnyHost

    Profesjonalista

  • Użytkownik

Reputacja: 39
Życzliwy

  • Postów:213
  • Imię:Bedoka
  • Lokalizacja:Opole
Offline

Napisano 11.05.2012 22:04

Nie może odnaleźć "amx_sql_host "mysql8.webd.pl" "
spróbuj wpisać tam adres strony (np gdyby twój amxbans stał na amxx.pl)
amx_sql_host "amxx.pl"
  • +
  • -
  • 0

#3 Egbert

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:70
  • GG:
  • Imię:Egbert
  • Lokalizacja:Gdańsk
Offline

Napisano 11.05.2012 22:11

Nie możliwe bo bany zapisują się na stronie (te co były to usunąłem bo kumpli banowałem na próbę). Czyli to połączenie istnieje. Problem w tym, że nie banuje od razu. tylko po kilku kickach albo po zmianie mapy - różnie. webd.pl podaje taki host do łączenia się z zewnątrz.
Sprawdzałem różnicę czasu pomiędzy www a serwerem i jest ok. Jednak ten komunikat... dziwne co nie?

Użytkownik Egbert edytował ten post 11.05.2012 22:13

  • +
  • -
  • 0

#4 Kamyk345D

    Zaawansowany

  • Zbanowany

Reputacja: 11
Początkujący

  • Postów:125
  • Imię:Kamil
  • Lokalizacja:Kg
Offline

Napisano 11.05.2012 22:26

Zrób to co on napisał, jeżeli nie będzie działał to zmień amxbans na 1.6 . ;)

#5 Egbert

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:70
  • GG:
  • Imię:Egbert
  • Lokalizacja:Gdańsk
Offline

Napisano 12.05.2012 11:31

Wpisanie jako hosta raqsz.webd.pl (uniontm.pl - to domena zaparkowana):
LOGI:
Spoiler


Po przywróceniu poprzedniego hosta wrzuciłem na serwer plugin 1.6 (rzekomy finał) jak mówił Kamyk345D i lipa. serwer crashował non-stop.
Ale panowie, nie myślcie, że nie czytałem tematów podobnych do mojego. Jest ich pełno ale nikt nie potrafi powiedzieć o co chodzi. Tylko, że spotkałem się w każdym z takich tematów z radami typu: wgraj pluga od 1.5.1 i będzie ok. Myślę, że szyfrant nie cofa się w rozwoju i chyba zrobił tego mixa po to, żeby działał lepiej a nie gorzej. Pierwsze słyszę o tym aby w wrzucać 1.6 zamiast 1.5.1

powróciłem do 1.5.1 z paczki MIX
Sprawdzałem co się dzieje po wrzuceniu adminów na www, przestawiłem aby czytał z MySQL i też był problem, więc zmieniłem spowrotem na odczyt z users.ini
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: gmamxbans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych