Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

PokeMod v1.2.3 RC /error log/


  • Zamknięty Temat jest zamknięty
17 odpowiedzi w tym temacie

#1 L0rdS^P0l4K

    Profesjonalista

  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 01.03.2009 14:49

Witam. Otóż mam pewien problem z pokemodem. Nie mówiąc już o CRASH'ach to w logach powtarza mi się ten błąd.
Daje error oraz linijki z kodem do którego się odwołuję.
L 02/28/2009 - 22:18:38: [nVault] Invalid vault id: 0
L 02/28/2009 - 22:18:38: [AMXX] Displaying debug trace (plugin "pokemod.amxx")
L 02/28/2009 - 22:18:38: [AMXX] Run time error 10: native error (native "nvault_set")
L 02/28/2009 - 22:18:38: [AMXX]    [0] pokerank.inl::SaveRanks (line 354)
L 02/28/2009 - 22:18:38: [AMXX]    [1] <img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/tongue2.gif' class='bbc_emoticon' alt='xP' />.inl::save_all (line 734)
L 02/28/2009 - 22:18:38: [AMXX]    [2] pokemod.sma::plugin_end (line 619)
pokerank.inl (line 352, 353, 354, 355)
for( i=0; i<5; i++){
            formatex(save_key, 50, "PokeMod_Rank%d", i);
            nvault_set(nvault_db, save_key, ranks[i])
        }
xP.inl (line 733, 734, 735)
#if POKERANK_SYSTEM==1
        SaveRanks();
    #endif
pokemod.sma funkcja posiadająca błąd.
public plugin_end()
 {
    if(PM_disabled==1)
        return;
    // SAVE EVERYTHING...
    debugMessage( 0,3,"%s Making final saves before plugin unloads", PREFIX );
    save_all();
    #if SAVE==SAVE_MYSQL || SAVE==SAVE_SQLX
        //Final cleanup in the saving include
        saving_end();
    #endif
    cleanXP();
 }
W plugins.ini mam wpis "pokemod.amxx debug"

Mam nadzieje że ktoś wie o co chodzi z tym wszystkim :-)
  • +
  • -
  • 0

#2 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 01.03.2009 17:58

A dodałeś dane MySQL do pokemod.cfg ?
  • +
  • -
  • 0

#3 L0rdS^P0l4K

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 01.03.2009 22:46

A dodałeś dane MySQL do pokemod.cfg ?


Nie bardzo rozumiem...
[nVault] Invalid vault id: 0

Z tego logu jasno wynika że wszystko zapisuje sie do pliku... vault a na serwerze dokładnie on nazywa się [pm_save.vault]
Więc raczej MySQL odpada. :-)
  • +
  • -
  • 0

#4 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 02.03.2009 15:00

Skąd masz tego pokemoda? Jeśli chcesz udostępnię Ci wersje PL, zapis do MySQL i na nick. W tej jest coś nie tak za plikiem który odpowiada za zapis xP, nie zapisywałem statów do pliku tak że nie wiem czy działa to u mnie, ale z reguły taki zapis przy dużym serwerze z dużą ilością graczy,a co za tym idzie xP w pliku nie kończy się dobrze :-)

Co do błędu to jeśli nie chcesz zapisywać xP do bazy to spróbuj usunąć ten plik pm_save.vault może jest uszkodzony?
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#5 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 02.03.2009 15:24

portek, jaka wersja? includes czy samo .amxx?
  • +
  • -
  • 0

#6 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 02.03.2009 16:10

portek, jaka wersja? includes czy samo .amxx?

v1.2.3 RC 2, tylko .amxx nie mam .sma, po formacie nie chciało mi się już szukać od nowa ;P
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#7 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 02.03.2009 17:05

Ja w temacie o Pokemod udostępniłem Portek twoją wersje. Ale nie wiadomo czy właśnie denis13wroc pobierał tą twoją wersje.
  • +
  • -
  • 0

#8 L0rdS^P0l4K

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 02.03.2009 19:39

:-) Zrezygnowałem z nVault i skompilowałem sobie moda na MySQL.
I teraz mam za to inny problem

L 03/02/2009 - 19:14:45: [pokemod.amxx] MySQL connect error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)' (localhost,root,pokemod)

To jest bardzo dziwna sprawa... bo na samym początku jak połączyło się już wszystko z bazą i zaczął zapisywać dane w rekordach to kilka mapek normalnie wszystko działało. Później podczas zmiany mapy serwer CRASH i w logach pojawił się ten problem... :-)
  • +
  • -
  • 0

#9 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 02.03.2009 20:01

a moduł włączone? upewnij się że nie maszamxx 1,8.1- tam jest niedziałający poprawnie moduł mysql
  • +
  • -
  • 0

#10 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 02.03.2009 20:18

Przeczytaj w pierwszym poście adnotacje odemnie, nie chce mi się jej poraz X pisać ;)
http://amxx.pl/viewt...?t=3209&start=0
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#11 L0rdS^P0l4K

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 02.03.2009 21:20

Przeczytaj w pierwszym poście adnotacje odemnie, nie chce mi się jej poraz X pisać ;)
http://amxx.pl/viewt...?t=3209&start=0


Zrozum człowieku że nie jestem na tyle tempy aby nie wpisać nigdzie danych do połączenia z bazą.
Ta sprawa jest załatwiona. xP normalnie zapisuje się w tabeli w DB MySQL.

Problem polega na tym że po zakończeniu kilku mapek serwer dochodząc do końca mapy a dokładnie przy jej zmianie łapie CRASHe. A w logach pozostaje
L 03/02/2009 - 19:14:45: [pokemod.amxx] MySQL connect error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)' (localhost,root,pokemod)

ALE xP PODCZAS MAPY NORMALNIE SIĘ ZAPISUJE !!
  • +
  • -
  • 0

#12 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 03.03.2009 08:14

jaką masz wersję? spróbuj ściągnąć od nowa http://forums.allied...ad.php?p=200169
  • +
  • -
  • 0

#13 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 03.03.2009 15:44

Przeczytaj w pierwszym poście adnotacje odemnie, nie chce mi się jej poraz X pisać ;)
http://amxx.pl/viewt...?t=3209&start=0


Zrozum człowieku że nie jestem na tyle tempy aby nie wpisać nigdzie danych do połączenia z bazą.
Ta sprawa jest załatwiona. xP normalnie zapisuje się w tabeli w DB MySQL.

Problem polega na tym że po zakończeniu kilku mapek serwer dochodząc do końca mapy a dokładnie przy jej zmianie łapie CRASHe. A w logach pozostaje
L 03/02/2009 - 19:14:45: [pokemod.amxx] MySQL connect error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)' (localhost,root,pokemod)

ALE xP PODCZAS MAPY NORMALNIE SIĘ ZAPISUJE !!

Gdzie masz tą baze? Hosting ma limit co do ilości zapytać do jednej tabeli przez określony czas... Serwer nie powinien przez to padać miałem podobny problem to jedynie xP się nie zapisywało... a ten błąd wygląda tak jakbyś podał niepoprawne dane do bazy i tyle ;)
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#14 L0rdS^P0l4K

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 03.03.2009 16:07

A no właśnie i to jest dziwne... bo podczas gry exp się zapisywał i mam w bazie wpisy a podczas zmiany mapy serwer crashowało. Pytanie jest takie... o co mu chodzi z tym /tmp/mysql.sock baza jest zdalna z cal.pl a serwer stoi na game2play baza jest tzw zewnętrzna. Więc czemu w logu jest localhost ? specjalnie sprawdziłem i ten localhost odnosi się do serwera mysql. Pokemod to nazwa mojej bazy w cal.pl więc jeżeli jakiś problem jest raczej z tym. Folder tmp wskazuje na miejsce gdzie zapisuje się jakieś tymczasowe dane... tylko o co mu może chodzić skoro baza działa poprawnie ?
  • +
  • -
  • 0

#15 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 03.03.2009 16:18

Ogólnie to spróbuj przenieść obecną baze na db4free.net. Tak jak mówie wygląda tak jakby serwer gubił połączenie z bazą danych, lub baza miała limit ilości zapytań do określonej bazy/tabeli...
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#16 L0rdS^P0l4K

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 04.03.2009 19:46

Niestety i to nie pomogło... 2 płatne hostingi + darmowy który mi podałeś. Wszystko nie wytrzymuje i traci się połączenie... na jednej bazie więcej razy na drugiej mniej... ale nie można sobie pozwolić na takie coś... Za każdym razem jak tylko traciło się połączenie a później zostało wznowione osoby które były na serwerze nadpisywały sobie dane w chwili jak nic nie mieli.
  • +
  • -
  • 0

#17 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 04.03.2009 20:59

Spróbuj wgrać moduł MySQL od starszej wersji AMXMODX np. 1.76, możliwe że moduł jest wadliwy i gubi połączenie... gdzie wykupiony jest serwer?
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#18 L0rdS^P0l4K

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:197
  • GG:
  • Steam:steam
  • Imię:Denis
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 05.03.2009 11:18

Serwer CS stoi na gam2play a MySQL sprawdzałem na... cal.pl, bitmar.net i tą darmową bazę co polecaliście. 2 Pierwsze hosty są płatne 3 darmowy a i tak taki sam wynik :-).
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych