Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
PHP

Nie działająca rejestracja

php

  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 LucKy_skiLL

    Godlike

  • Power User

Reputacja: 160
Profesjonalista

  • Postów:1301
  • GG:
  • Lokalizacja:Kraków
Offline

Napisano 04.03.2012 21:38

Witam, mam taki kod na rejestracje

http://wklej.org/id/701663/


I po wypełnieniu danych na stronie, nie wyświetla żadnego błędu, ale nie rejestruje usera, dlaczego ?


Pierwotnie kod wyglądał tak i wtedy działał, a ten u góry trochę edytowałem i coś sie popsuło.

http://wklej.org/id/701664/


Może ktoś wie dlaczego ?
  • +
  • -
  • 0

Oglądasz seriale typu: The Flash, Arrow, Daredevil, The Walking Dead? Jeśli tak, to zapraszam na mój kanał YouTube


#2 Leihto

    Wszechobecny

  • Użytkownik

Reputacja: 150
Profesjonalista

  • Postów:452
  • Lokalizacja:Rabka
Offline

Napisano 05.03.2012 15:06

Wywołaj samo zapytanie w phpmyadmin.. Prawdopodobnie tam masz błąd.
  • +
  • -
  • 0
Portek: Za 20zł, to ja nawet notatnika nie otworze..

Nowe portfolio. Ciekawe artykuły, ciekawe przykłady: WojtusDEV.pl

#3 LucKy_skiLL

    Godlike

  • Autor tematu
  • Power User

Reputacja: 160
Profesjonalista

  • Postów:1301
  • GG:
  • Lokalizacja:Kraków
Offline

Napisano 05.03.2012 19:30

Chodzi o to zapytanie ?

INSERT INTO $tabela VALUES('', '$login', '$haslo', '$email', '$gg', '$kod', NOW(), '')");

Bo nawet po wysłaniu formularza (chociaż nie wiem czy to się w ogóle odbywa) nie ma żadnych rekordów w tabeli użytkownicy.
  • +
  • -
  • 0

Oglądasz seriale typu: The Flash, Arrow, Daredevil, The Walking Dead? Jeśli tak, to zapraszam na mój kanał YouTube


#4 Leihto

    Wszechobecny

  • Użytkownik

Reputacja: 150
Profesjonalista

  • Postów:452
  • Lokalizacja:Rabka
Offline

Napisano 05.03.2012 22:32

Najpierw wyświetl zapytanie, które chcesz wykonać, a później wykonaj je wklejając je w phpmyadmina.
Twój kod powioduje to że gdy zapytanie jest błędne, to cała reszta się nie wykonuje...

W ogóle nie powinno się już stosować eregi ;) http://www.php.net/m...ction.eregi.php

Użytkownik Leihto edytował ten post 05.03.2012 22:35

  • +
  • -
  • 0
Portek: Za 20zł, to ja nawet notatnika nie otworze..

Nowe portfolio. Ciekawe artykuły, ciekawe przykłady: WojtusDEV.pl

#5 LucKy_skiLL

    Godlike

  • Autor tematu
  • Power User

Reputacja: 160
Profesjonalista

  • Postów:1301
  • GG:
  • Lokalizacja:Kraków
Offline

Napisano 05.03.2012 22:36

Dobra doszedłem do błędu, można zamknąć.
  • +
  • -
  • 0

Oglądasz seriale typu: The Flash, Arrow, Daredevil, The Walking Dead? Jeśli tak, to zapraszam na mój kanał YouTube






Również z jednym lub większą ilością słów kluczowych: php

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych