Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Mapchooser4 - spam w logach, rtv nie działa


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Pitek

    Pomocny

  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:70
  • GG:
  • Steam:steam
  • Imię:Piotrek
  • Lokalizacja:Konin
Offline

Napisano 01.03.2012 23:13

Od razu przechodze do rzeczy:

debug log:

L 03/01/2012 - 22:37:35: [AMXX] Displaying debug trace (plugin "mapchooser4.amxx")
L 03/01/2012 - 22:37:35: [AMXX] Run time error 10: native error (native "get_pcvar_num")
L 03/01/2012 - 22:37:35: [AMXX]	[0] 60839.attach::voteNextmap (line 688)
L 03/01/2012 - 22:37:50: Invalid CVAR pointer

oraz wspomniana powyżej linijka:

	if ((get_pcvar_num(pv_amx_rtv) > 0) && (g_nominationsHelpMsgIter + 6 == NOMINATIONS_HELPMSG) && (!g_hasbeenrocked))

ocb ? nie mam pojęcia, ale wiem, że nie działa rtv na serwerze...próbowalem już wszelkiej magii i nic mi do głowy nie przychodzi.

-standardowy mapchooser naturalnie wyłączony
-żadnego innego nie posiadam
-nextmap.amxx i timeleft.amxx włączone
-na serwerze posiadam bf2 by Misiek (jeśli takie info komuś się przyda)

cvary mapchoosera4 ustawione w ten sposób:

amx_mapchooser_type "0"
amx_mapchooser_mapsloc "0"
amx_mapchooser_mapsfile "mapy.ini"
amx_mapchooser_mapsfile_s "mapy_male.ini"
amx_nominfromfile "0"
amx_maxnominperplayer "1"
amx_map_history "5"
amx_ext_round_max "3"
amx_ext_round_step "3"
amx_ext_win_max "3"
amx_ext_win_step "3"
amx_rtv "1"
amx_rtv_percent "0.6"
amx_rtv_min_time "10"
amx_rtv_map_time "10"
amx_last_voting "10"

PS. nie pisać mi tu postów typu "zmień na galileo" itp...mapchooser4 ma jedną, ale za to bardzo przydatną opcję, mianowicie - osobny plik z mapami, gdy na serwerze jest mniej niż 10 graczy, dlatego go tak męczę ;P

z góry dzięki za pomoc i ewentualne podpowiedzi...

Użytkownik Pitek edytował ten post 01.03.2012 23:23

  • +
  • -
  • 0

#2 Pitek

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:70
  • GG:
  • Steam:steam
  • Imię:Piotrek
  • Lokalizacja:Konin
Offline

Napisano 02.03.2012 19:16

wygląda na to, że problem rozwiązałem...wystarczyło odkomentować jedno #define w sma

także można zamknąć
  • +
  • -
  • 0

#3 Misiaczek ;c

    /dev/null

  • Moderator

Reputacja: 1662
Godlike

  • Postów:2495
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Halemba
Offline

Napisano 11.03.2012 14:57

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych