Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Bugowanie się itemu po 1 rundzie grania :(

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 Legenda

    Życzliwy

  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:33
  • Imię:Piotrek
  • Lokalizacja:TrN
Offline

Napisano 29.02.2012 20:25

Po 1 rundzie gry z itemem 3mod ginie grawitacja : (
Mogłyby mi to ktoś naprawić i przy okazjji dodać 50 kondycji zamiast 25

Załączone pliki


  • +
  • -
  • 0

di-I8OB5N2Q_gif_300x300_q85.jpg


#2 Eustachy8

    Wszechpomocny

  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:304
  • Imię:Kuba
  • Lokalizacja:Buczacz
Offline

Napisano 01.03.2012 16:59

teraz powinno banglać

edit: mam problem z wysłaniem załącznika ;< oto sma

#include <amxmodx>
#include <codmod>
#include <fakemeta>
#include <engine>
#include <hamsandwich>

new nazwa[] = "3mod";
new opis[] = "Dostajesz 50 kondycji oraz 150 grawitacji";

new bool:ma_perk[33];
new snajper_id;

public plugin_init() 
{
register_plugin(nazwa, "1.0", "QTM_Peyote");
register_forward(FM_PlayerPreThink, "forward_PlayerPreThink");

cod_register_perk(nazwa, opis);
}

public cod_perk_enabled(id)
{
if(cod_get_user_class(id) == snajper_id)
return COD_STOP;

  entity_set_float(id, EV_FL_gravity, 150.0/800.0);

cod_set_user_bonus_trim(id, cod_get_user_trim(id, 0, 0)+50);
return COD_CONTINUE;
}

public cod_perk_disabled(id)
{
  entity_set_float(id, EV_FL_gravity, 1.0);
cod_set_user_bonus_trim(id, cod_get_user_trim(id, 0, 0)-50);
}




public PlayerPreThink(id)
{
if(ma_perk[id])
entity_set_float(id, EV_FL_gravity, 150.0/800.0);
}

Użytkownik Eustachy8 edytował ten post 01.03.2012 17:01

  • +
  • -
  • 1

24azdk0.jpg
b_350_20_692108_381007_FFFFFF_000000.png
 


#3 Legenda

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:33
  • Imię:Piotrek
  • Lokalizacja:TrN
Offline

Napisano 01.03.2012 21:55

dzięki Plusik dla ciebie
  • +
  • -
  • 0

di-I8OB5N2Q_gif_300x300_q85.jpg


#4 Legenda

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:33
  • Imię:Piotrek
  • Lokalizacja:TrN
Offline

Napisano 01.03.2012 23:18

niestety ale item nadal nie działa poprawnie
  • +
  • -
  • 0

di-I8OB5N2Q_gif_300x300_q85.jpg


#5 Eustachy8

    Wszechpomocny

  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:304
  • Imię:Kuba
  • Lokalizacja:Buczacz
Offline

Napisano 02.03.2012 10:07

ale co dokładnie? Nie ma cały czas grawitacji?
  • +
  • -
  • 0

24azdk0.jpg
b_350_20_692108_381007_FFFFFF_000000.png
 


#6 Legenda

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:33
  • Imię:Piotrek
  • Lokalizacja:TrN
Offline

Napisano 02.03.2012 17:01

Grawitacja jest, ale po rundzie znika i zostaje tylko sama kondycja : /
  • +
  • -
  • 0

di-I8OB5N2Q_gif_300x300_q85.jpg


#7 Legenda

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:33
  • Imię:Piotrek
  • Lokalizacja:TrN
Offline

Napisano 04.03.2012 11:59

może zrób amxx ?
  • +
  • -
  • 0

di-I8OB5N2Q_gif_300x300_q85.jpg


#8 Sewek

    Pomocny

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:64
  • Lokalizacja:Daleko
Offline

Napisano 04.03.2012 12:02

a może masz plugin amx_super

#9 Enson

    Wszechwidzący

  • Użytkownik

Reputacja: 159
Profesjonalista

  • Postów:269
  • GG:
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 04.03.2012 12:07

w
public cod_perk_enabled(id)

brakowalo ci:
 ma_perk[id] = true;


Teraz powinno dzialac

/Edit
@up
wprowadzasz tylko w blad...

Załączone pliki


Użytkownik Enson edytował ten post 04.03.2012 12:07

  • +
  • -
  • 1
b_350_20_4169E1_FFFFFF_000000_9D513F.png
b_350_20_4169E1_FFFFFF_000000_9D513F.png
b_350_20_4169E1_FFFFFF_000000_9D513F.png
b_350_20_4169E1_FFFFFF_000000_9D513F.png
Oferuje pomoc: Tworzenie klas/perkow/pluginów na cod modzie oraz pomoc techniczna przy serwerach/sieci. Pomoc poza forum - odplatna

#10 Eustachy8

    Wszechpomocny

  • Użytkownik

Reputacja: 116
Zaawansowany

  • Postów:304
  • Imię:Kuba
  • Lokalizacja:Buczacz
Offline

Napisano 05.03.2012 13:11

a faktycznie, zapomniałem tam tego dodać ;D to co dał Enson powinno banglać
  • +
  • -
  • 0

24azdk0.jpg
b_350_20_692108_381007_FFFFFF_000000.png
 






Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych