Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

CMD nowych pluginów nie działają.


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 Twity

    Nowy

  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:8
  • Imię:Jędrek
  • Lokalizacja:Lublin
Offline

Napisano 26.02.2012 20:32

Witam,

Chciałbym się zwrócić z wami z prośbą o rozwiązanie mojego problemu.
A teraz na czym polega problem;

Otóż problem polega na tym iż mam swój serwer DeathRun .
Mam na nim pluginy z komendami np /invis . Ale od ostatniego czasu, po wgraniu pluginu(właśnie /invis) zauważyłem iż,
cmd nie działa, zignorowałem to myśląc iż plugin jest zepsuty. Dobra, ale po pewnym czasie wgrałem kolejny plugin. Tym razem
serwery.amxx - lista serwerów. Oczywiście po wgraniu i zrobieniu restartu mapy, wpisałem komendę... okazuje się iż ona również nie działa.
Dobrze, znów zignorowałem to. Lecz po pewnym czasie wgrałem plugin Deathrun_wyscigi (by speedkill) i co sie okazuje ? Tak, dobrze zgadujecie, że nie działa !!!

Opowiedziałem wszysto speedkillowi i nakierował mnie tutaj, bym napisał temat.
Powiedział również żebym zamieścił swoje plugins.ini.
Niestety ale mimo błędu, nie chcę zamieszczać tego publicznie, wolałbym prywatnie.
Nie zrozumcie mnie źle, ale ktoś kto będzie miał podobny błąd(lub co kolwiek), wystuka frazę w google i ma paczkę dr.
Zatem proszę mnie zrozumieć iż wysyłam plugins.ini na Pw.(więc proszę o pisanie w wątku komu wysłać plugins)

Dobrze, kolejna rzecz to error logi.
W errorach nic nie ma, po za tymi trzema błędami ;
1 - drvipek - autorstwa speedkill
2 - respawnik - nieco przerobiony przeze mnie(auto respawn po zginięciu, jak w dm)
3 - dr wyścigi - również autorstwa speedkill



L 02/26/2012 - 19:49:21: [AMXX] Displaying debug trace (plugin "respawnik.amxx")
L 02/26/2012 - 19:49:21: [AMXX] Run time error 10: native error (native "give_item")

L 02/26/2012 - 19:51:38: [AMXX] Displaying debug trace (plugin "Drvipek.amxx")
L 02/26/2012 - 19:51:38: [AMXX] Run time error 10: native error (native "cs_get_user_team")
L 02/26/2012 - 19:51:38: [AMXX] [0] Drvipek.sma::Bacon_Spawn (line 314)

L 02/26/2012 - 19:51:56: [AMXX] Run time error 4 (plugin "Deathrun_wyscig.amxx") - debug not enabled!
L 02/26/2012 - 19:51:56: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Dodam iż dziś przed dodaniem tych dwóch pluginów(respawnik i wyscigi) Drvipek notorycznie spamował cały error log.
Co prawda nadal spamuje ... i jest nawet gorzej iż teraz zamiast jednego errora mam jeszcze error z wyscigow i tego respawnika.


Proszę o pomoc, z góry dziękuję wszystkim zainteresowanym tym wątkiem.

Pozdrawiam i liczę na pomoc od waszej społeczności.
  • +
  • -
  • 0

#2 Waleq

    Profesjonalista

  • Użytkownik

Reputacja: 47
Pomocny

  • Postów:184
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Bełchatów
Offline

Napisano 27.02.2012 06:48

Spróbuj przenieść plugin odpowiedzialny za /invis na sam dół plugins.ini.
  • +
  • -
  • 0

#3 Twity

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:8
  • Imię:Jędrek
  • Lokalizacja:Lublin
Offline

Napisano 27.02.2012 07:11

W tym problem, że plugin jest na samym dole.

Wycinek:





deathrun_stats.amxx

;

cmd.amxx

;
menu.amxx
Drvipek.amxx debug
;komendyservera.amxx




;waddownload.amxx



;fakefull_original.amxx



kolorowane_tagi.amxx




nickprzycel.amxx



afkkisss.amxx



;;;;respawn.amxx



respawnik.amxx debug



autospawn.amxx





Allow_round_finish.amxx



;alt_end_round_sounds.amxx



;simple_redirect.amxx




;cheat.amxx


;Hook.amxx


;DeathOrFree.amxx


;testvipplug.amxx

;rules_mifu.amxx
;serwery.amxx

;kolejka_v2.amxx

;napisz_skarge.amxx

rekordsound.amxx
;snieg.amxx
sound_mp3.amxx
walkguardPL.amxx
GHW_Toggleable_Noclip.amxx
invis.amxx
terrorysta.amxx
zakaz_rekl.amxx
Map_Spawns_Editor.amxx
serwery.amxx
Deathrun_wyscig.amxx


ooo zauważyłem że komenda pluginu: napisz_skarge.amxx również nie działa....
Dodam że jeszcze w tym roku(stycznia)dodałem menu.amxx by speedkill i działa.... lecz jest w środku plugins.ini (zaznaczyłem czerwonym markerem)

Użytkownik Twity edytował ten post 27.02.2012 07:25

  • +
  • -
  • 0

#4 Drzanas

    Godlike

  • Power User

Reputacja: 328
Wszechpomocny

  • Postów:1283
  • Steam:steam
  • Imię:Piotrek
  • Lokalizacja:Warszawa
Offline

Napisano 27.02.2012 09:11

Daj sma tych pluginów.
I debuguj wyścig jeszcze.
  • +
  • -
  • 0

graphic.png


#5 Waleq

    Profesjonalista

  • Użytkownik

Reputacja: 47
Pomocny

  • Postów:184
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Bełchatów
Offline

Napisano 27.02.2012 10:04

A jak ma Ci działać plugin "napisz skargę" skoro jest on zakomentowany (wyłączony)?
  • +
  • -
  • 0

#6 Twity

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:8
  • Imię:Jędrek
  • Lokalizacja:Lublin
Offline

Napisano 27.02.2012 15:02

Oczywiście że teraz jest wyłączony....
Przecież nie będę obciążał serwera niedziałającymi funkcjami...

SMA wyścigu można ściągnąć stąd : http://amxx.pl/topic...peedrun-wyscig/

Pomijając wcześniejsze niedziałające pluginy(typu np napisz_skarge.amxx)proszę o pomoc w tym pluginie co podałem link wyżej.
Jeżeli okaże się że plugin jest źle zrobiony(chodź nic w nim nie zmieniałem)to poprostu to nie wina serwera.

@Co do sma pluginów nie działających :

1.Plugin na /admins
#include <amxmodx>

/*---------------EDIT ME------------------*/
#define ADMIN_CHECK ADMIN_KICK

static const COLOR[] = "^x04" //green
static const CONTACT[] = ""
/*----------------------------------------*/

new maxplayers
new gmsgSayText

public plugin_init() {
register_plugin("Admin Check", "1.51", "OneEyed")
maxplayers = get_maxplayers()
gmsgSayText = get_user_msgid("SayText")
register_clcmd("say", "handle_say")
register_cvar("amx_contactinfo", CONTACT, FCVAR_SERVER)
}

public handle_say(id) {
new said[192]
read_args(said,192)
if( ( containi(said, "who") != -1 && containi(said, "admin") != -1 ) || contain(said, "/admins") != -1 )
set_task(0.1,"print_adminlist",id)
return PLUGIN_CONTINUE
}

public print_adminlist(user)
{
new adminnames[33][32]
new message[256]
new contactinfo[256], contact[112]
new id, count, x, len

for(id = 1 ; id <= maxplayers ; id++)
if(is_user_connected(id))
if(get_user_flags(id) & ADMIN_CHECK)
get_user_name(id, adminnames[count++], 31)

len = format(message, 255, "%s ADMINS ONLINE: ",COLOR)
if(count > 0) {
for(x = 0 ; x < count ; x++) {
len += format(message[len], 255-len, "%s%s ", adminnames[x], x < (count-1) ? ", ":"")
if(len > 96 ) {
print_message(user, message)
len = format(message, 255, "%s ",COLOR)
}
}
print_message(user, message)
}
else {
len += format(message[len], 255-len, "No admins online.")
print_message(user, message)
}

get_cvar_string("amx_contactinfo", contact, 63)
if(contact[0]) {
format(contactinfo, 111, "%s Contact Server Admin -- %s", COLOR, contact)
print_message(user, contactinfo)
}
}

print_message(id, msg[]) {
message_begin(MSG_ONE, gmsgSayText, {0,0,0}, id)
write_byte(id)
write_string(msg)
message_end()
}


2.Plugin na /serwery.
#include <amxmodx>
#include <amxmisc>
#define PLUGIN "Menu serwerow"
#define VERSION "1.0"
#define AUTHOR "Mlody"
public plugin_init() {
register_plugin(PLUGIN, VERSION, AUTHOR)
register_clcmd("say /serwer","AwesomeMenu")
register_clcmd("say /server","AwesomeMenu")
register_clcmd("say_team /serwer","AwesomeMenu")
register_clcmd("say_team /server", "AwesomeMenu")
register_clcmd("say /servery","AwesomeMenu")
register_clcmd("say_team /servery","AwesomeMenu")


// Add your code here...
}
public AwesomeMenu(id)
{
new menu = menu_create("Menu serwerow CSTorrenty:", "menu_handler")
menu_additem(menu, "#1 CsTorrenty [DeathRun]", "1", 0)
menu_additem(menu, "#2 CsTorrenty [SoccerJam]", "2", 0)
menu_additem(menu, "#3 CsTorrenty [OnlyDD2+BF2]", "3", 0)
menu_additem(menu, "#4 CsTorrenty [Zombie Mod]", "4", 0)
menu_setprop(menu, MPROP_EXIT, MEXIT_ALL)
menu_display(id, menu, 0)
}
public menu_handler(id, menu, item)
{
if (item == MENU_EXIT)
{
return PLUGIN_HANDLED
}
new data[6], iName[64]
new access, callback
menu_item_getinfo(menu, item, access, data,5, iName, 63, callback)
new key = str_to_num(data)
switch(key)
{
case 1:{
client_cmd(id, "Connect 188.116.34.99:27100")
menu_destroy(menu)
return PLUGIN_HANDLED
}
case 2:{
client_cmd(id, "Connect xxxxxxxxxxxx")
menu_destroy(menu)
return PLUGIN_HANDLED
}
case 3:{
client_cmd(id, "Connect xxxxxxxxxx")
menu_destroy(menu)
return PLUGIN_HANDLED
}
case 4:{
client_cmd(id, "Connect xxxxxx")
menu_destroy(menu)
return PLUGIN_HANDLED
}
}
menu_destroy(menu)
return PLUGIN_HANDLED
}

(na deathrunie można zobaczyć(nawet teraz) że wyskakuje takie cuś jak "Wyzwij kogos na pojedynek[1v1] lub coś podobnego, ale komendy nie działają)

3.Plugin napisz skargę na serwerze.
http://amxx.pl/topic...-napisz-skarge/

4.Plugin Invis - Podobno zwiększa fps.
http://darkgl.amxx.p...-graczy-i-wody/
  • +
  • -
  • 0

#7 Twity

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:8
  • Imię:Jędrek
  • Lokalizacja:Lublin
Offline

Napisano 28.02.2012 14:19

Jest ktoś w stanie pomóc mi i poświęcić troszeczkę czasu ?
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych