Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Prośba o przerobienie VIP'APrzeróbka

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
17 odpowiedzi w tym temacie

#1 Pietras11

    Wszechwiedzący

  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 17.02.2012 09:40

Witam mam prośbę o przerobienie tego sma VIP'A.
VIP ma takie funkcję:
-sey/speed większa prędkość
-sey/grawitacja wiadomo
-sey/vips vipy online
-darmowe granaty
-sey/vip info co ma vip
-1 model gracza dla ct i tt
Po przeróbce chciałbym by miał:
-napis vip w tabeli wynikow
-sey/vips vipy online
-vip+nick vipa jak wbija na serwer na środku ekranu
-sey/vip informacja co posiada vip
-2 modele gracza ct i tt
Za pomoc +++ sma i modele w załączniku.link do modeli: http://speedy.sh/dPQWA/modele.rar

Załączone pliki


Użytkownik Pietras11 edytował ten post 17.02.2012 09:42

  • +
  • -
  • 0

#2 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 20.02.2012 12:03

Modeli już nie trzeba mam oddzielny plugin tylko te 4 rzeczy.
-napis vip w tabeli wynikow
-sey/vips vipy online
-vip+nick vipa jak wbija na serwer na środku ekranu
-sey/vip informacja co posiada vip.
  • +
  • -
  • 0

#3 forma

    Godlike

  • Power User

Reputacja: 198
Profesjonalista

  • Postów:487
  • Imię:Jakub
  • Lokalizacja:Piła
Offline

Napisano 20.02.2012 12:31

tworzysz plik vip.txt wklejasz go do cstrike i w htmlu zamieszczasz tam te informacje.

Załączone pliki


  • +
  • -
  • 0

#4 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 20.02.2012 12:57

-napis vip w tabeli wyników
-vip+nick vipa jak wbija na serwer na środku ekranu.Te 2 rzeczy nie działają :/

#include<amxmodx>

#define PLUGIN "New Plug-In"
#define VERSION "1.0"
#define AUTHOR "MisieQ"

#define VIP ADMIN_IMMUNITY

public plugin_init()
{
register_plugin(PLUGIN, VERSION, AUTHOR)

register_message
(get_user_msgid("ScoreAttrib"), "msgScoreAttrib");
}

public msgScoreAttrib( const MsgId, const MsgType, const MsgDest )
{
static id;
id = get_msg_arg_int( 1 );

if( ( get_user_flags( id ) & VIP ) && !get_msg_arg_int( 2 ))
{
set_msg_arg_int( 2, ARG_BYTE, ( 1 << 2 ) );
}

}


Zamieszam kod misqa moze z niego coś się wykorzysta by status VIP dzialał.

Użytkownik Pietras11 edytował ten post 20.02.2012 12:58

  • +
  • -
  • 0

#5 forma

    Godlike

  • Power User

Reputacja: 198
Profesjonalista

  • Postów:487
  • Imię:Jakub
  • Lokalizacja:Piła
Offline

Napisano 20.02.2012 13:02

Testowałeś to w 2 osoby :) ?

Jak nie to przetestuj jak jedna będzie na serwie a ty wbij :) to samo z vip w tabeli musi działać funkcje z amxx.

Użytkownik forma edytował ten post 20.02.2012 13:03

  • +
  • -
  • 0

#6 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 20.02.2012 13:21

Tak wiem testowałem w 2 osoby i nie działa z tego kodu od misqa nawet jak sam byłem to działał O:)
Taki error mam w logach:

L 02/20/2012 - 12:43:37: Start of error session.
L 02/20/2012 - 12:43:37: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20120220.log")
L 02/20/2012 - 12:43:37: Function "info" was not found
L 02/20/2012 - 12:43:37: [AMXX] Run time error 19 (plugin "vip.amxx") - debug not enabled!
L 02/20/2012 - 12:43:37: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:43:37: Invalid CVAR pointer
L 02/20/2012 - 12:43:37: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:43:37: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:46:16: Invalid CVAR pointer
L 02/20/2012 - 12:46:16: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:46:16: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:48:38: Invalid CVAR pointer
L 02/20/2012 - 12:48:38: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:48:38: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:48:38: Invalid CVAR pointer
L 02/20/2012 - 12:48:38: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:48:38: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:49:12: Invalid CVAR pointer
L 02/20/2012 - 12:49:12: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:49:12: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:49:15: Invalid CVAR pointer
L 02/20/2012 - 12:49:15: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:49:15: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:49:36: Invalid CVAR pointer
L 02/20/2012 - 12:49:36: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:49:36: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:50:12: Invalid CVAR pointer
L 02/20/2012 - 12:50:12: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:50:12: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:54:58: Invalid CVAR pointer
L 02/20/2012 - 12:54:58: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:54:58: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 12:58:23: Invalid CVAR pointer
L 02/20/2012 - 12:58:23: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 12:58:23: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 13:09:36: Start of error session.
L 02/20/2012 - 13:09:36: Info (map "de_inferno") (file "addons/amxmodx/logs/error_20120220.log")
L 02/20/2012 - 13:09:36: Function "info" was not found
L 02/20/2012 - 13:09:36: [AMXX] Run time error 19 (plugin "vip.amxx") - debug not enabled!
L 02/20/2012 - 13:09:36: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 13:12:59: Invalid CVAR pointer
L 02/20/2012 - 13:12:59: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 13:12:59: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 02/20/2012 - 13:14:01: Invalid CVAR pointer
L 02/20/2012 - 13:14:01: [AMXX] Run time error 10 (plugin "vip.amxx") (native "get_pcvar_num") - debug not enabled!
L 02/20/2012 - 13:14:01: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).


Użytkownik Pietras11 edytował ten post 20.02.2012 13:22

  • +
  • -
  • 0

#7 forma

    Godlike

  • Power User

Reputacja: 198
Profesjonalista

  • Postów:487
  • Imię:Jakub
  • Lokalizacja:Piła
Offline

Napisano 20.02.2012 13:29

Zobacz to powitanie teraz powinno być okej i errologow też nie powinno być.

Załączone pliki


  • +
  • -
  • 1

#8 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 20.02.2012 13:59

Tak samo jest te same errory:/
Ta grawitacje i speeda możesz usunąć zbędne to jest:)

Użytkownik Pietras11 edytował ten post 20.02.2012 13:59

  • +
  • -
  • 0

#9 forma

    Godlike

  • Power User

Reputacja: 198
Profesjonalista

  • Postów:487
  • Imię:Jakub
  • Lokalizacja:Piła
Offline

Napisano 20.02.2012 14:15

Zobacz to.

Załączone pliki


  • +
  • -
  • 1

#10 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 20.02.2012 14:37

Kurcze nie działa:/ ale w logach czysto:) jest jednak ten sam error:/

Użytkownik Pietras11 edytował ten post 20.02.2012 14:38

  • +
  • -
  • 0

#11 forma

    Godlike

  • Power User

Reputacja: 198
Profesjonalista

  • Postów:487
  • Imię:Jakub
  • Lokalizacja:Piła
Offline

Napisano 20.02.2012 15:01

zobacz

Załączone pliki


  • +
  • -
  • 1

#12 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 20.02.2012 15:13

Działa all oprócz status VIP w tabeli wyników pomoże ktoś? dla formy +++

Użytkownik Pietras11 edytował ten post 20.02.2012 15:33

  • +
  • -
  • 0

#13 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 22.02.2012 06:40

Ref.
  • +
  • -
  • 0

#14 adamus81

    Profesjonalista

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:156
  • GG:
  • Imię:Adam
  • Lokalizacja:Konin
Offline

Napisano 22.02.2012 13:28

http://amxx.pl/topic...8-admin-vip-10/ Może to się przyda?
  • +
  • -
  • 1

#15 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 22.02.2012 17:00

Z tego co napisał Misieq działa tylko w CT i na spekcie:/ ale jest coraz bliżej :)
  • +
  • -
  • 0

#16 forma

    Godlike

  • Power User

Reputacja: 198
Profesjonalista

  • Postów:487
  • Imię:Jakub
  • Lokalizacja:Piła
Offline

Napisano 22.02.2012 17:07

eh ;d to wszystko związane z vipem w tabeli jakieś zbugowane jest ale jak tydzień temu testowałem plugin masło to działał.
http://amxx.pl/topic...s-vip-w-tabeli/
Tobie podobno nie działa ale sprawdź jeszcze raz.
  • +
  • -
  • 0

#17 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 22.02.2012 20:02

Wgrałem i Ct tylko widać:/
  • +
  • -
  • 0

#18 Pietras11

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 89
Zaawansowany

  • Postów:518
  • GG:
  • Steam:steam
  • Imię:Piotr
  • Lokalizacja:Gniezno
Offline

Napisano 22.02.2012 22:19

Jeśli nie ma innej możliwości można zamknąć ogólnie jak masło napisał raz widać raz nie ;)
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych