Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Plugin przenosi graczy z pełnego serwera na inny


  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 uszy1983pl

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • GG:
  • Lokalizacja:Jastrzebie Zdrój
Offline

Napisano 04.04.2008 16:10

Witam.

Mam plugin "simple_redirect" ale zamiast przenosić na inny serwer to wywala z tego pierwszego serwera ludzi:/

sma wygląda tak:

/* AMXX Mod Script 
* 
* Simple Redirection Plugin for AMXX 
* Orginal Code by Sonic (sonic@codet.de) 
* Modified and Made for AMXX by BigBaller 
* 
*  Place following cvars in server.cfg 
* 
*  amx_rd_maxplayers <16>             // - begin redirection when more the x ppl connected ( 0 = redirect all players ) 
*  amx_rd_server <ip serwa >                // - redirect to this server 
*  amx_rd_serverport <27106>          // - redirect server port 
*  amx_rd_serverpw <password>        // - password for the amx_rd_server (if needed) 
* 
* 
*  To Disable this plugin set amx_rd_maxppl to 33 or remove from plugins.ini 
*/ 

#include <amxmodx> 
#include <amxmisc> 

public plugin_init() { 
    register_plugin("Simple Redirect","1.0","BigBaller") 
    register_cvar("amx_rd_maxplayers","0") 
    
    register_cvar("amx_rd_server","") 
    register_cvar("amx_rd_serverport","") 
    register_cvar("amx_rd_serverpw","") 
} 

public client_connect(id){ 
    
    if(!is_user_admin(id)) 
    {    
        new rd_maxplayers = get_cvar_num("amx_rd_maxplayers") 
        new rd_serverport = get_cvar_num("amx_rd_serverport") 
        new rd_server[64], rd_serverpw[32] 
        get_cvar_string("amx_rd_server",rd_server,63) 
        get_cvar_string("amx_rd_serverpw",rd_serverpw,31) 
        if ( get_playersnum() >= rd_maxplayers) { 
            if ( !equal(rd_serverpw,"") ) 
                client_cmd(id,"echo ^"[AMXX] Simple Redirection - Set Password to %s^";password %s",rd_serverpw,rd_serverpw) 
            client_cmd(id,"echo ^"[AMXX] Simple Redirection -  Redirecting to %s:%d^";connect %s:%d",rd_server,rd_serverport,rd_server,rd_serverport) 
        } 
    } 
    return PLUGIN_CONTINUE 
} 

Czy wie ktoś co zrobić zeby działał ten plugin lub jakiś inny polecić co przenosi ludzi z pełnego serwera na drugi nasz serwer?
  • +
  • -
  • 0

#2 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 04.04.2008 16:21

Dodaj do serwer.cfg
amx_rd_maxplayers <18>              
amx_rd_server <85.25.152.150>            
amx_rd_serverport <27205>          
amx_rd_serverpw <password> - jak serwer nie ma hasła zostaw puste.
Napisałem to na przykładzie mojego serwera, IP: 85.25.152.150:27205

#3 uszy1983pl

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • GG:
  • Lokalizacja:Jastrzebie Zdrój
Offline

Napisano 04.04.2008 16:53

kurde dalej wywala wszystkich z serwera i nieidzie na niego wejść:( a na ten drugi nie przenosi

Pierwszy serwer mam na 16 slotów i często jest pełny i chce by na drugi serwer przenosiło który ma 12 slotów,plugin zainstalowałem na tym pierwszym serwie zmieniłem w sma i dopisałem to do serwer.cfg to w czym jest problem?
  • +
  • -
  • 0

#4 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 04.04.2008 17:04

uszy1983pl, w sma nic nie zmieniaj...

#5 uszy1983pl

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • GG:
  • Lokalizacja:Jastrzebie Zdrój
Offline

Napisano 05.04.2008 11:21

wywala cały czas z serwera na którym zainstalowany jest plugin
  • +
  • -
  • 0

#6 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 05.04.2008 11:23

uszy1983pl, pokaż logi serwera.

#7 bicek

    Ja tu tylko sprzątam.

  • Zbanowany

Reputacja: 914
Master

  • Postów:796
  • Lokalizacja:Wieluń
Offline

Napisano 05.04.2008 12:37

uszy1983pl, a jaki jest powód kicka?

#8 uszy1983pl

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • GG:
  • Lokalizacja:Jastrzebie Zdrój
Offline

Napisano 21.04.2008 22:28

sorki że nieodpisywałem ale miałem problemy z kompem.

Dzięki za odpowiedzi już wszystko ok.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych