Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

RS nie odtwarza piosenek


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
11 odpowiedzi w tym temacie

#1 LuQazz

    Zaawansowany

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:128
  • GG:
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Kobyłka
Offline

Napisano 21.12.2011 21:26

Witam, dziś mam następujący problem. Na serwer wgrałem plugin alt_end_round_sounds. Robię to nie pierwszy raz więc myślałem że pójdzie łatwo, jednak nie. Wgrałem pliki na serwer,plugin itd. Ustawiłem ścieżki piosenek w roundsound.ini, do amxx.cfg wpisałem następujące cvary:
ers_enabled "1"
ers_player_toggle "1"
erc_time_ads "240"
erc_random_precache "8”

Pliki ściągają się przy wejściu na serwer, lecz nie są odtwarzane. Są w formacie .wav. Gdy wpisuję w konsole
spk misc/nazwa.wav odtwarza się ale tylko w tym momencie.
Proszę mnie nie odsyłać do poradnika, czytałem już go kilka razy :)

W logach piszę że wczytano piosenki, ale po 3 na team, a w roundsound.ini wpisałem że po 4 na team.

Proszę o pomoc :)
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika

#2 Rob Zombie `

    Wszechpomocny

  • Użytkownik

Reputacja: 153
Profesjonalista

  • Postów:320
  • GG:
  • Imię:Paweł
  • Lokalizacja:Kozienice
Offline

Napisano 21.12.2011 21:59

a w roundsound.ini wpisałem że po 4 na team.


no to cvar:
erc_random_precache "8”
jest źle ustawiony

ustaw:
erc_random_precache "4-4”

  • +
  • -
  • 0

#3 LuQazz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:128
  • GG:
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Kobyłka
Offline

Napisano 21.12.2011 22:26

Nic nie zmieniło :/
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika

#4 Raitaa

    Zaawansowany

  • Użytkownik

Reputacja: 40
Pomocny

  • Postów:142
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Kwidzyn
Offline

Napisano 22.12.2011 11:57

korzystasz z wersji pluginu 2.3b?

spróbuj całkowicie usunąć ten cvar z amxx

erc_random_precache "8”

  • +
  • -
  • 0

b_350_20_118301_000000_FFFFFF_000000.png
 


#5 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 22.12.2011 12:47

ustaw:

erc_random_precache "4-4”


Jest źle ustawione. Wystarczy 4, a nie 4-4. Jeżeli jest o 1 piosenkę gdzieś więcej to wpisujemy 4-5, a nie 4-4.

UP@ Odpuść sobie już pisania tutaj, bo jak widzę Twoje rozwiązywanie problemów i podejście, to aż mi po prostu niedobrze.

P.S: Mogą być też źle skonwertowane piosenki.
erc_random_precache - tu nie wpisujemy całkowitą ilość piosenek, tylko tyle piosenek, ile występuje w teamie.

Pokaż roundsound.ini - tam powinna być ścieżka do piosenek CT/TT, a w amxx.cfg cvary.
Wywal również inne cvary, a pozostaw "erc_random_precache".

Użytkownik Nenczoks edytował ten post 22.12.2011 12:49


#6 LuQazz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:128
  • GG:
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Kobyłka
Offline

Napisano 22.12.2011 16:34

roundsound.ini:


; CT Sounds
"sound/misc/sw1z8.wav" "CT"
"sound/misc/sw2z8.wav" "CT"
"sound/misc/sw3z8.wav" "CT"
"sound/misc/sw4z8.wav" "CT"

; T Sounds
"sound/misc/sw5z8.wav" "T"
"sound/misc/sw6z8.wav" "T"
"sound/misc/sw7z8.wav" "T"
"sound/misc/sw8.wav" "T"

Wszystko wgrałem do misc.
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika

#7 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 22.12.2011 17:37

Nie no, jest dobrze. Wywal tak jak Ci pisałem wszystkie cvary odnośnie alt end round sounds, i dodaj taki: erc_random_precache "4”.
Jak nie zadziała, wówczas do konwertowania muzyka idzie. Jeżeli chcesz, wykonam to za Ciebie. Jedynie będzie trzeba nazwą lub lokalizację dźwięków zmienić.

P.S: Nie lepiej na mp3 Ci przerobić?

#8 LuQazz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:128
  • GG:
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Kobyłka
Offline

Napisano 22.12.2011 21:20

Przyzwyczaiłem się już do wav. Pokombinuję jeszcze.
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika

#9 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 22.12.2011 21:39

Wykonaj to, co napisałem i napisz o wyniku, a nie kombinujesz.

#10 LuQazz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:128
  • GG:
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Kobyłka
Offline

Napisano 22.12.2011 23:21

Zrobiłem tak jak poleciłeś. Oraz zmieniłem na mp3. Bez efektu, nadal to samo ;/
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika

#11 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 23.12.2011 00:13

Napisałem, że ja Ci to lepiej zrobię, więc mi daj te dźwięki.

#12 LuQazz

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:128
  • GG:
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Kobyłka
Offline

Napisano 23.12.2011 11:21

Konwertowałem dwoma programami, więc na pewno nie zrobisz nic innego co ja w tej chwili -.-
  • +
  • -
  • 0
Dołączona grafika
Dołączona grafika




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych