Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Przekierowanie ze starych adresów tematów


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 zryty

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:24
  • Imię:Krzysiek
  • Lokalizacja:Polska
Offline

Napisano 18.12.2011 13:58

Witam,
proponuję dodać przekierowanie ze starych formatów adresów, ponieważ dużo ich jest w postach i uciążliwe jest ich zmienianie. A wystarczy dodać w htaccess:
RewriteRule (.*)-t([0-9]+)\.html /topic/$2-$1/ [L,R=301]

Użytkownik zryty edytował ten post 18.12.2011 13:59

  • +
  • -
  • 1

#2 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 18.12.2011 17:43

RewriteRule (.*)-t([0-9]+)\.html /topic/$2-$1/ [L,R=301]


tak wyglądałoby to w apache ;>

dodałem dwie reguły:
rewrite ^/(.*)-t([0-9]+)\.html /topic/$2-$1/ permanent;
		rewrite ^/topics[0-9]*/(.*)-vt([0-9]+)\.htm$ /topic/$2-$1/ permanent;

efekt jest taki, że linki typu:

http://amxx.pl/spadochron-parachute-t20496.html
powinny zamienić się w
http://amxx.pl/topic/20496-spadochron-parachute/

Jeśli jeszcze jakiś link działa niepoprawnie daj znać
  • +
  • -
  • 0

#3 zryty

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:24
  • Imię:Krzysiek
  • Lokalizacja:Polska
Offline

Napisano 18.12.2011 18:37

To się tyczy też działów na forum, bo też jakoś inaczej były. U nas to po prostu stare reguły w IPB zrobiliśmy :P

//Po za tym nie wiem czemu, ale nie działa mi szybka odpowiedź... Kod błędu:
Uncaught exception: TypeError: Cannot convert 'ipb.textEditor.getEditor(ipb.topic.fastReplyId)' to object
Error thrown at line 1153, column 14 in (e) in http://amxx.pl/public/min/index.php?ipbv=32006&charset=UTF-8&f=public/js/ipb.js,cache/lang_cache/2/ipb.lang.js,public/js/ips.hovercard.js,public/js/ips.quickpm.js,public/js/ips.sharelinks.js,public/js/ips.textEditor.js,public/js/ips.topic.js,public/js/ips.like.js:
    var Post=ipb.textEditor.getEditor(ipb.topic.fastReplyId).getText();
called via Function.prototype.call() from line 5598, column 10 in (event) in https://ajax.googleapis.com/ajax/libs/prototype/1.7.0.0/prototype.js:
    handler.call(element, event);

Użytkownik zryty edytował ten post 18.12.2011 18:39

  • +
  • -
  • 0

#4 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 18.12.2011 19:26

//Po za tym nie wiem czemu, ale nie działa mi szybka odpowiedź... Kod błędu:


Próbowałeś z innej przeglądarki?
  • +
  • -
  • 0

#5 zryty

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:24
  • Imię:Krzysiek
  • Lokalizacja:Polska
Offline

Napisano 18.12.2011 19:42

Wybacz, ale korzystam z Opery i miło jak by na Operze działało...
  • +
  • -
  • 0

#6 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 18.12.2011 19:49

Wybacz, ale na innych przeglądarkach działa poprawnie, więc nie jest to wina skryptu, aczkolwiek jeśli chcesz polemizować na ten temat możesz otworzyć ticket w trackerze IPSu.

Na forum nie ma żadnych dodatków ingerujących w "szybką odpowiedź" a fakt jest taki, że opera sprawia przeróżne problemy, które rozwiązać można przesiadką na firefoxa lub chrome.
Pewnie nie takiej odpowiedzi się spodziewałeś, ale nic na to nie poradzę.
  • +
  • -
  • 0

#7 zryty

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:24
  • Imię:Krzysiek
  • Lokalizacja:Polska
Offline

Napisano 18.12.2011 19:53

U nas mamy identyczną wersje i wszystko działa poprawnie, nawet na operze :)
  • +
  • -
  • 0

#8 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 18.12.2011 19:59

dzieje się tak tylko na stylu Luminous, czy na stylu IP.Board również występuje ten 'błąd'?
  • +
  • -
  • 0

#9 zryty

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:24
  • Imię:Krzysiek
  • Lokalizacja:Polska
Offline

Napisano 18.12.2011 20:03

Ja właśnie korzystam ze stylu IPB, ale na tym drugim też nie działa.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych