Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Plugin nie czyta flag uprawnień [Przerobiony HugeBan]


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Egbert

    Pomocny

  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:70
  • GG:
  • Imię:Egbert
  • Lokalizacja:Gdańsk
Offline

Napisano 19.11.2011 22:31

Witam, plugin, którego używam działa niewłaściwie. To HugeBan po przeróbkach - dopisany w środek inny plugin odpowiedzialny za wyświetlanie osobnych informacji w HUD dla osób posiadających flagę t (ADMIN_LEVEL_H) i dla osób nieposiadających flagi t.

Problem polega na tym, że w momencie gdy jako admin posiadający wszystkie flagi wchodzę na serwer komunikat jest prawidłowy natomiast, gdy wchodzę jako użytkownik flag tz komunikat jest nieprawidłowy (taki jak dla graczy z domyślną flagą z). Dodam, że flagi są przypisane do usera - w amx_who sprawdzałem.

to jest sma:
Załączony plik  hugeban2.sma   7,87 KB  10 Ilość pobrań
  hugeban2.amxx
Dodam, że próbowałem różnych rozwiązań np. bez 'else' a z negacją if

Bardzo mnie to denerwuje, już tydzień nad tym siedzę i już mi się w głowie merda... Gdyby ktoś z Was mógłby zerknąć o co w tym wszystkim chodzi...

Aha po kompilacji mam 4 warny:
Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team
hugeban2.sma(30) : warning 217: loose indentation
hugeban2.sma(41) : warning 217: loose indentation
hugeban2.sma(127) : warning 217: loose indentation
hugeban2.sma(236) : warning 217: loose indentation
Header size:		   1120 bytes
Code size:			13124 bytes
Data size:			 5624 bytes
Stack/heap size:	  16384 bytes; estimated max. usage=847 cells (3388 bytes)
Total requirements:   36252 bytes
4 Warnings.
Done.

CHYBA POMYLIŁEM DZIAŁ > PROSZĘ O PRZENIESIENIE.
Hiroshima (19.11.2011 22:35):
Kod powyżej 200 linijek dajemy jako załącznik lub na wklejkę.
24h na poprawę

Użytkownik Egbert edytował ten post 19.11.2011 22:43

  • +
  • -
  • -1

#2 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 19.11.2011 22:36

Automatyczna wiadomość


Ten temat został przeniesiony z forum:
AMX Mod XProblemy
do
Scripting AMXXProblemy


  • +
  • -
  • 0

#3 Egbert

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:70
  • GG:
  • Imię:Egbert
  • Lokalizacja:Gdańsk
Offline

Napisano 21.11.2011 13:59

próbowałem już tak:
public client_putinserver(id){
if(has_flag(id, "t")) {
new gcvarOpoznienie = register_cvar("info_opoznienie","30",0,30.0)
new Float:fTime = get_pcvar_float(gcvarOpoznienie)
set_task(fTime, "showInfo2",id+TASKID_INFO)
}
else{
new gcvarOpoznienie = register_cvar("info_opoznienie","30",0,30.0)
new Float:fTime = get_pcvar_float(gcvarOpoznienie)
set_task(fTime, "showInfo",id+TASKID_INFO)
}
}
gdy gracz jest nieznany (z flagą "z") pokazuje dobrze
gdy gracz jest znany (z flagą "tz") pokazuje złą informację
gdy gracz jest adminem pokazuje dobrą informację

Nic z tego nie rozumiem... czemu adminowi pokazuje dobrze a graczowi z "tz" źle...
Bardzo proszę o pomoc nie mam pojęcia jak to naprawić. Już odchodzę od zmysłów :(
  • +
  • -
  • 0

#4 QuahodronN

    Godlike

  • Power User

Reputacja: 228
Wszechwidzący

  • Postów:1262
  • GG:
  • Steam:steam
  • Imię:Olo
  • Lokalizacja:Śląsk
Offline

Napisano 21.11.2011 16:16

gdy dajesz komuś flagę "t" to po co "z"?
  • +
  • -
  • 0

| CPU: I7-6700K @4.7GHz | Cooling: Corsair H110 | GPU: MSI GTX 1080 Gaming X | MOBO: Asus Maximus VIII Hero | RAM: Kingston Savage 16GB DDR4 @2800MHz |

| SSD: Samsung 840 Pro 128GB | SSD2: Samsung 840 Pro 256GB  |  PSU: Be Quiet L8 630W | Case: Gladius M40 | Mouse: Gigabyte M6980X | Keyboard: Sharkoon SHARK ZONE K20 Headphones: HyperX HX Cloud Black Display: Triple LG 24MP67VQ-P |

 

TS3: ts.kreedzmania.pl - 512 Slotów - Darmowe Kanały ;)


#5 Egbert

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:70
  • GG:
  • Imię:Egbert
  • Lokalizacja:Gdańsk
Offline

Napisano 21.11.2011 17:13

Bo to nie jest admin. Tak było w instrukcji Hugeban'a. Sprawdzę jak jest na samej fladze t.

EDIT:
Pomino zmiany flag userów na samą "t", nie ma różnicy.
nawet zmieniłem na
if(access(id,ADMIN_LEVEL_H))
nic się nie zmieniło.

EDIT2:
Wzorując się na tym co napisano w dokumentacji:
if(access(id,ADMIN_LEVEL_C))
		 client_print(id,print_chat,\"TAK\")
else
		 client_print(id,print_chat,\"NIE\")
:facepalm: Pomocy!

Użytkownik Egbert edytował ten post 21.11.2011 19:16

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych