Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problemy z językiem


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
Brak odpowiedzi do tego tematu

#1 LebeX

    Zaawansowany

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:82
  • Imię:Tomek
  • Lokalizacja:Podkarpackie
Offline

Napisano 16.11.2011 10:10

Witajcie
Od zawsze mam problem z wyświetlaniem komunikatów z jakimkolwiek języku.
W amxx-cfg mam wpisy:
amx_client_languages 1
amx_debug 2
amx_mldebug "pl"
amx_langmenu "pl"

Potem w logach widzę, że niby pluginy nie odnajdują właściwego tłumaczenia dla konkretnych fraz.
L 11/15/2011 - 20:21:04: [AMXX] Language key "MSG_FREQ" not found for language "pl", check "scrollmsg.amxx"
L 11/15/2011 - 20:31:01: [AMXX] Language key "SPE_MENU" not found for language "pl", check "cmdmenu.amxx"
L 11/15/2011 - 20:32:44: [AMXX] Language key "TYPE_LANGMENU" not found for language "pl", check "multilingual.amxx"
L 11/15/2011 - 20:40:02: [AMXX] Language key "YOU_RE_NOT_RANKED" not found for language "pl", check "ps3stats.amxx"
L 11/15/2011 - 21:02:48: [AMXX] Language key "NOMINATE_MAP" not found for language "pl", check "mapchooser4.amxx"
Przeglądając całe logi wydaje się, że błędy wywala na losowych pluginach i losowych wyrażeniach. Zmieniłem potem wpisy a amxx.cfg na amx_mldebug "en" i oto co widzę teraz w logach:

L 11/15/2011 - 01:40:52: [AMXX] Language key "MSG_FREQ" not found for language "en", check "scrollmsg.amxx"
L 11/15/2011 - 01:40:52: [AMXX] Language key "SQL_LOADED_REASONS" not found for language "en", check "amxbans_main.amxx"
L 11/15/2011 - 03:34:26: [AMXX] Language key "RTV_MAP" not found for language "en", check "mapchooser4.amxx"
L 11/15/2011 - 03:39:27: [AMXX] Language key "NOMINATE_MAP" not found for language "en", check "mapchooser4.amxx"
L 11/15/2011 - 03:42:43: [AMXX] Language key "NOMINATE_MAP" not found for language "en", check "mapchooser4.amxx"

Są to wyrywkowe logi. Oczywiście wszystkie pliki txt mam wrzucone do katalogu data w amxmodx, sprawdzałem poszczególne linijki i tłumaczenia się zgadzają i są na swoich miejscach.
Proszę o pomoc.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych