Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Spadochron - Grawitacja po uzyciu


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Plax

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:75
  • Lokalizacja:Złotów
Offline

Napisano 23.01.2009 11:35

Witam,
Uzywam na moim serwerze Zombie Plague mod, z różnymi klasami zombie i gdy np. dana klasa ma 50% grawitacji, to po użyciu spadochronu będzie miała spowrotem 800 grawitacji. Czy jest to możliwe, aby ustawić, że po użyciu spadochronu grawitacja nie wraca do 800, ale do poprzedniej jaką się miało?
W załączniku jest plik .sma
Bardzo proszę o pomoc

Z góry dziękuję!

Pozdrawiam,
Plax

Załączone pliki


  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 23.01.2009 11:45

Robione w notatniku ale powinno być dobrze xD

Załączone pliki


  • +
  • -
  • 0

#3 Plax

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:75
  • Lokalizacja:Złotów
Offline

Napisano 23.01.2009 14:46

Nie działa tak jak powinno :
Po użyciu spadochronu grawitacja drastycznie się zmniejsza, nawet gdy jestes człowiekiem, nie wraca do poprzedniej ;f
  • +
  • -
  • 0

#4 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 23.01.2009 16:23

user_grav[id]=get_user_gravity(id)
set_user_gravity(id, 0.1)

przed zmiana gravitacji na 0.1 pobiera ja do tablicy. Przy zmianie z powrotem uzywa tej tablicy (all po id idzie). Skoro nie dziala to nie bardzo wiem co robic ;>
  • +
  • -
  • 0

#5 Plax

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:75
  • Lokalizacja:Złotów
Offline

Napisano 23.01.2009 16:50

Teraz jest tak, że gdy używasz spadochronu jest normalnie, a po użyciu jest 0.1...
  • +
  • -
  • 0

#6 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 23.01.2009 17:00

nie wiem jakie beda efekty uboczne tego, ale powinno zabezpieczyc przezd w/w bledem.

Załączone pliki


  • +
  • -
  • 0

#7 Plax

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:75
  • Lokalizacja:Złotów
Offline

Napisano 23.01.2009 19:31

Żadnych efektów ubocznych, wszystko pięknie śmiga! Dzięki wielkie! +pomógł :)

Temat do zamknięcia :)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych