Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

errory- silnik CoDa

CoD Nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
2 odpowiedzi w tym temacie

#1 ewciak

    Pomocny

  • Girl

Reputacja: 14
Początkujący

  • Postów:54
  • Steam:steam
  • Imię:Ewelina
  • Lokalizacja:Warszawa
Offline

Napisano 20.10.2011 10:40

Witam,
Mam taki problem:
W error logach od bardzo długiego czasu ciągle loguje mi się taki błąd:

L 10/18/2011 - 17:57:28: Start of error session.
L 10/18/2011 - 17:57:28: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20111018.log")
L 10/18/2011 - 17:57:28: [FAKEMETA] Undefined pev index: 255
L 10/18/2011 - 17:57:28: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 10/18/2011 - 17:57:28: [AMXX] Run time error 10: native error (native "set_pev")
L 10/18/2011 - 17:57:28: [AMXX]    [0] QTM_CodMod.sma::MessageHealth (line 438)

Obecnie dodałam debug do QTM_CodMod.sma ale wcześniej ten błąd też występował.
Dziś dodałam tą modyfikację http://amxx.pl/topic/62492-hp-w-hud/ więc ilość hp już mi się pokazuje prawidłowo w hud

Proszę o pomoc w naprawieniu tego błędu

Miał ktoś kiedyś taki problem ??

Załączone pliki


  • +
  • -
  • 0
Dołączona grafika

Dołączona grafika

#2 Muzzi

    Guru

  • Przyjaciel

Reputacja: 226
Wszechwidzący

  • Postów:772
  • Lokalizacja:Kraków
Offline

Napisano 20.10.2011 17:46

@Edit

Sprawdź to


public MessageHealth(msg_id, msg_dest, msg_entity)
{
new health = get_msg_arg_int(1);

if(health < 256)
return;

if (!(health % 256))
set_msg_arg_int(1, get_msg_argtype(1), 255);
}

Użytkownik Muzzi edytował ten post 20.10.2011 17:55

  • +
  • -
  • 0

#3 M3nt0s

    Życzliwy

  • Zbanowany

Reputacja: 1
Nowy

  • Postów:28
  • Imię:SM
  • Lokalizacja:Ass
Offline

Napisano 25.11.2011 17:20

Usuń całkowicie z silnika funkcję MessageHealth i wgraj ten plugin:
http://speedy.sh/W5rNf/hpbug.sma





Również z jednym lub większą ilością słów kluczowych: CoD Nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych