Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Czemu to nie działa?


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 SadistiC

    Pomocny

  • Zbanowany

Reputacja: 8
Nowy

  • Postów:57
  • GG:
  • Imię:Bartłomiej
  • Lokalizacja:Czersk
Offline

Napisano 14.10.2011 15:04

Witam. Mam problem z pluginem, którego sam pisałem od podstaw.
A chodzi Mi o ten plugin:
#include <amxmodx>
#include <amxmisc>
#define PLUGIN "Pokazuj MOTD"
#define VERSION "1.0"
#define AUTHOR "SadistiC. #"

public plugin_init() {
register_plugin(PLUGIN, VERSION, AUTHOR)
register_clcmd("say /komendy", "komendy")
register_clcmd("say /regulamin", "regulamin")
register_clcmd("say /admini", "admini")
register_clcmd("say /vip", "vip")
register_clcmd("say /mapy", "mapy")
register_clcmd("say /kontakt", "kontakt")
}

public komendy(id)
{
show_motd(id, "komendy.txt", "Komendy dostepne na serwerze.")
}

public regulamin(id)
{
show_motd(id, "regulamin.txt", "Regulamin serwera.")
}

public admini(id)
{
show_motd(id, "admini.txt", "Lista adminow.")
}

public vip(id)
{
show_motd(id, "vip.txt", "Przywileje VIPa.")
}

public mapy(id)
{
show_motd(id, "mapy.txt", "Lista map na serwerze.")
}

public kontakt(id)
{
show_motd(id, "kontakt.txt", "Kontakt z Head Adminem serwera.")
}

Po wpisaniu na say: /regulamin i /komendy wszystko się pięknie pojawia, lecz po wpisaniu na say: /admini , /mapy , /kontakt lub /vip nic się nie wyświetla.

Co jest źle zrobione?

Użytkownik SadistiC edytował ten post 14.10.2011 15:37


#2 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 14.10.2011 16:24

Co jest źle zrobione?


nic, wszystko w tym kodzie jest dobrze.
pewnie nie stworzyłeś plików w cstrike kontakt.txt, mapy.txt, admini.txt, mapy.txt
  • +
  • -
  • 0

#3 SadistiC

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 8
Nowy

  • Postów:57
  • GG:
  • Imię:Bartłomiej
  • Lokalizacja:Czersk
Offline

Napisano 16.10.2011 09:41

Dobra, wszystko działa... Mój błąd...

Do zamknięcia!

#4 Hiroshima

    Godlike

  • Administrator

Reputacja: 1312
Godlike

  • Postów:4968
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Málaga
Offline

Napisano 16.10.2011 10:04

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych